Hurricane Electric's IPv6 Tunnel Broker Forums

General IPv6 Topics => IPv6 on Linux & BSD & Mac => Topic started by: macsavvyit on May 14, 2008, 09:30:14 AM

Title: GUI guide for Configuring a tunnel under *BSD & MacOS X
Post by: macsavvyit on May 14, 2008, 09:30:14 AM
The command line instructions are over my head for setting up IPv6 on OS X Leopard. They lack a GUI version. I will begin a step by step setup GUI guide for Mac users with Airport Extreme base Stations. Please add to this post by contributing to it's completion/accuracy.

1. Register and obtain your IPv6 address by providing your EXTERNAL IPv4 address (even if your address is dynamic)
Get your external IPv4 address by surfing to http://whatsmyipaddress.com

2. View Tunnel Details and extract your IPv6 address from "Client IPv6 address:"

3. Enter this address into the Airport Utility (found in your Utilities inside your Applications folder) "Advanced" Tab's IPv6 sub-tab after you have selected Node (not tunnel) and Configure IPv6 "Manually." For the field, "Local IPv6 Address:" Enter your client IPv6 address as provided in your Tunnel Details. Leave the prefix length in the next field set to 0

4. Reboot your base station and make sure your Leopard equipped Mac has IPv6 set up as automatic in the Network Preferences of your active network connection.

Ok folks, this did not work for me so fix the above GUI instructions so those of us who are not comfortable with Terminal (or who noticed that there were commands missing, preventing us from employing the NetBSD command instructions) can get this done with a minimum of pain.
Title: GUI guide for Configuring a tunnel under *BSD & MacOS X
Post by: jimb on June 10, 2009, 05:58:41 PM
FYI:  http://ip4.me and http://ip6.me work well too, and are faster to type.  :)
Title: GUI guide for Configuring a tunnel under *BSD & MacOS X
Post by: NTICompass on October 27, 2009, 08:01:36 PM
Shouldn't prefixlen be 64, and not 128?
Title: GUI guide for Configuring a tunnel under *BSD & MacOS X
Post by: broquea on October 27, 2009, 08:43:58 PM
Shouldn't prefixlen be 64, and not 128?

Try it and see if it works. It didn't as of testing with 6.2 or 6.3 or 7.x. Maybe it'll work with 8.0
Title: GUI guide for Configuring a tunnel under *BSD & MacOS X
Post by: jimb on October 28, 2009, 04:03:58 AM
Wrong thread?  This one is from June! :P