Hurricane Electric's IPv6 Tunnel Broker Forums

General IPv6 Topics => IPv6 on Windows => Topic started by: maguirre on March 14, 2012, 09:31:59 AM

Title: Problem connecting to HE Tunnel in Windows but not in Linux
Post by: maguirre on March 14, 2012, 09:31:59 AM
Hello everyone I have searched this forums trying to find a solution to the same problem that a lot of people are having

I am unable to ping ipv6.google.com or even the end point of the tunnel  (2001:470:1f10:1362::1).

I am running a Windows 7 x64 machine and I am trying to setup a tunnel.

I am behind a NAT however I know my router (Linksys running DD-WRT) doesn't block proto == 41 because I have a Virtual machine running ubuntu that doesn't have issues connecting to my HE tunnel


Any idea of what I am doing wrong?


For reference I have used the following commands



Code: [Select]
netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel IP6Tunnel 192.168.1.111 209.51.181.2
netsh interface ipv6 add address IP6Tunnel 2001:470:1f10:1362::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f10:1362::1

my ipconfig is as follows:

Code: [Select]
Windows IP Configuration


Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : myhome.westell.com
   IPv6 Address. . . . . . . . . . . : 2001:470:1f11:1362::2
   Link-local IPv6 Address . . . . . : fe80::8417:e32d:f36c:e54b%15
   IPv4 Address. . . . . . . . . . . : 192.168.1.111
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::f46d:7d88:32af:f9fd%25
   IPv4 Address. . . . . . . . . . . : 192.168.78.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::3d88:3a51:bd81:9b04%26
   IPv4 Address. . . . . . . . . . . : 192.168.2.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Tunnel adapter isatap.myhome.westell.com:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : myhome.westell.com

Tunnel adapter IP6Tunnel:

   Connection-specific DNS Suffix  . : myhome.westell.com
   IPv6 Address. . . . . . . . . . . : 2001:470:1f10:1362::2
   Link-local IPv6 Address . . . . . : fe80::64dd:885a:c78c:b86b%11
   Default Gateway . . . . . . . . . : 2001:470:1f10:1362::1

Tunnel adapter isatap.{0CAC2F68-A59E-47EF-9A9F-57FE102FA177}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{DF49A3DE-3CBF-4080-A406-C908F01ABCDB}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Title: Re: Problem connecting to HE Tunnel in Windows but not in Linux
Post by: cholzhauer on March 14, 2012, 10:06:48 AM
I'd suggest this first: (this won't fix your problem)

Code: [Select]
netsh int ipv6 isatap set state disabled
netsh int ipv6 6to4 set state disabled

You say your router is passing proto41...how did you tell it to do that?  I ask because maybe you had to specify an IP to allow traffic to and the IP on your windows machine is different than your Ubuntu machine
Title: Re: Problem connecting to HE Tunnel in Windows but not in Linux
Post by: maguirre on March 14, 2012, 10:46:23 AM
Thanks for your response.

I didn't need need to configure anything except turn off DMZ after that my Ubuntu VM tunnel just worked using the HE instructions


Melvin