Hurricane Electric's IPv6 Tunnel Broker Forums

General IPv6 Topics => IPv6 on Routing Platforms => Topic started by: samip on June 27, 2014, 10:41:31 PM

Title: OpenWRT on TP-Link TL-WR1043ND V1 & Asus RT-N56U providing IPV6
Post by: samip on June 27, 2014, 10:41:31 PM
Hi everyone,

I'm not sure how can I give you the best picture of my setup currently, but:

Cable Modem  -> Asus RT-N56U -> TP-Link TL-WR1043ND running OpenWRT

Info about the modem:

Info about ASUS:

Info about TP-Link:

/etc/config/network:


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fc84:7776:ec49::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option accept_ra '1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5t'



/etc/config/firewall:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option drop_invalid '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config include
        option path '/etc/firewall.user'


ifconfig:
br-lan    Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fc84:7776:ec49::1/64 Scope:Global
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17716 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24214 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1930019 (1.8 MiB)  TX bytes:26053279 (24.8 MiB)

eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:92378 errors:0 dropped:8 overruns:3412 frame:0
          TX packets:90912 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:70916744 (67.6 MiB)  TX bytes:70705774 (67.4 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17716 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24214 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1930019 (1.8 MiB)  TX bytes:26053279 (24.8 MiB)

eth0.2    Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          inet addr:192.168.1.14  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6666:b3ff:fefa:1d80/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:55836 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34943 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:65693033 (62.6 MiB)  TX bytes:3642740 (3.4 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:70 errors:0 dropped:0 overruns:0 frame:0
          TX packets:70 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6488 (6.3 KiB)  TX bytes:6488 (6.3 KiB)


List of installed packages:

6to4 - 12-1
base-files - 154-r41353
busybox - 1.22.1-1
dnsmasq - 2.71-3
dropbear - 2014.63-1
firewall - 2014-06-26
fstools - 2014-06-22-e0430f5c62f367e5a8e02755412977b02c3fc45e
hostapd-common - 2014-06-03-1
ip6tables - 1.4.21-1
iptables - 1.4.21-1
iputils-traceroute6 - 20101006-1
iw - 3.15-1
iwinfo - 49
jshn - 2014-06-24-39a8fae44186c074265482a09eaa8465334f8183
jsonfilter - 2014-06-19-cdc760c58077f44fc40adbbe41e1556a67c1b9a9
kernel - 3.10.44-1-ce8f8daeadc723677dec701bf65a8e0a
kmod-ath - 3.10.44+2014-05-22-1
kmod-ath9k - 3.10.44+2014-05-22-1
kmod-ath9k-common - 3.10.44+2014-05-22-1
kmod-cfg80211 - 3.10.44+2014-05-22-1
kmod-crypto-aes - 3.10.44-1
kmod-crypto-arc4 - 3.10.44-1
kmod-crypto-core - 3.10.44-1
kmod-gpio-button-hotplug - 3.10.44-1
kmod-ip6tables - 3.10.44-1
kmod-ipt-conntrack - 3.10.44-1
kmod-ipt-core - 3.10.44-1
kmod-ipt-nat - 3.10.44-1
kmod-ipt-nathelper - 3.10.44-1
kmod-iptunnel - 3.10.44-1
kmod-iptunnel4 - 3.10.44-1
kmod-ipv6 - 3.10.44-1
kmod-ledtrig-usbdev - 3.10.44-1
kmod-lib-crc-ccitt - 3.10.44-1
kmod-mac80211 - 3.10.44+2014-05-22-1
kmod-nls-base - 3.10.44-1
kmod-ppp - 3.10.44-1
kmod-pppoe - 3.10.44-1
kmod-pppox - 3.10.44-1
kmod-sit - 3.10.44-1
kmod-slhc - 3.10.44-1
kmod-usb-core - 3.10.44-1
kmod-usb-ohci - 3.10.44-1
kmod-usb2 - 3.10.44-1
libblobmsg-json - 2014-06-24-39a8fae44186c074265482a09eaa8465334f8183
libc - 0.9.33.2-1
libdaemon - 0.14-3
libgcc - 4.8-linaro-1
libip4tc - 1.4.21-1
libip6tc - 1.4.21-1
libiwinfo - 49
libiwinfo-lua - 49
libjson-c - 0.11-2
libjson-script - 2014-06-24-39a8fae44186c074265482a09eaa8465334f8183
liblua - 5.1.5-1
libncurses - 5.9-1
libnl-tiny - 0.1-3
libubox - 2014-06-24-39a8fae44186c074265482a09eaa8465334f8183
libubus - 2014-05-24-3869e0ca0774e8f17597db5b60bee97d21b5b1fa
libubus-lua - 2014-05-24-3869e0ca0774e8f17597db5b60bee97d21b5b1fa
libuci - 2014-04-11.1-1
libuci-lua - 2014-04-11.1-1
libxtables - 1.4.21-1
lua - 5.1.5-1
luci - svn-r10375-1
luci-app-firewall - svn-r10375-1
luci-base - svn-r10375-1
luci-lib-nixio - svn-r10375-1
luci-mod-admin-full - svn-r10375-1
luci-proto-ipv6 - svn-r10375-1
luci-proto-ppp - svn-r10375-1
luci-theme-bootstrap - svn-r10375-1
mtd - 20
nano - 2.3.4-1
netifd - 2014-06-20-4452867c4b34cb0d9dc7fe9dc42ecc86af887176
odhcp6c - 2014-06-04-26c5466e626735f27dd073b727b02612c5a807cd
odhcpd - 2014-06-18-82f3096351911d8c4f3b38e7a5bbeaf75938b6b8
opkg - 9c97d5ecd795709c8584e972bfdf3aee3a5b846d-7
ppp - 2.4.6-1
ppp-mod-pppoe - 2.4.6-1
procd - 2014-06-19-8e12022c3d00f8acca4471016d71794988113c34
radvd - 1.9.1-2
swconfig - 10
terminfo - 5.9-1
uboot-envtools - 2014.04-3
ubox - 2014-05-28-1c2a9c1cbe9d18bf342edfa617eff319c1d3ce3a
ubus - 2014-05-24-3869e0ca0774e8f17597db5b60bee97d21b5b1fa
ubusd - 2014-05-24-3869e0ca0774e8f17597db5b60bee97d21b5b1fa
uci - 2014-04-11.1-1
uhttpd - 2014-06-11-dabd7dea6445aaa0e5b8d9add1872fa7393b3a85
uhttpd-mod-ubus - 2014-06-11-dabd7dea6445aaa0e5b8d9add1872fa7393b3a85
wpad-mini - 2014-06-03-1


I don't know how can I get an prefix from the ASUS router and then advertise it on TP-Link's local network.

Any ideas?