Hurricane Electric's IPv6 Tunnel Broker Forums

Please login or register.

Login with username, password and session length
Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: [SOLVED] OpenWRT: IPv6 MTU problem, routing slow, packet loss  (Read 4140 times)

lorenzoz

  • Newbie
  • *
  • Posts: 9
    • View Profile
[SOLVED] OpenWRT: IPv6 MTU problem, routing slow, packet loss
« on: September 11, 2010, 04:04:36 PM »

I have been experiencing for a few months a strange problem with the IPv6 tunnel on my OpenWrt router.
My configuration is:
Linux 2.6.30.10 (MIPS)
Radvd 1.5-1

The IPv4 connection (ADSL2) is at about 10Mbps (MegaBITpersecond)
I have made some test with a file (700MByte) hosted on a remote server (with low-latency and no bandwidth problem).

The router establishs the ipv6 tunnel to tunnelbroker with the "ip" utility and shares the tunnel with the internal network, about ten devices via wifi and lan.
If i download the file directly from the router, i get a speed of about 7-8Mbps, but if i download the file from any pc of the internal network, i get a very slow speed.. about 20Kbps (less then 1KB/s).
To debug it I removed any ip6tables rule (ACCEPT/ACCEPT/ACCEPT) and i found that there isn't any cpu/ram overload.
Obviously i have rebooted the router many times, with no result
Thanks in advance for any help


[EDIT] maybe a MTU problem? now the ADSLv4 is 1460, the internal network is 1500, the ipv6 tunnel is 1440
« Last Edit: September 12, 2010, 07:24:31 AM by lorenzoz »
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2236
    • View Profile
Re: OpenWRT: IPv6 routing very slow
« Reply #1 on: September 11, 2010, 04:49:51 PM »

what's the load on the system if you leave the firewall enabled?

I can't imagine that's a problem though.

Have you tried changing the MTU?
Logged

lorenzoz

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: OpenWRT: IPv6 routing very slow
« Reply #2 on: September 12, 2010, 02:59:09 AM »

the load with firewall enabled is always under 0.4
now i'll try to change the mtu but the fact is that i haven't always had this problem, it started some months ago, and the only configuration i changed was the ip6 firewall (i set some per-ip forwarding rules and allowed the forwarding of any RELATED,ESTABLISHED from the tunnel to the internal network)
However if I ping an external host from any computer i get always latency under 100ms, so i will also try if i have the same problem with udp connections

[EDIT]: I have run Wireshark on my client to try to debug this issue, i found that during a TCP session there are many [TCP Previous segment lost] [TCP Retrasmission]. And it seems that the router before forwarding ANY packet sends a "Neighbor Solicitation" to the client and forward the packet only after it receives a "Neighbor Advertisement" from the client".. i don't know it this is the standard behavior of ipv6, i think not, maybe some problem with the ip neigh tables or ttl? If i watch the "ip -6 neigh" table of my router i see that often during a download the entry of my router goes to "DELAY" and then again to "REACHABLE". IPv4 networking doesn't have any problem and the client is connected directly to the router with a 100Mbps Ethernet cable.

[EDIT2]: Direct transfer client <=> router does not suffer any problem


[EDIT3]: Solved with AdvLinkMTU '1440' in radvd conf
« Last Edit: September 12, 2010, 07:25:44 AM by lorenzoz »
Logged