Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Pages: 1 [2]

Author Topic: [SOLVED] IPv6 eMail Test not working (with hmail setup).  (Read 12573 times)

vivow

  • Newbie
  • *
  • Posts: 16
Re: IPv6 eMail Test not working (with mercury setup).
« Reply #15 on: January 11, 2011, 09:54:50 AM »

Yes, the is only one persistant route left which points to the ::1 server and belongs to the IP6Tunnel

for testings sake, i also enabled router discovery both for the ip6tunnel and nic and i also published the ip6tunnel route.

here the two tables again with their current status
Code: [Select]
C:\Windows\system32>netstat -rn
===========================================================================
Interface List
 20...00 ff da 85 0e 8d ......Anchorfree HSS Adapter
 11...00 23 5a 4e 77 bc ......Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Contro
ller
  1...........................Software Loopback Interface 1
 13...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
 14...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #2
 26...00 00 00 00 00 00 00 e0 Microsoft Direct Point-to-point Adapater
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0    77.20.231.254     77.20.229.35     20
      77.20.228.0    255.255.252.0         On-link      77.20.229.35    276
     77.20.229.35  255.255.255.255         On-link      77.20.229.35    276
    77.20.231.255  255.255.255.255         On-link      77.20.229.35    276
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link      77.20.229.35    276
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link      77.20.229.35    276
===========================================================================
Persistent Routes:
  None

IPv6 Route Table
===========================================================================
Active Routes:
 If Metric Network Destination      Gateway
 26    281 ::/0                     2001:470:1f0a:316::1
  1    306 ::1/128                  On-link
 26    281 2001:470:1f0a:316::/64   On-link
 26    281 2001:470:1f0a:316::2/128 On-link
 11    276 2001:470:1f0b:316::/64   On-link
 11    276 2001:470:1f0b:316::5/128 On-link
 26    281 fe80::/64                On-link
 11    276 fe80::/64                On-link
 11    276 fe80::59cb:da5d:566:b508/128
                                    On-link
 26    281 fe80::999a:30c3:25ec:eee7/128
                                    On-link
  1    306 ff00::/8                 On-link
 26    281 ff00::/8                 On-link
 11    276 ff00::/8                 On-link
===========================================================================
Persistent Routes:
 If Metric Network Destination      Gateway
  0 4294967295 ::/0                     2001:470:1f0a:316::1
===========================================================================

ipconfig
Code: [Select]
C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : vivow-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection* 15:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Anchorfree HSS Adapter
   Physical Address. . . . . . . . . : 00-FF-DA-85-0E-8D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Atheros AR8121/AR8113/AR8114 PCI-E Ethern
et Controller
   Physical Address. . . . . . . . . : 00-23-5A-4E-77-BC
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:470:1f0b:316::5(Preferred)
   Link-local IPv6 Address . . . . . : fe80::59cb:da5d:566:b508%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 77.20.229.35(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.252.0
   Lease Obtained. . . . . . . . . . : Tuesday, January 11, 2011 6:50:19 PM
   Lease Expires . . . . . . . . . . : Tuesday, January 11, 2011 8:01:54 PM
   Default Gateway . . . . . . . . . : 77.20.231.254
   DHCP Server . . . . . . . . . . . : 83.169.184.130
   DHCPv6 IAID . . . . . . . . . . . : 234890074
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-A5-FA-E9-00-23-5A-4E-77-BC

   DNS Servers . . . . . . . . . . . : 83.169.184.161
                                       83.169.184.225
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{DA850E8D-5FF3-4368-9375-BBD96AC44396}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{D672CF71-F6DD-478A-9E30-C85FFF79573E}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter IP6Tunnel:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Direct Point-to-point Adapater
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:470:1f0a:316::2(Preferred)
   Link-local IPv6 Address . . . . . : fe80::999a:30c3:25ec:eee7%26(Preferred)
   Default Gateway . . . . . . . . . : 2001:470:1f0a:316::1
   DNS Servers . . . . . . . . . . . : 83.169.184.161
                                       83.169.184.225
   NetBIOS over Tcpip. . . . . . . . : Disabled

thanks again for all your help so far.
« Last Edit: January 11, 2011, 02:13:27 PM by vivow »
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2671
Re: IPv6 eMail Test not working (with mercury setup).
« Reply #16 on: January 11, 2011, 10:02:52 AM »

Well that didn't work..I can't ping your side of the tunnel now.

Oh...It just hit me.  You don't have a default IPv6 gateway for your LAN connection

Logged

vivow

  • Newbie
  • *
  • Posts: 16
Re: IPv6 eMail Test not working (with mercury setup).
« Reply #17 on: January 11, 2011, 10:10:17 AM »

I thought I only should have one Persistant route, which is the IP6Tunnel one. Having both didnt work before.
As soon as I can directly connect back to my modem (other people wanna use this net too some time :D ), I will reset everything and build it from the ground up.


: Ok, so even with everything built from the ground up I can only use my client ::2 adress.
Maybe it doesnt even work with only one NIC on a machine and i'd have to get a second box to do the trick.
« Last Edit: January 11, 2011, 11:41:00 AM by vivow »
Logged

vivow

  • Newbie
  • *
  • Posts: 16
Re: IPv6 eMail Test not working (with mercury setup).
« Reply #18 on: January 11, 2011, 12:01:44 PM »

Quick update:

I fell back to option #1, doing everything with my ::2 Client IP, since that almost worked before (except for the "unexpected welcome" error when sending the message).
After some fine tuning in Hmail, which didnt really change anything, magic happened and it worked \o/

for solution: Re-edited the Hmail settings according to this http://www.hmailserver.com/documentation/latest/?page=details_ipv6
The turning point was: "In the IP range, choose the same settings as in the already existing Internet IP range. [...]"
I had IMAP turned off on the internet range.

thanks anyway cholzhauer, some day I will get my /64 working :D
« Last Edit: January 11, 2011, 02:12:56 PM by vivow »
Logged
Pages: 1 [2]