• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Trouble with Mac OS 10.6.6 tunnel.

Started by cykros, January 17, 2011, 12:41:46 AM

Previous topic - Next topic


Well, I've tried just about everything I could think to try, with some reboots thrown in just to be sure I didn't have any leftover bad configuration compounding issues.  I set up a tunnel yesterday (ID 90750) and followed the instructions given, using the local IP address from the router.  No errors there (or at least, none other than some weird Apple quirkiness, which I managed to clear up).  Beforehand, I made sure to put my computer in the DMZ, as I wasn't able to determine whether or not it forwarded protocol 41 by default.  Also made sure to allow internet ICMP requests, and turned off NAT filtering security.  For the purpose of completeness, the router is a Netgear WGR614v8 home wireless G router.  The issue comes when I try to access an IPv6 site, or ping.  Web requests definitely are not going through, and this is the output from a ping6 attempt:

sh-3.2# ping6 tunnelbroker.net
PING6(56=40+8+8 bytes) 2001:470:1f06:e84::2 --> 2001:470:0:63::2
Request timeout for icmp_seq=0
Request timeout for icmp_seq=1

This seems to be moderately hopeful, though obviously discouraging, just because it IS resolving the hostname to an IPv6 address, however, nothing is going through.  I've tried setting my wireless interface up with and without an ipv6 address, but neither setup seemed to make any difference.  I've seen other posts from people suggesting that this should "just work" on macs, and yet it isn't, so I'm somewhat inclined to suspect that it may be an issue of the router (though I can't imagine how given that it's in the DMZ).   Any help on getting this to work would be much appreciated.

On a bit of a side note:  would there be anything I might gain by using ip6config instead of dealing with ifconfig commands?  I'm not particularly familiar with the utility, but it came up in some of my searching to figure this out, so I figured it was worth asking about.  Yes/no?

???  ???  ???


Regarding the DMZ thing...I just saw a post the other day where the posted put his machine in the DMZ of the firewall, but it didn't help.

Can you try connecting your mac directly to the outside world and testing?


Well, that worked.  Should there be any settings I'm looking to fix in the netgear configuration?  Or is there just no way around this short of a new router?

Thanks for the tip.



The only thing I found was

but that looks like it's only to get it to respond on the internet port


It does not appear that your router properly passes protocol41. I find that most of the routers that don't pass protocol41 don't even do it for systems in the DMZ. So it looks like you are stuck with either getting a new router, or perhaps flashing your router with third-party firmware such as DD-WRT.


All right.  Seems kind of strange to me, given that from my understanding Protocol 41 is just standard UDP traffic, but if that's the way things work, then that's how it'll have to be.

I did find an article by someone with an older Netgear with the same issue, except they were able to enable telnet debugging, and made an iptables entry to fix the problem.  Unfortunately, modern Netgear routers apparently require a proprietary windows program to enable that telnet interface.  Wasn't sure if there was another way around this.  I guess I'll just leave it at that for now, but if anyone DOES find a way, I'd love to hear it.