• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

IPv6 tunnel + RRAS on Windows Server 2008 R2 does not work

Started by AVasiliu, February 20, 2011, 03:51:11 AM

Previous topic - Next topic



It seems that my tunnel does not work when RRAS is configured and running... I can ping my own IPv6 address, but nothing else. As soon as I deconfigure RRAS, IPv6 starts working just fine, and as soon as I enable it again, it stops working.

Not sure if this helps, but here's what I get with Wireshark: no relevant packets at all (not even to the IPv4 tunnel end-point) with RRAS running, and lots of protocol 41 packets with RRAS disabled, which means that RRAS somehow blocks packets from even leaving my computer. And last but not least, IPv6 works fine with gogo6's client (which creates a virtual adapter), but I'd rather use HE instead if at all possible.

Anyone ever had problems with v6v4tunnel+RRAS before? Any ideas on how to continue debugging?


No experience with RRAS, but it almost sounds like the routing is being screwed up when you enable it.

Have you compared the routing tables with RRAS enabled and RRAS disabled?  Is there any difference?


Routing table looks identical. Assuming it uses the same routing table, anyway (from 'route print').


I have found no actual solution either. As a workaround I have a mini Hyper-V debian VM providing the tunnel to my network.



Not sure if I arrive very late with an answer, but this's my guess.

When you install RRAS service on 2008, it applies filters to the external interface to add some security to the server. All the inbound or outbound traffic should be allowed manually changing the default configuration.

Check the following on Server Manager:

Roles->Network Policy and Access Services->Routing and Remote Access->IPv4->General->

Right-click on the External_NIC and check 'Inbound Filters' and 'Outbound Filters'.

Modify the configuration to allow incoming traffic (Inbound Filters) and outgoing traffic (Outbound Filters) for 6-to-4 tunnel and it should work.

Try it and let me know.