• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.


Welcome to Hurricane Electric's Tunnelbroker.net forums!

Main Menu

Auto configuration issue

Started by phil, May 05, 2009, 06:41:28 PM

Previous topic - Next topic


Hi all,

Apologies for my ignorance, this is my first time in doing this...

The tunnel is set up on a Linux server and can happily ping in/out. My radvd conf is as follows:

interface eth1
  AdvSendAdvert on;
  prefix 2001:470:1f09:d4d::/64
    AdvOnLink on;
    AdvAutonomous on;

A Linux PC on the network happily configures itself with an IP from the subnet and gets the Link scope ipv6 address for the Linux server:

eth0      Link encap:Ethernet  HWaddr 00:0f:b0:76:62:9e 
          inet addr:  Bcast:  Mask:
          inet6 addr: 2001:470:1f09:d4d:20f:b0ff:fe76:629e/64 Scope:Global
          inet6 addr: fe80::20f:b0ff:fe76:629e/64 Scope:Link
          RX packets:1291 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1290 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:987856 (964.7 KiB)  TX bytes:270908 (264.5 KiB)

Kernel IPv6 routing table
Destination                    Next Hop                   Flag Met Ref Use If
2001:470:1f09:d4d::/64         ::                         UAe  256 0     5 eth0
fe80::/64                      ::                         U    256 0     0 eth0
::/0                           fe80::20e:cff:fe4e:b4f0    UGDAe 1024 0     0 eth0
::/0                           ::                         !n   -1  1   179 lo
::1/128                        ::                         Un   0   1     1 lo
2001:470:1f09:d4d:20f:b0ff:fe76:629e/128 ::                         Un   0   1     0 lo
fe80::20f:b0ff:fe76:629e/128   ::                         Un   0   1     5 lo
ff00::/8                       ::                         U    256 0     0 eth0
::/0                           ::                         !n   -1  1   179 lo

However, it cannot ping the outside world and, when it tries to ping the router address I get...

phil@phil:~$ ping6 fe80::20e:cff:fe4e:b4f0
connect: Invalid argument

It works if I do...

phil@phil:~$ ping6 -I eth0 fe80::20e:cff:fe4e:b4f0
PING fe80::20e:cff:fe4e:b4f0(fe80::20e:cff:fe4e:b4f0) from fe80::20f:b0ff:fe76:629e eth0: 56 data bytes
64 bytes from fe80::20e:cff:fe4e:b4f0: icmp_seq=1 ttl=64 time=2.76 ms
64 bytes from fe80::20e:cff:fe4e:b4f0: icmp_seq=2 ttl=64 time=0.417 ms
--- fe80::20e:cff:fe4e:b4f0 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1006ms
rtt min/avg/max/mdev = 0.417/1.592/2.767/1.175 ms

Does anyone have any advice about how to make it such that each PC can auto configure itself and be able to route out through the Linux server?

Kind Regards



sysctl has been configured with forwarding = 1?

also this is the generic radvd.conf i use that hasn't failed me yet:

interface eth#
AdvSendAdvert on;
AdvHomeAgentFlag off;
MinRtrAdvInterval 30;
MaxRtrAdvInterval 100;
prefix 2001:470:x:x::/64
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;

obviously make it the correct interface and /64


Just tried that radvd config - it has exactly the same result.

Quotephil@127dot0dot0dot1:~$ cat /proc/sys/net/ipv6/conf/all/forwarding

Is that all I need to be enabeld?