Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Enthusiast test: Could not grab the file via IPv6 HTTP  (Read 4577 times)

swarren

  • Newbie
  • *
  • Posts: 2
Enthusiast test: Could not grab the file via IPv6 HTTP
« on: May 18, 2011, 08:17:29 PM »

I'm failing to get past the enthusiast test; verifying that my web server is serving OK on ipv6. Whenever I click the test button, I immediately get the error message "Could not grab the file via IPv6 HTTP". I verified with wireshark that the he.net server is returning this message in reponse to the AJAX request, so it's no a local problem.

The URL in question is http://www.wwwdotorg.org/sxywqw332y.txt.

I've verified that URL works, using another ipv6-capable machine and "wget -6". A traceroute6 on a different ipv6-capable machine that gets its connectivity through an he.net tunnel works.

Any clues what could be wrong? Thanks.
Logged

swarren

  • Newbie
  • *
  • Posts: 2
Re: Enthusiast test: Could not grab the file via IPv6 HTTP
« Reply #1 on: May 18, 2011, 08:37:35 PM »

Hmm. The he.net server must have been caching something. I tried resetting the test and using a different hostname in the same domain; same result. Then, I changed to a different domain hosted on the same IP and it immediately worked. Odd.
Logged

rlininger

  • Newbie
  • *
  • Posts: 1
Re: Enthusiast test: Could not grab the file via IPv6 HTTP
« Reply #2 on: May 26, 2011, 07:17:16 AM »

I had to wait a day for the AAAA record to propagate to the point where the he.com DNS servers saw it.  It could be that the only problem you had was time.  This propagation could have happened while you were testing alternate methods and once you came back to the original issue DNS was ready for you.
Logged