• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.


Welcome to Hurricane Electric's Tunnelbroker.net forums!

Main Menu

D-Link 655 IPv6 firewall

Started by ykok, October 28, 2011, 11:47:41 AM

Previous topic - Next topic


I have a D-Link 655, and I'd really like to allow port 80 to go through to my server - but I'm rather puzzled how I should do this.

The firewall page on my router is as follows:

Currently it works mostly like a NAT IPv4 router - I can access anything on the outside, but nothing on the outside can access anything inside.

I tried setting the IP address range to ::/0 - but then I get an error saying that it only allows one "::". I've also tried to set it to "Firewall on and ALLOW the following rules" and enabled the first rule - but that didn't allow anything through (from inside to outside).

I tried looking for this in the manual - but the one I have doesn't even mention this page.


From that picture it looks like you have it backwards...the source should be "WAN" and the destination should be "LAN"


Quote from: cholzhauer on October 28, 2011, 11:50:25 AM
From that picture it looks like you have it backwards...the source should be "WAN" and the destination should be "LAN"

Yep - but if the above rule doesn't even allow me to connect to the outside (when the rule is enabled and the firewall is set to "Firewall on and ALLOW the following rules") - then I need some more basic knowledge about how to configure this firewall before even considering trying to focus on port 80.


It seems that the problems I had where all fixed in a later firmware upgrade. While writing the above I had firmware version 2.00. Since I'm an Danish (European) customer later firmwares where not directly available. However at least one later firmware can be downloaded from d-link German ftp site. I found it here:

EDIT: You can also try the Taiwan one (I believe) revision 2.02 - it's a beta though:

It should be possible to use the American firmwares as well as the European(according to some forum I went by - no, I don't remember which), but they are named diffidently.

After using firmware 2.01 the router now behaves as expected.