• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Is protocol 41 blocked for me?

Started by SoupDragonJutsu, November 15, 2010, 05:45:36 AM

Previous topic - Next topic


I originally tried setting up my Windows Server 2008 R2 for IPv6, I'm using Virgin Media's terrible combo box, VMDG280 as my endpoint, which I suspect does block protocol 41 but I can enable DMZ on there.
However, no matter what I tried, I just couldn't get it working - was getting errors such as Generic Transmit Error (or something similar) when pinging ip6.google.com.

But I did go and try it in Ubuntu, whilst the Linux-route2 instructions didn't work either, the Linux-net-tools instructions worked perfectly fine. It actually worked without me changing anything in the Virgin Box, DMZ was off too.
So I'm a bit confused what's going on here..  ???



You said it worked in Ubuntu behind the same router/firewall, so that tells me that Protocol 41 is not being blocked.


I thought that too, but have no idea what to try now, I've also tested on Windows 7 (also 64-bit) with no luck. I'm wondering if it could be to do with my end-point since when following the Linux-net-tools method you do not specify your end-point IP


Well, we need some more information...what did you try? What isn't working? lets see:

1) the commands you used to set up the tunnel. 
2) routing tables
3) output of ipconfig /all


I really don't want to post all the here, could get messy, so I've pasted it all at these links below:

Windows 7

Ubuntu 10.10

Sorry for dumping so much stuff!


You said Ubuntu works, so I'll ignore that config for now.

For Windows:

1) Line 12 needs to be:

netsh interface ipv6 add v6v4tunnel IP6Tunnel

2) You need to assign an IPv6 address to your "Local Area Connection" adapter from your routed /64 or /48


Sorry for taking so long, I got it all working in the end

Thank you for all your help :)


on Ubuntu log line #12, you should use routed /64 or /48 instead of tunnel endpoint address, which is just one number difference (1f08 and 1f09)


have also had the same problem, but how did edit my config on my windows box?