• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

No IPv6 to Ubuntu laptop via DHCP

Started by ssimlo, March 31, 2012, 01:49:13 PM

Previous topic - Next topic

ssimlo

I am in the process of trying to get v6 running in our home network. I have a Cisco 1801 running 15.1(4)

I have an active tunnel and can ping to the HE end of the tunnel from my router.

I have tried to configure DHCP allocation from my /48:

ip cef
no ip domain lookup
ip name-server 208.67.222.220
ip name-server 208.67.222.222
ip name-server 2001:470:20::2
ipv6 general-prefix HE 2001:470:7A10::/48
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool IPv6
dns-server 2001:470:20::2

Tunnel is up:

25hailes#show ipv6 int tun 0
Tunnel0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::57C2:9869
  No Virtual link-local address(es):
  Description: Hurricane Electric IPv6 Tunnel Broker
  Global unicast address(es):
    2001:470:1F14:362::2, subnet is 2001:470:1F14:362::/64
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::1:FF00:2
    FF02::1:FFC2:9869
  MTU is 4450 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds (using 30000)
  ND RAs are suppressed (periodic)
  Hosts use stateless autoconfig for addresses.
25hailes#

I can ping the other end of the tunnel from the router:

25hailes#ping 2001:470:1f14:362::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:470:1F14:362::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/48/48 ms
25hailes#

In config I have:

25hailes#show run | include ipv6
ipv6 general-prefix HE 2001:470:7A10::/48
ipv6 unicast-routing
ipv6 cef
ipv6 dhcp pool IPv6
ipv6 address 2001:470:1F14:362::2/64
ipv6 enable
tunnel mode ipv6ip
ipv6 address 2001:470:7A10:1::/64 eui-64
ipv6 enable
ipv6 mtu 1380
ipv6 nd other-config-flag
ipv6 dhcp server IPv6
ipv6 route ::/0 Tunnel0
25hailes#


but I have no IPv6 address in DHCP on my wifi attached Ubuntu....see attached

What am I missing ?
What are some good tests to try ?
Thanks for ideas ?

cholzhauer

It looks like you're trying to use the whole /48 block..you need to select a /64 from the /48 and advertise that instead

ssimlo

You are suggesting instead of:

ipv6 general-prefix HE 2001:470:7A10::/48

I have something like:

ipv6 general-prefix HE 2001:470:7A10:CAFE::/64

Is that the only change I would need ?

cholzhauer

perhaps not the only change, but a needed change

antillie

#4
Here is now I have my 3745 running 12.4 setup. There is no wifi interface of course but it should serve as a general example of a basic setup.

ipv6 unicast-routing
no ipv6 source-route
ipv6 cef
!
interface Tunnel0
no ip address
ipv6 address 2001:470:1F0E:6CA::2/64
ipv6 enable
ipv6 traffic-filter Block-IPv6-SSH in
no ipv6 redirects
ipv6 verify unicast reverse-path
tunnel source 70.114.48.211
tunnel destination 216.218.224.42
tunnel mode ipv6ip
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.252
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
ipv6 address 2001:470:B98A:1::/64 eui-64
ipv6 mtu 1480
ipv6 nd prefix 2001:470:B98A:1::/64
!
interface FastEthernet0/1
ip address dhcp
no ip redirects
no ip unreachables
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip nat inside source list 2000 interface FastEthernet0/1 overload
!
access-list 2000 permit ip any any
ipv6 route 2001:470:B98A::/48 FastEthernet0/0 FE80::21F:9EFF:FE45:2422
ipv6 route 2001:DB8::/32 Null0
ipv6 route FC00::/7 Null0
ipv6 route ::/0 2001:470:1F0E:6CA::1
!
ipv6 access-list Block-IPv6-SSH
deny tcp any any eq 22
permit ipv6 any any

nickbeee

#5
For the 1801 your LAN interface is probably taken from the built-in 8-port switch. In that case you should assign your ipv6 address to the SVI (switch virtual interface) which will probably be interface vlan 1.

Please post output of show ip interface brief and show ipv6 interface brief.
Nick B.

Tunnelling with [Open|Net|Free]BSD and IOS.
IPv6 courtesy of   HE and   Sixxs.