Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Configuring wide-dhcp6 (server and client)  (Read 6109 times)

lucabert

  • Newbie
  • *
  • Posts: 26
Configuring wide-dhcp6 (server and client)
« on: March 06, 2012, 07:04:47 AM »

Hi, all!

I really think, that I need a vacation...

Well, after you said (http://www.tunnelbroker.net/forums/index.php?topic=2317.msg13415#msg13415) that radvd can only work with a /64 subnet, I'm trying to configure a DHCPv6 server and client.

I installed wide-dhcpv6-server on my PC and wide-dhcpv6-client on my wife's PC.
Here the configurations (currently I use again HE, because I want to solve all problems before I run the tunnel through my server):

My PC:
option domain-name-servers 2001:470:1f0b:191:1::1;

host anika {
        duid 00:03:00:06:00:0b:6a:73:a7:cb;
        address 2001:470:1f0b:191:2::1 infinity;
};

interface eth0 {
        address-pool pool1 3600;
};

pool pool1 {
        range 2001:470:1f0b:191:2::1 to 2001:470:1f0b:191:2::ff;
};


My wife's PC:
interface eth0 {
        request domain-name-servers;
        request domain-name;
        send rapid-commit;
        send ia-na 15;
        script "/etc/wide-dhcpv6/dhcp6c-script";
};

id-assoc na 15 { #
};


Well, as I started the server and the client, the PC of my wife get the address 2001:470:1f0b:191:2::1, but not the routes...
Here what I see on my wife's PC:

root@anika:~# ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1400 qlen 1000
    inet6 2001:470:1f0b:191:2::1/128 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::20b:6aff:fe73:a7cb/64 scope link
       valid_lft forever preferred_lft forever
root@anika:~# ip -6 route
2001:470:1f0b:191:2::1 dev eth0  metric 256  expires 21334353sec mtu 1400 advmss 1340 hoplimit 4294967295
fe80::/64 dev eth0  metric 256  expires 21308488sec mtu 1400 advmss 1340 hoplimit 4294967295
ff00::/8 dev eth0  metric 256  expires 21308488sec mtu 1400 advmss 1340 hoplimit 4294967295


Well, of course I can't reach my PC from the PC of my wife and, of course, from this PC I can't reach any other host...

I searched for other options on the server's side, but I didn't found anything...

What's the error, now?

Thanks a lot!
Luca Bertoncello
Logged

bpier

  • Newbie
  • *
  • Posts: 22
Re: Configuring wide-dhcp6 (server and client)
« Reply #1 on: March 06, 2012, 08:28:16 AM »

In my radvd.conf, I include a route:

 
route 2001:470:####:##::/64 {
                AdvRoutePreference high;
        };


I have two virtual systems as DHCPv6 clients:  Windows Vista picks up the default route; Windows 8 does not.


Bill
Logged

kriteknetworks

  • Sr. Member
  • ****
  • Posts: 260
    • aRDy Music
Re: Configuring wide-dhcp6 (server and client)
« Reply #2 on: March 06, 2012, 06:08:58 PM »

dhcpv6 doesnt support routes. you still need to run radvd with the managed and other (M and O) options set in order to have client machines pick up the default route.
Logged