Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Problems with Apple Time Capsule  (Read 2533 times)

maxwellhadley

  • Newbie
  • *
  • Posts: 2
Problems with Apple Time Capsule
« on: October 06, 2012, 12:50:14 PM »

Hi,

I have just set up a tunnel with HE. I was planning to terminate this on my Apple Time Capsule, which is a 3rd gen (I think) running 7.6.1 firmware. It lives behind a Draytek Vigor 2820 ADSL router which is implementing NAT: I have a static IPv4 address from Demon, my ISP. When I set this up following the posted instructions, it did not work. Sometimes the TC would give me a 'bad tunnel' error, but most of the time it had a green status but no IPv6.

I then tried setting up a tunnel endpoint on my Mac using ifconfig gif0, and that worked exactly as expected. It appears to go through the router & NAT without any problems and without requiring any setup. I don't know how it does this, but it does (which is nice). so I have IPv6!

Has anybody come across this issue before? Any ideas? I'd really rather use the TC as the IPv6 router, as it is always on, unlike this Mac.

Max
Logged

maxwellhadley

  • Newbie
  • *
  • Posts: 2
Re: Problems with Apple Time Capsule
« Reply #1 on: October 07, 2012, 01:45:06 PM »

Mysteriouser & mysteriouser!

I tried using a refurb AirPort Express 802.11n (2nd Generation) I have just acquired. I used the exact same settings I had tried on the Time Capsule, and this time it worked! The firmware on this unit is 7.6.2, whereas on the TC it was 7.6.1. In both cases, this is the current version. I can only assume the TC firmware is bugged in some way. Anyway, this solves my problem. The AE only takes 1W from the mains (measured) so I can leave it permanently on instead of switching it on and off with the stereo system power, with a clear conscience
Logged