• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Stuck at administrator test, no idea how to troubleshoot further

Started by AndrejaKo, October 08, 2012, 01:04:04 PM

Previous topic - Next topic


Hi! As the title says, I'm stuck at administrator level test and I don't know what to do next.

I've got a windows computer with a fixed IPv6 address and set up Ability Mail Server 2012 on it. The server is set to prefer IPv6 over IPv4. I can send and receive mails fine using IPv4 (tested with Gmail) and I can telnet from the router into the server using its IPv6 address. The address pings fine from the Internet too. Unfortunately, I don't have a computer with IPv6 at another location, so I can't telnet into the server and test it that way, but I think that my firewall settings are fine. Right now, I've set it to accept traffic on all ports (yes, I know that's unsafe!). Also the Windows firewall is disabled.

So when I input the mail address on the web page and click on the send mail button, I get two rotating arrows which keep doing that until I refresh the page. Once I do that, I get the send mail button again. Is this normal behavior? On wireshark, don't see anything trying to make contact with the computer running the server, so I guess that I may have a problem somewhere in the DNS configuration.

I've been provided with domain rm1211.s.raf.edu.rs by my school for experimental purposes and I've set the MX record to point to mail.rm1211.raf.edu.rs. When I do nslookup of that, I get:

root@OpenWrt:/# nslookup mail.rm1211.s.raf.edu.rs
Address 1: localhost.

Name:      mail.rm1211.s.raf.edu.rs
Address 1: 2001:470:1f0b:de5::5 mail.rm1211.s.raf.edu.rs
Address 2: 77-105-40-140.adsl-2.sezampro.rs

The dig for MX record of my domain looks like this:

root@OpenWrt:/# dig mx rm1211.s.raf.edu.rs

; <<>> DiG 9.7.2-P3 <<>> mx rm1211.s.raf.edu.rs
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21801
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;rm1211.s.raf.edu.rs.           IN      MX

rm1211.s.raf.edu.rs.    38426   IN      MX      10 mail.rm1211.s.raf.edu.rs.

;; Query time: 35 msec
;; WHEN: Mon Oct  8 21:55:01 2012
;; MSG SIZE  rcvd: 58

Both outputs looks fine to me, so I'm out of ideas where to look for troubleshooting ideas.

What do I do now?



Quote from: AndrejaKo on October 08, 2012, 01:04:04 PMWhat do I do now?
You might just need to wait. The tunnel server you have chosen (tserv1.fra1) is not the most stable of them. Right now it has the third outage in two days. I have ticket #1996499 open about this issue. If you don't want to wait for that, you can of course create another tunnel on a different tunnels server. You can create up to five total.

You should also be aware that at the moment edu.rs does not have sufficient IPv6 support to complete the certification using the domain that you have got. You can go through most of the certification, but not all of it.


Yeah, I'm aware that edu.rs doesn't have IPv6 glue records and that I won't be able to get sage level with my current domain. Which is the last point where I can add another domain to the test? I see that for sage, I need to use one of the domains I already used.

Anyway, would the outages actually affect mail system? Back when I was testing the mail system, tunnel looked like it was working fine.  Right now, the tunnel works fine too and I'm still not getting the mail.


Quote from: AndrejaKo on October 09, 2012, 01:23:56 AMAnyway, would the outages actually affect mail system? Back when I was testing the mail system, tunnel looked like it was working fine.  Right now, the tunnel works fine too and I'm still not getting the mail.
The outage would affect everything. During that particular outage it was still possible to communicate between different tunnels on that tunnel server, but communication with the rest of the IPv6 Internet was impossible.

The tunnel server came back shortly after my message.

But your mail server is misconfigured. The domain name is spelt differently in DNS and on the mail server. And the mail server doesn't recognize either version.$ telnet mail.rm1211.s.raf.edu.rs. 25
Trying 2001:470:1f0b:de5::5...
Connected to mail.rm1211.s.raf.edu.rs.
Escape character is '^]'.
220 rrm1211.s.raf.edu.rs ESMTP (Code-Crafters Ability Mail Server 2012)
HELO mx3.kasperd.net
250 rrm1211.s.raf.edu.rs
MAIL From:<>
250 Email address accepted. <>
RCPT To:<postmaster@rm1211.s.raf.edu.rs>
550 Account is not local, relaying disallowed. <postmaster@rm1211.s.raf.edu.rs>
RCPT To:<postmaster@rrm1211.s.raf.edu.rs>
550 Account is not local, relaying disallowed. <postmaster@rrm1211.s.raf.edu.rs>
221 Thank you and good bye.


Ah! I can't believe that I actually misspelled the mailserver settings.... Thanks a lot! I got to professional level now.