Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Pages: [1] 2

Author Topic: Time Capsule / Airport 7.6.3 firmware update  (Read 24492 times)

kcochran

  • Sr. Network Engineer, Hurricane Electric
  • Administrator
  • Sr. Member
  • *****
  • Posts: 405
    • View Profile
Time Capsule / Airport 7.6.3 firmware update
« on: February 08, 2013, 07:11:43 AM »

Looks like the existing configuration settings will not work with the 7.6.3 firmware.  If you have a working tunnel configured using an earlier firmware, it will likely not work with the new firmware.  Unless you need something in the 7.6.3 firmware, you may want to hold off until what they changed or expect has been determined.  If you have upgraded, you can use Airport Utility to revert to a previous firmware.  Instructions are available at http://support.apple.com/kb/HT1218
« Last Edit: February 08, 2013, 07:13:23 AM by kcochran »
Logged

cjkreklow

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #1 on: February 08, 2013, 01:45:05 PM »

Just got bit by this!  Guess that's what I get for upgrading without looking at the forums first.
Logged

cpg

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #2 on: February 08, 2013, 03:55:52 PM »

In the 7.6.1 firmware, there was a new field introduced in the tunnel setup - delegated prefix.

Did you ever put a value into that field?  I used the 'Routed 64' value.

When I upgraded to 7.6.3 my Hurricane tunnel still works but the default tunnel shows a 6to4 address that has nothing to do with my HE tunnel information.

Yet, all my computers get IPv6 addresses that are part of my /64 from Hurricane and I can ping my router's he ipv6 address.

So my tunnel works but the values displayed in the Airport utility are wacky.

Does this help anyone?
Logged

ddulay

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #3 on: February 09, 2013, 01:27:05 PM »

I had to update my airport settings. My previous settings had been created using the older Airport Utility (5.6). I created the new settings using the 6.2 airport utility: Ineternet > Internet Options... Previously I had IPv6 Delegated Prefix blank and my Routed /64 as the IPv6 LAN Address. I had to change this so the IPV6 Delegated Prefix is the Routed /64, and the IPv6 LAN Address is the ::1 in the Routed /64. For example, my IPv6 Delegated Prefix is "2001:DB8::/64" and my IPV6 LAN Address is "2001:DB8::1".

The screenshot in the tunnelbroker.net example configurations will need to be updated.
Logged

cpg

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #4 on: February 10, 2013, 09:30:54 PM »

@ddulay - this is what I had in the Airport IPv6 settings since 7.6.1.  Using Airport Utility 6.2 and firmware 7.6.1 the IPv6 WAN address shows my HE IPv6 WAN address.  The same settings on the Extreme using firmware 7.6.3 show an IPv6 WAN Address of some random 6to4 address.

Something is wrong with 7.6.3 and IPv6 in general or just the tunneling.
Logged

kcochran

  • Sr. Network Engineer, Hurricane Electric
  • Administrator
  • Sr. Member
  • *****
  • Posts: 405
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #5 on: February 11, 2013, 03:00:46 PM »

I had to update my airport settings. My previous settings had been created using the older Airport Utility (5.6). I created the new settings using the 6.2 airport utility: Ineternet > Internet Options... Previously I had IPv6 Delegated Prefix blank and my Routed /64 as the IPv6 LAN Address. I had to change this so the IPV6 Delegated Prefix is the Routed /64, and the IPv6 LAN Address is the ::1 in the Routed /64. For example, my IPv6 Delegated Prefix is "2001:DB8::/64" and my IPV6 LAN Address is "2001:DB8::1".

The screenshot in the tunnelbroker.net example configurations will need to be updated.

I just tried that here, and no v6 worked after those settings either on AU6.2.  I wonder if there's something either funky with their firmware, or if it's behaving differently depending on the specific model, which shouldn't really make a difference.  Mine's a 3rd Gen.
Logged

Warthog

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #6 on: February 13, 2013, 09:23:50 AM »

Saw this issue got picked up on Ars Technica this morning.

http://arstechnica.com/apple/2013/02/airport-extreme-update-breaks-ipv6-tunnels-but-heres-how-to-fix-it/#p3n

The article pretty much recaps what has been discussed / tried here, however for me it's working now if I put the routed /64 in the IPv6 Delegated Prefix field, and then the same thing in the IPv6 LAN Address with 1 on the end instead of the /64.
Logged

superpixel

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #7 on: February 13, 2013, 12:47:08 PM »

The tunnel works for me with the new firmware and these settings:
« Last Edit: February 13, 2013, 12:49:53 PM by superpixel »
Logged

ddulay

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #8 on: February 13, 2013, 01:47:02 PM »

@cpg
Yes, your suggestion helped. Thanks. I had not looked at the IPv6 WAN Address, and it shows the 6to4 address matching my IPv4 address. I can't ping that address, so I doubt it is in use.

I have a 4th generation AEBS.

@superpixel
Yes, these are the working settings I have, too.
Logged

kcochran

  • Sr. Network Engineer, Hurricane Electric
  • Administrator
  • Sr. Member
  • *****
  • Posts: 405
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #9 on: February 24, 2013, 09:24:45 AM »

To continue the weirdness, I tried updating a 4th gen AEBS with native, non-tunnel, IPv6.  After going to 7.6.3, no IPv6 love on the internal network.

So either there's something funky with the update, or some setting hiding is causing issues, or I just have the absolute worst luck in the world.  At least with the 4th gen, the delegated prefix doesn't zero out.
Logged

CUTLER719NET

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #10 on: February 25, 2013, 08:17:00 PM »

I found the upgrade from 7.6.2 to 7.6.3 on a fifth generation Airport Extreme to be transparent for native IPv6 routing.   8)

I did have to re-enter tunnel settings per the Ars Technica article http://arstechnica.com/apple/2013/02/airport-extreme-update-breaks-ipv6-tunnels-but-heres-how-to-fix-it/ to make a tunnel work.  :P

Of course, the IPv6 experience gained with HE TunnelBroker over the past year or so made it easier to understand what was happening. 

Thank you very much, Hurricane Electric!  ;D
Logged

skippingrock

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #11 on: March 25, 2013, 07:15:39 AM »

To continue the weirdness, I tried updating a 4th gen AEBS with native, non-tunnel, IPv6.  After going to 7.6.3, no IPv6 love on the internal network.

So either there's something funky with the update, or some setting hiding is causing issues, or I just have the absolute worst luck in the world.  At least with the 4th gen, the delegated prefix doesn't zero out.

Has this been figured out yet what exactly has to be done? I've downgraded back to 7.6.1 on my TC Gen 1 for now.
- Cheers and thanks.
Logged

kcochran

  • Sr. Network Engineer, Hurricane Electric
  • Administrator
  • Sr. Member
  • *****
  • Posts: 405
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #12 on: March 25, 2013, 10:14:08 AM »

There are several threads on the Apple support forums about this topic, and there's been no reply back from them to any of the users seeing this issue.  Everyone there has had success just going back to 7.6.1.
Logged

brontide

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #13 on: March 31, 2013, 10:28:24 AM »

I had been keeping around my old gig AirPort Extreme ( pre simultaneous dual band ) for the sleep proxy, but I finally unplugged it yesterday.  It was causing no end to grief on the internal network and bonjour, several of my hosts kept cycling up their names ... host bacame host-1, -2, -3 and the problem was it was breaking my shairport services.  It was also trashing the address space by making 169.225 for many hosts that were happy ipv6 internally.  This is not the same issue, but native ipv6 breakage set to native or link-local only on 7.6.1 or 7.6.3 it was causing grief.
Logged

alankuranov

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Time Capsule / Airport 7.6.3 firmware update
« Reply #14 on: November 27, 2013, 01:06:30 AM »

Does anyone able to set up Airport Extreme with firmware 7.7.2 for IPv6?
Logged
Pages: [1] 2