• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Ipv6 tunnel stops working after 24 hours.

Started by vjheaven, February 12, 2013, 02:08:39 PM

Previous topic - Next topic


Hello all,
I have a Linksys E900 router with dd-wrt firmare: dd-wrt.v24-19342_NEWD-2_K2.6_big-nv64k and after ~24 hours my tunnel stops working. Then if I reboot the router and enter the new ipv4 adress (i have dynamic ip adress) on the tunnelbroker page the ipv6 will work for another 24 hours.

My settings are:

Startup config:

sleep 10
insmod ipv6
sleep 10

ip tunnel add he-ipv6 mode sit remote (Server IPv4 Address) ttl 64
ip link set he-ipv6 up
ip addr add (Server IPv6 Address) dev he-ipv6
ip route add ::/0 dev he-ipv6
ip addr add (Server IPv6 Address) dev br0
sleep 5
radvd -C /tmp/radvd.conf

radv config:

interface br0 {
MinRtrAdvInterval 3;
MaxRtrAdvInterval 10;
AdvLinkMTU 1480;
AdvSendAdvert on;
prefix (Routed /64) {
AdvOnLink on;
AdvAutonomous on;
AdvValidLifetime 86400;
AdvPreferredLifetime 86400;
RDNSS 2001:470:20::2 {};

I've tried removing AdvValidLifetime, AdvPreferredLifetime lines, i've change lifetime to 120, i also removed RDNSS 2001:470:20::2 line but the same, after ~24 hours my ipv6 tunnel stopped working.


some people have to rung ping in a cron job to keep the tunnel up...did you try that?


I dont know networking or linux and I tought my settings were wrong or I need to open some ports.
Or it's because i dont keep my ip icmp pingable? After i enter the new ip in Client IPv4 Address on tunnelbroker page i re-enable the firewall and block any further ping requests.

I'll try tomorow to set a chron and ping, thanks! :)