Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Configuring Mikrotik Router OS for DHCPv6 with tunnelbroker  (Read 8900 times)

srijit92

  • Newbie
  • *
  • Posts: 15
    • My Blog

Problem:

Clients not getting IPV6 via DHCP. But if configured statically IPV6 works fine.

ROS Code:

Code: [Select]
/ipv6 dhcp-server
add address-pool=pool1 authoritative=after-2sec-delay disabled=no interface=\
    LAN lease-time=3d name=server1
/ipv6 pool
add name=pool1 prefix=2001:470:19:1292::/64 prefix-length=64
/ipv6 address
add address=2001:470:18:1292::2/64 advertise=no disabled=no eui-64=no \
    interface=IPV6
add address=2001:470:19:1292::1/64 advertise=yes disabled=no eui-64=no \
    interface=LAN
/ipv6 dhcp-client
add add-default-route=yes disabled=no interface=LAN pool-name=ty \
    pool-prefix-length=64
/ipv6 nd
set [ find default=yes ] advertise-dns=yes advertise-mac-address=yes \
    disabled=yes hop-limit=unspecified interface=all \
    managed-address-configuration=no mtu=unspecified other-configuration=no \
    ra-delay=3s ra-interval=3m20s-10m ra-lifetime=30m reachable-time=\
    unspecified retransmit-interval=unspecified
add advertise-dns=yes advertise-mac-address=yes disabled=no hop-limit=64 \
    interface=LAN managed-address-configuration=yes mtu=unspecified \
    other-configuration=no ra-delay=3s ra-interval=3m20s-10m ra-lifetime=30m \
    reachable-time=unspecified retransmit-interval=unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=4h valid-lifetime=4h
/ipv6 route
add disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:18:1292::1 \
    scope=30 target-scope=10

Logged