Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Outgoing IP address  (Read 6426 times)

lucabert

  • Newbie
  • *
  • Posts: 26
Outgoing IP address
« on: May 08, 2011, 10:30:55 PM »

Hi, all!

I have this problem and I can't explain me why...
I have a tunnel (with IPv6 2001:470:1f08:135d::2/64) and a Subnet (2001:470:9735::/48). The PC of my wife has IPv6, too (using my PC as gateway).

If I try to surf an IPv6-ready website (such as http://ipv6.he.net/) I see that my PC uses 2001:470:1f08:135d::2 to send the request (the IPv6 of the tunnel), but my wife uses her own IP.

Hier my configuration:

/etc/ppp/ip-up.d/he-ipv6-tunnel:
Code: [Select]
ip tunnel add he-ipv6 mode sit remote $SERVER_IPv4_ENDPOINT local $IPLOCAL ttl 255
ip link set he-ipv6 up
ip addr add $CLIENT_IPv6_ENDPOINT dev he-ipv6
ip route add ::/0 dev he-ipv6
ip -f inet6 addr

/etc/network/interfaces:
Code: [Select]
auto eth0
iface eth0 inet static
        address 192.168.10.3
        netmask 255.255.255.0
        up /sbin/ip -6 addr add 2001:470:9735:1::1/64 dev eth0

Am I doing somewhat wrong?

Thanks a lot!
Luca Bertoncello
« Last Edit: May 08, 2011, 11:22:13 PM by lucabert »
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: Outgoing IP address
« Reply #1 on: May 09, 2011, 04:39:13 AM »

No.

Everything is working isn't it?
Logged

lucabert

  • Newbie
  • *
  • Posts: 26
Re: Outgoing IP address
« Reply #2 on: May 09, 2011, 05:03:39 AM »

No.

Everything is working isn't it?


Of course work everything! But I'd like to have the outgoing connection from my PC using an IPv6 of my subnet...  ;D

Is it possible?

Thanks
Luca Bertoncello
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: Outgoing IP address
« Reply #3 on: May 09, 2011, 06:50:21 AM »

When you say she uses her own IP, I assume you mean it's the IP address that either you, RA or DHCP has assigned to her computer?

If you want traffic to appear from your tunnel IP address, I don't think that's possible (easily at least...I'm sure you could break/hack something to do it)

If you don't want her real IP showing, turn on privacy extensions.
Logged

jgeorge

  • Newbie
  • *
  • Posts: 38
Re: Outgoing IP address
« Reply #4 on: May 09, 2011, 09:26:42 AM »

Luca,

So what you're wanting is YOUR pc to show an IP address in your /48 like your wife's PC, and not to use the tunnel address for it's public IP address, correct?

I don't know the answer offhand but I think what you might need to do is to move your route from the tunnel definition and set upa route from your eth0 interface to the tunnel instead. It looks like your PC thinks to route all of it's IPv6 traffic directly out the tunnel interface, so that your end of the tunnel would look like the originating IP address.

I think if you were to try to move that route definition to your eth0 interface you should get the results you're looking for.

Cheers,

Joe
Logged

lucabert

  • Newbie
  • *
  • Posts: 26
Re: Outgoing IP address
« Reply #5 on: May 09, 2011, 11:10:09 AM »

So what you're wanting is YOUR pc to show an IP address in your /48 like your wife's PC, and not to use the tunnel address for it's public IP address, correct?

Correct!

Quote
I don't know the answer offhand but I think what you might need to do is to move your route from the tunnel definition and set upa route from your eth0 interface to the tunnel instead. It looks like your PC thinks to route all of it's IPv6 traffic directly out the tunnel interface, so that your end of the tunnel would look like the originating IP address.

I think if you were to try to move that route definition to your eth0 interface you should get the results you're looking for.

Could you suggest me how can I do that? I tried today, but I didn't got it working...

Thanks
Luca Bertoncello
Logged

jgeorge

  • Newbie
  • *
  • Posts: 38
Re: Outgoing IP address
« Reply #6 on: May 09, 2011, 02:49:33 PM »

Hey Luca,

That's what I'm not sure how to do. I'd try moving your ip route ::/0 dev he-ipv6 statement to the script that raises eth0 instead of he-ipv6-tunnel as a first start.

Cheers,

Joe
Logged

snarked

  • Hero Member
  • *****
  • Posts: 774
Re: Outgoing IP address
« Reply #7 on: May 09, 2011, 06:22:53 PM »

See "ip addrlabel".
Logged

lucabert

  • Newbie
  • *
  • Posts: 26
Re: Outgoing IP address - SOLVED
« Reply #8 on: May 09, 2011, 11:29:34 PM »

See "ip addrlabel".

Hi, all!

As I found here http://www.tunnelbroker.net/forums/index.php?topic=299.0 I solved my problem!

I just don't add the IPv6-Address to the interface he-ipv6.
And it just works! :D

Thanks
Luca Bertoncello
Logged