Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: connecting back to my computer using ipv6 address  (Read 7729 times)

din100

  • Newbie
  • *
  • Posts: 3
connecting back to my computer using ipv6 address
« on: October 08, 2013, 04:48:23 AM »

hi I'm trying to connect to my windows 2012 box behind the 6rd tunnel. I can access all ipv6 sites from the machines but I cant ping my ipv6 address or even connect from outside ipv6 internet.

Tried the port fording disable ipv6 firewall etc on router linksys e4200v1

I'm new to ipv6
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2702
Re: connecting back to my computer using ipv6 address
« Reply #1 on: October 08, 2013, 05:16:01 AM »

Port forwarding won't work as you need to forward a protocol, not a port.  But, having said that, you mentioned 6rd...are you not using an HE tunnel?
Logged

din100

  • Newbie
  • *
  • Posts: 3
Re: connecting back to my computer using ipv6 address
« Reply #2 on: October 08, 2013, 06:59:47 AM »

sorry I'm using HE's tunnel on my router the HE setting is call 6rd tunnel but that could be wrong their is no protocol setting on the router
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2702
Re: connecting back to my computer using ipv6 address
« Reply #3 on: October 08, 2013, 07:06:07 AM »

Normally they're two different settings, I'm surprised tits works.

In any event, it sounds like a firewall issue is preventing you from doing what you want.  Since the tunnel is on the router, dmz mode won't help.  Are there any ways to change firewall settings?
Logged

din100

  • Newbie
  • *
  • Posts: 3
Re: connecting back to my computer using ipv6 address
« Reply #4 on: October 08, 2013, 07:45:07 AM »

i will be changing  my router to pfsense next week so I can try it. this router is bit limited.  what exactly I need to do. I have windows 2012 box with internal ip of 192.168.x.89 and ip from HE 2001:X:X:X:X:x:x:X I assume it's a public ip.

I'm getting 3 ipv6 ips 
 2001:X:X:X:X:X:X:X <-- public ip

 fd33:2001:X:X:X:X:X:X:X <--- what is this ?

 fe80:2001:X:X:X:X:X:X:X <--- this is a local link
 
Logged

kasperd

  • Founder, Netiter ApS
  • Hero Member
  • *****
  • Posts: 952
Re: connecting back to my computer using ipv6 address
« Reply #5 on: November 14, 2013, 02:12:03 PM »

I'm getting 3 ipv6 ips 
 2001:X:X:X:X:X:X:X <-- public ip
Not all addresses in that prefix are the same. More information is needed in order to tell you, what sort of address it is.

fd33:2001:X:X:X:X:X:X:X <--- what is this ?
ULA address. It cannot be used to communicate outside of your own LAN.

fe80:2001:X:X:X:X:X:X:X <--- this is a local link
Usually link local addresses are assigned from fe80::/64. Yours is different which may or may not be related to your problem.

If you mention your full IPv6 address we can traceroute it and tell you what we find.
Logged

ravenstar

  • Jr. Member
  • **
  • Posts: 63
Re: connecting back to my computer using ipv6 address
« Reply #6 on: December 30, 2013, 03:38:25 AM »

Windows firewall by default only allows ICMP pings from the local subnet on both IPv4 and IPv6.

To change this behaviour go to Control Panel->Windows Firewall
Click Advanced settings
Double click Inbound rules

Scroll down past all the Application rules and you will come to the System Rules.  More Specifically you need to locate File And Printer Sharing (Echo Request ICMPv6 in)
Note that there are 3 profiles - use the one for Private Networks and  double click.
Click the Scope Tab
Click the Any IP Address radio link under the Remote IP address section

Click OK and close the Windows Firewall.

Note though that it is best only to leave this enabled while you are testing.  Alternatively you can Allow ICMPv6 Pings from specific IP addresses only by adding the address or range into the Remote IP Address section.

Ravenstar68

Edit I note there have been no replies since October but hopefully this post will still prove useful to someone.
« Last Edit: December 30, 2013, 03:40:56 AM by ravenstar »
Logged