• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Can't connect to secure yahoo mail over IPv6

Started by KNBu5ZMdbR, November 22, 2020, 05:00:39 PM

Previous topic - Next topic


The issue still persists. :-(

I use Yahoo Finance and my firewall rule is to reject connections to 2a00:1288:80::/48.


I just submit a request to he support and yahoo support, provided tracepath result and explain it to both ends.  I am hoping someone from HE or Yahoo will take a look on it.   I will suggest  others to do the same. 



I have the same issue with Yahoo via the HE tunnel with my own IPv6 prefix via a BGP session with HE
Doing the same test curl --verbose --verbose https://mail.yahoo.com

I don't have such this issue, if I run this test from a server with its IPv6 not going through this tunnel.

Difficult also to find a Yahoo support to assist.

He support is answering but with no solution


I could test more the Yahoo issue with HE IPv6 tunnel.

My SIT tunnel uses MTU 1480

For Yahoo access, if I change the MTU of my server or computer to MTU from 1500 to 1480, it works fine, otherwise no.

It seems that PMTU with Yahoo is not well negociated.

What else could be done?




my MTU is set to 1480 already.  I still can't get to https://finance.yahoo.com/  Can you try it from your end?




Quote from: hellokitty2016 on April 05, 2021, 08:09:10 AM
my MTU is set to 1480 already.  I still can't get to https://finance.yahoo.com/  Can you try it from your end?
Tried setting it to 1280?


I tried lower the MTU.  Anyways, I am able to get to finance.yahoo.com via IPv6..  Can other tries it and report back as well?


I am seeing the same issue with e-mail.

With Thunderbird and Firefox, a workaround is to set:


in the configuration editor (Tools->options->general-> "advanced config"; about:config respectively).  Of course, if you already have domains in this list, just append these. 

This will force the DNS lookups for these domains to request only IPv4 addresses, while continuing to use IPv6 elsewhere.  (Assuming you aren't on an IPv6-only machine...)

I don't use other Yahoo! services, but if you do, you may have to add more domains to the list.

Getting Yahoo! (and other large domains) to fix things like this is extremely difficult to impossible.  They have so many layers of useless "virtual assistant", script-limited humans, and other barriers that finding a technically savvy human is an exercise in frustration. 

Hopefully, at some point this will percolate up to someone who'll fix it.  Maybe the latest new owners will help.  Hope springs eternal.


IPv6 Yahoo access only works for me when I set MTU on the tunnel to 1280.