• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Google forcing ReCAPTCHA on all searches from my HE assigned IPv6 address

Started by cshilton, May 31, 2023, 01:58:14 PM

Previous topic - Next topic


I'm being forced to confirm that I'm a human when I create a perform a new google search. I can stop this behavior by changing my IPv6 settings from Automatic to Link-Local. This setting change stops me from using IPv6 to connect to google, or anything else.

Is anyone else seeing this?

-- Chris



I started seeing this same problem on 31 May 2023. 
I get the "I am not a robot" and multiple captcha images to solve.
If I turn off ipv6 the problem goes away.
Looks like time to switch to bing search.


Seeing the same problem starting May 31st. DuckDuckGo is looking like a fine alternative.


I can add that when on native IPv6 from AT&T via my phone, Google is fine. Also, blocking outbound https to google's ip fixes things. I'll check from my house on Friday if this is still a problem then.


I removed IPv6 DNS resolution for Google's domains overnight to work around the issue. I enabled this morning and the problem persists. I think Google is pulling a Netflix and considering HE tunneled connections as a VPN.


It's odd though.  Only search (google.com) seemed to be affected.  mail and docs were fine.  I switched back to my CenturyLink 6RD for now but the next time my IPv4 address changes, I'm going to be in hell since the IPv6 network will also change. 


Same here. European server.
Quote from: gtjoseph on June 01, 2023, 03:42:04 PMIt's odd though.  Only search (google.com) seemed to be affected.  mail and docs were fine.
It's just first day or two, who knows, perhaps in another couple of days the rest of google services would be blocked as well. My guess is someone did use HE tunnel for some nefarious purposes, causing the issue for everyone.

Edit: still haven't been solved, but DuckDuckGo proves to be an excellent substitute.

I've contacted support, they said they already know about it and working with google to resolve. Here's to hoping it'll go away :)

June 8 - looks it's been resolved. Took a week or so lol


I had to avoid searching google over IPv6 for about a week but now things seem to be working. Are other people seeing this too or have I misdiagnosed things?

- Chris



So, it worked for a few days. Now we have a new issue. Anything going to www.google.com is giving me a "403 forbidden" error.


Same issue. 403 forbidden.


Confirm, Google now seems to block ipv6 queries to search from HE tunnelbroker ASN


Glad to see that i'am not alone with this issue. Same things - first captcha, then (few week later) 403 Forbidden... Quering only with ipv4 "solves" te issue.