• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Feature request for ipv4_end.php

Started by roguefugu, March 09, 2009, 08:21:02 PM

Previous topic - Next topic


I would like to suggest that the https://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=1&pass=2&user_id=3&tunnel_id=4
script, in addition to taking an IP address, offer an option to use the IP address of the requesting computer. This would make
automatically updating the IPv4 tunnel endpoint behind a NAT much easier, as instead of having to find the public IPv4 address
using public websites that might fail, the script would automatically find the IP. Such functionality already exists in freedns.org's
dynamic dns update script.

it might look something like this:
in addition to: https://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=1&pass=2&user_id=3&tunnel_id=4
the following could exist, which would use the IP address of the requesting computer.


If ipv4b = AUTO, it'll use the requesting client's IP address for the updated endpoint.

One thing to be careful of:
If you're going through an HTTP proxy, you'll be updating with the proxy's IP address.


I am currently using this URL:
(Parts of the md5 password have been changed to protect my account from compromise.), but it does not seem to work. I have read all relevant forum posts about ipv4_end.php, and have tried the URL using both Firefox and Wget. Since I have never used ipv4_end.php before, I would appreciate if someone could tell me whether this is merely a problem in its invocation, or some other issue.


Strange... I tried the exact same command from a box I have hosted on Tampa FL (sagonet), and the script, with the ipv4b=AUTO, got the reply:
Your tunnel endpoint has been updated to: 66.111.x.x

Before doing that, it had the IP from my dsl link at home, and I was trying the AUTO with the answer:
Please enter a valid IPv4 endpoint!

I thought it was because AUTO resolved to the same actual ipv4 endpoint. But to my surprise, after I changed via the tampa box, the command issued from here at home gave the same 'enter a valid IPv4' result!

Maybe it was some delay in syncing something of some sort. I waited a couple minutes and tried again with the same 'enter a valid' refuse message. Then I tried manually saying the IP address, only when it worked.

It seems the AUTO option is not working for some IPs.

My IP's first lines of whois information:
inetnum:     189.104/14
aut-num:     AS7738

The IP is under Nic.BR (I think it is like lac-nic or internic for the addresses of brazil).

Hope that information helps in identifying the problem!