Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Google Going Slow  (Read 9758 times)

comptech

  • Newbie
  • *
  • Posts: 31
Google Going Slow
« on: November 28, 2009, 07:11:18 PM »

I've noticed over the past week or so that all of my Google services are going a lot slower.  It's not a latency or DNS issue, Google's IPv6 servers just seem to be taking a lot longer to respond.  I'm still able to get 20Mbps down over my IPv6 tunnel, so it's not a bandwidth problem on my end.

Anyone else seeing this?  Anyone know what's going on?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2706
Re: Google Going Slow
« Reply #1 on: November 28, 2009, 07:54:47 PM »

yes i am seeing this problem...but for me, it started before last week.  it took close to 5 seconds just to load the home page, and searches also take several seconds to come back.  i have 3 T1s
Logged

piojan

  • Jr. Member
  • **
  • Posts: 85
Re: Google Going Slow
« Reply #2 on: November 29, 2009, 03:05:39 PM »

Might be some particular google datacenter having issues.
My nearest is fx - 2001:4860:a003::68 (frankfurt, de)
Try this link: http://[2001:4860:a003::68]/search?source=ig&hl=pl&rlz=&q=he.net&meta=lr%3D&aq=f&oq=
Loads quickly - at lest from the Europien side of the globe ;)

Edit: Had some problems making this an url - due to the [ ] in the address
« Last Edit: November 29, 2009, 03:09:07 PM by piojan »
Logged

comptech

  • Newbie
  • *
  • Posts: 31
Re: Google Going Slow
« Reply #3 on: November 29, 2009, 06:03:06 PM »

When I tried 2001:4860:a003::68 and browsed around on links within that IP pages loaded a lot faster.

These are the server's that I'm hitting in the U.S. that are going slow.
2001:4860:b007::67
2001:4860:b007::63
2001:4860:b007::93
2001:4860:b007::68
2001:4860:b007::69
2001:4860:b007::6a
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2706
Re: Google Going Slow
« Reply #4 on: November 30, 2009, 04:57:47 AM »

Yeah, I'd have to agree, the link that Piojan provided is faster than the servers I usually hit.
Logged

piojan

  • Jr. Member
  • **
  • Posts: 85
Re: Google Going Slow
« Reply #5 on: November 30, 2009, 06:17:15 AM »

I just did the same thing for the 2001:4860:b007::68 and even though it's on the other side of the globe, I haven't seen any performance impact.
I had sent emailes to google ipv6 address a few time and got replies - you could also point this out to them.
Howevere this might have been something temperary.
PJ
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2706
Re: Google Going Slow
« Reply #6 on: November 30, 2009, 06:19:25 AM »

I have noticed that if you use the "new" Google search page, it seems a little faster, but not much.

http://gizmodo.com/5412801/how-to-try-the-new-google-search
Logged

comptech

  • Newbie
  • *
  • Posts: 31
Re: Google Going Slow
« Reply #7 on: November 30, 2009, 12:27:06 PM »

I had sent emailes to google ipv6 address a few time and got replies - you could also point this out to them.

I've already let them know and sent them packet captures to try and find the problem.
Logged

comptech

  • Newbie
  • *
  • Posts: 31
Re: Google Going Slow
« Reply #8 on: December 03, 2009, 10:37:05 PM »

The problem was broken path MTU discovery between Google and me.
Setting the IPv6 MTU to 1280 on all the computers on my LAN fixed the problem.  Path MTU discovery is still broken but Google is back to the normal super fast speeds because their servers now know my MTU from the SYN packet MSS (Maxium Segment Size). Path MTU discovery is fine, see my post further down.  This fix is still needed in order for Google to respond fast, not sure why though?

Use this to find the interface index:
Code: [Select]
netsh interface ipv6 show interface
Windows XP:
Code: [Select]
ipv6 ifc [if index #] mtu 1280
Windows 7 and probably Vista as well:
Code: [Select]
netsh interface ipv6 set interface [if index #] mtu=1280
« Last Edit: December 05, 2009, 08:29:18 PM by comptech »
Logged

canal

  • readonly_member
  • Newbie
  • *
  • Posts: 1
Re: Google Going Slow
« Reply #9 on: December 05, 2009, 04:54:05 AM »

The problem was broken path MTU discovery between Google and me.
Setting the IPv6 MTU to 1280 on all the computers on my LAN fixed the problem (sort of).  Path MTU discovery is still broken but Google is back to the normal super fast speeds because their servers now know my MTU from the SYN packet MSS (Maxium Segment Size).

This command worked for my Windows XP boxes, haven't tried my Win 7 laptop yet. 
Code: [Select]
ipv6 ifc [if index #] mtu 1280

Good call! This did the job on my linux router:
Code: [Select]
ip6tables -t mangle -A FORWARD -o he-ipv6 -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --set-mss 1280
Logged

piojan

  • Jr. Member
  • **
  • Posts: 85
Re: Google Going Slow
« Reply #10 on: December 05, 2009, 09:52:25 AM »

There used to be a few topices about a feature request so that the user would be able to select there own MTU in HE tunnelbroker config. I would vote for that (and would probably set it to 1480).
Logged

brad

  • Jr. Member
  • **
  • Posts: 82
Re: Google Going Slow
« Reply #11 on: December 05, 2009, 12:45:32 PM »

There used to be a few topices about a feature request so that the user would be able to select there own MTU in HE tunnelbroker config. I would vote for that (and would probably set it to 1480).

Ya. I opened a thread requesting this feature quite awhile ago.
Logged

comptech

  • Newbie
  • *
  • Posts: 31
Re: Google Going Slow
« Reply #12 on: December 05, 2009, 07:41:35 PM »

piojan and brad, you got my thinking. 
I went and set my tunnel MTU to 1480 on my router and what do you know, my tunnel had 1480 as the MTU the whole time and I didn't know. 
My router was breaking Path MTU because of the MTU mismatch I introduced.  :-[
Logged