• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Win7-64bit + Teaming Adapters = NDIS 6.0 + FAIL... well not really

Started by Iohniron, January 29, 2010, 07:34:04 PM

Previous topic - Next topic


Hey guys and gals,

A little story, hopefully it assists someone...

I successfully created an IPv6 tunnel from Win7 64bit (Ultimate), but then I ran into a problem.. here's the lowdown.

I'm using a couple of onboard NICs with a AsusP7P55D Deluxe mobo.  The NICs are using the original RealTek drivers and teamed using the teaming_2005 app/driver/protocol for Realtek teaming NDIS 6.0. 
The Cisco RVS4000 (relatively inexpensive router/gateway for a home user) only needed the Multicast Passthrough Enabled, the Block WAN Request Disabled and the Dual-Stack radio button checked. 

I created a new tunnel, using my router's assigned IP and applied the settngs from Windows Vista/2008.  I copied the netsh output and pasted it into Powershell II, then changed the router IP to my machines IP 192.168.x.x

BAMM! success! I could get onto any ipv6.sweeet.com website I wanted.... nice now all I have to do is create my own ipv6 website and transfer a file, sounds easy enough but wait.. I can go faster. (so I thought, and that's when my idiot kicked in)

I tore apart my team and created a new team with modified properties on each adapter, but after creating the NDIS 6.0(#2) protocol my connection to ipv6 sites slowed to a crawl, probably nonexistant.  I came back to the site deleted and created a few tunnels, tore apart, uninstalled drivers and rebuilt the team a few times each time the teaming protocol number NDIS 6.0 (#3), (#4)... kept growing and I continued to get the output from PSII that the adapter already existed on the network and to join a workgroup in a domain or change the workgroup name.. ughh.

What's worse is that after I tried a few tricks ie. netsh interface ipv6 reset , and attempting a few more tunnel recreations I was banned from creating anymore tunnels for what I hope is only 24hours (could someone please fix that for me, thanks in advance).

Other than attempting to hack the crap out of bottomless registry and system directory in Windows 7, does anyone know how to reset a teaming protocol back to it's original ID?

I think, once I do that I should be able to reclaim my original tunnel (or perhaps create a new one). 

Any suggestions, hints or helps would be greatly appreciated.

- Iohniron




Any ideas on how I could remove adapter miniport adapter settings in win7-64bit?