• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Create my own tunnel broker -- add routable /64 to tunnel

Started by hisken, May 18, 2010, 12:01:43 PM

Previous topic - Next topic


Hello all,

This is the situation: I've got a colocated server with native IPv6 connectivity. From my ISP I got a fully routed /48. Let's call it 2001:1234:5678::/48. Currently I only use 2001:1234:5678:50::/64 on my server.

At home, I'd like to use one of those /64s. My home connection has got a static IPv4.

I was able to establish a 6in4 connection to my server using the following commands.

Commands on server:

ip tunnel add sit5 mode sit ttl 255 remote *REMOTE_IPv4* local *LOCAL_IPv4*
ip link set dev sit5 up
ip -6 addr add 2001:1234:5678:10::1/64 dev sit5
ip -6 route add 2001:1234:5678:10::/64 via 2001:1234:5678:10::2 dev sit5 metric 1

Commands on client at home:

ip tunnel add sit1 mode sit ttl 255 remote *REMOTE_IPv4* local *LOCAL_IPv4*
ip link set dev sit1 up
ip -6 addr add 2001:1234:5678:10::2/64 dev sit1
ip route add ::/0 via 2001:1234:5678:10::1

This works fine, but now I'd like to share a second /64 to advertise using radvd at home (just like with HE's tunnel broker: one /64 for the tunnel and one routable /64). So I tried adding an IP from a second /64 ( 2001:1234:5678:11:: ) to my eth0, and I enabled IPv6 forwarding. I configured radvd to advertise 2001:1234:5678:11::/64. At this point however, I'm stuck.

Computers at home get an IPv6 address using radvd, and they can ping the gateway at 2001:1234:5678:11::1 but they cannot reach the IPv6 internet.

I think I've got to route the second /64 on the server to the 6in4 interface (sit5 as stated above), but how to do so?

Doing this has no effect:
ip -6 route add 2001:1234:5678:11::/64 via 2001:1234:5678:10::2 dev sit5 metric 1
Executing the command mentioned above throws this error in:
RTNETLINK answers: No route to host

So, that's my problem  ???
How to route the second /64 like Hurricane Electric does?! I use Debian Lenny on this server.

Thanks in advance  :)


Heck - why am I always able to solve my problems after posting it on a forum.

For anyone else struggling with this, I provide here the solution.

This magic did the trick:
Quoteip -6 route add 2001:470:d18e::/64 dev sit5 metric 1

I did not need to specify a gateway - now it works perfectly!  :P