Hurricane Electric's IPv6 Tunnel Broker Forums

IPv6 Certification Program Topics => General Discussion => Topic started by: SakuyaIzayoi on November 20, 2011, 03:31:44 PM

Title: Daily reverse DNS test problem
Post by: SakuyaIzayoi on November 20, 2011, 03:31:44 PM
I can successfully pass every other test, except the one using dig -x. This is the output I'm getting:

Code: [Select]
; <<>> DiG 9.3.2 <<>> -x 2001:4860:800f::93
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 243
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;3.9.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.f.0.0.8.0.6.8.4.1.0.0.2.ip6.arpa. IN PT
R

;; ANSWER SECTION:
3.9.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.f.0.0.8.0.6.8.4.1.0.0.2.ip6.arpa. 86400
IN PTR iad04s01-in-x93.1e100.net.

;; Query time: 48 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sun Nov 20 18:31:02 2011
;; MSG SIZE  rcvd: 129

But the test fails due to a record mismatch. Is this something I'm doing wrong, or a problem on the other end? Thanks.
Title: Re: Daily reverse DNS test problem
Post by: broquea on November 20, 2011, 03:49:34 PM
Not certain, I just pasted the following and it worked without issue:

Code: [Select]
; <<>> DiG 9.4.2-P2.1 <<>> -x 2001:4860:800f::93
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45781
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;3.9.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.f.0.0.8.0.6.8.4.1.0.0.2.ip6.arpa. IN PTR

;; ANSWER SECTION:
3.9.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.f.0.0.8.0.6.8.4.1.0.0.2.ip6.arpa. 86400IN PTR iad04s01-in-x93.1e100.net.

;; Query time: 24 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sun Nov 20 15:47:42 2011
;; MSG SIZE  rcvd: 129

Looking at how both of ours are formatted, it looks like you have line-breaks after "PT" and "86400". Try making those whole complete lines.