Hurricane Electric's IPv6 Tunnel Broker Forums

General IPv6 Topics => IPv6 on Windows => Topic started by: Starry on August 28, 2014, 06:18:58 AM

Title: Tunnel does not work in Windows 8.1
Post by: Starry on August 28, 2014, 06:18:58 AM
I created a tunnel and successfully entered commands in cmd (because of using router and NAT I used private 192.168.1.100 IP). Tests show that I have no ipv6 connection and I need help to diagnose and solve the problem. I'm using Windows 8.1 64 bit, Binatone ADSL DM 856W Router.

C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Starz
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
   Physical Address. . . . . . . . . : (Removed)
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::344d:f8a0:97cc:5d00%3(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 27 August 2014 06:17:19 AM
   Lease Expires . . . . . . . . . . : 29 August 2014 03:10:51 PM
   Default Gateway . . . . . . . . . : fe80::ed2:b5ff:fe1b:cc78%3
                                       192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 54026359
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-D3-4E-D6-35-60-77-26-77-EB

   DNS Servers . . . . . . . . . . . : 59.185.3.11
                                       59.185.3.12
   NetBIOS over Tcpip. . . . . . . . : Enabled


Tunnel adapter IP6Tunnel:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Direct Point-to-point Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:470:1f10:d54::2(Preferred)
   Link-local IPv6 Address . . . . . : fe80::88f9:7770:6c5d:f3ef%21(Preferred)
   Default Gateway . . . . . . . . . : 2001:470:1f10:d54::1
   DHCPv6 IAID . . . . . . . . . . . : 352321536
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-D3-4E-D6-35-60-77-26-77-EB

   DNS Servers . . . . . . . . . . . : 59.185.3.11
                                       59.185.3.12
   NetBIOS over Tcpip. . . . . . . . : Disabled


C:\Windows\system32>netsh interface ipv6 show interfaces

Idx     Met         MTU          State                Name
---  ----------  ----------  ------------  ---------------------------
  3          20        1500  connected     Ethernet
  1          50  4294967295  connected     Loopback Pseudo-Interface 1
 13          50        1280  disconnected  isatap.{1EF55D2E-8495-464E-B9B7-C9073
0F0F1BC}
 21          25        1280  connected     IP6Tunnel


C:\Windows\system32>netsh interface ipv6 show address

Interface 3: Ethernet

Addr Type  DAD State   Valid Life Pref. Life Address
---------  ----------- ---------- ---------- ------------------------
Other      Preferred     infinite   infinite fe80::344d:f8a0:97cc:5d00%3


Interface 21: IP6Tunnel

Addr Type  DAD State   Valid Life Pref. Life Address
---------  ----------- ---------- ---------- ------------------------
Manual     Preferred     infinite   infinite 2001:470:1f10:d54::2
Other      Preferred     infinite   infinite fe80::88f9:7770:6c5d:f3ef%21


C:\Windows\system32>ping -6 ipv6.google.com

Pinging ipv6.l.google.com [2404:6800:4009:802::1008] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 2404:6800:4009:802::1008:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
Title: Re: Tunnel does not work in Windows 8.1
Post by: cholzhauer on August 28, 2014, 06:30:28 AM
Have you had another tunnel on a different os before?

Ideas:

Wrong ip endpoint with he
Router not passing protocol 41
Isp blocking proto41
Title: Re: Tunnel does not work in Windows 8.1
Post by: Starry on August 28, 2014, 06:57:58 AM
Thank you, cholzhauer for your prompt reply. I've had the tunnel working  in  the past on Windows 8.1 using a wireless 3G USB modem from another ISP. However I cannot not get it to work on my current ISP namely MTNL Mumbai. I've correctly updated my tunnel's IPv4 endpoint with HE, and my router does pass protocol 41. The issue could possibly be my present ISP blocking protocol 41, though I'm not too sure.
Title: Re: Tunnel does not work in Windows 8.1
Post by: cholzhauer on August 28, 2014, 07:02:16 AM
I'd either ask the isp or run a packet sniffer and see what you can see
Title: Re: Tunnel does not work in Windows 8.1
Post by: Starry on August 28, 2014, 04:49:19 PM
I found out that my ISP does not block protocol 41. To quote from their website:
Quote
Presently, ADSL Modems "Beetel 450TC1" & "Binatone DM 856W" being supplied by MTNL supports IPv6. Since, MTNL Broadband Network supports both the protocols i.e IPv4 & IPv6 you will continue to get the uninterrupted service.
Please help me get the tunnel to work.
Title: Re: Tunnel does not work in Windows 8.1
Post by: broquea on August 28, 2014, 05:41:43 PM
Paste the exact commands you ran. I'm wondering if you ran the commands from the broker without changing your IPv4 endpoint IP to your actual NATed IP of 192.168.1.100.
Title: Re: Tunnel does not work in Windows 8.1
Post by: Starry on August 28, 2014, 05:48:49 PM
The exact commands that I ran for the tunnel are:

netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel 192.168.1.100 184.X.X.X
netsh interface ipv6 add address IP6Tunnel 2001:470:1f10:d54::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f10:d54::1

All the commands were successfully run with 'Ok.' response. However, tests show that I have no ipv6 connection.
Title: Re: Tunnel does not work in Windows 8.1
Post by: broquea on August 28, 2014, 06:14:16 PM
Then I'd start researching into any Windows 8.1 firewalling for IPv4/IPv6, or if the commands need to be run any differently. These were based on Vista/7.
Title: Re: Tunnel does not work in Windows 8.1
Post by: broquea on September 08, 2014, 06:37:01 PM
There is also the chance that whatever your NAT appliance is (assuming the Binatone ADSL DM 856W Router), doesn't forward Protocol 41 packets to hosts behind it. Remember, Protocol, not TCP/UDP ports.
Title: Re: Tunnel does not work in Windows 8.1
Post by: malagaspain on September 09, 2014, 01:14:30 AM
Why not just use IPV6 supplied from your ISP via your router?
Title: Re: Tunnel does not work in Windows 8.1
Post by: Starry on September 09, 2014, 05:17:24 PM
broquea: thank you for your replies, I suppose its my router's fault. malagaspain: my ISP did not provide me with an IPv6 address contrary to their website claiming to do so, their customer care seems clueless about it & weren't of much help in getting it to work despite my calls & emails to them. Besides, I find Tunnelbroker's service to be superior to the IPv6 provided by my ISP in the sense that I can assign my own rDNS Delegations/Nameservers to HE's tunnels which allows for the creation of custom virtual hosts from the IPv6 blocks given to me by Tunnelbroker. On the other hand, the IPv6 provided by my ISP cannot be assigned a virtual host which would reverse resolve.