Hurricane Electric's IPv6 Tunnel Broker Forums

General IPv6 Topics => IPv6 on Windows => Topic started by: zwitterions on June 15, 2015, 06:30:23 AM

Title: IPv6 tunnel config, in windows 10 ver 10130.
Post by: zwitterions on June 15, 2015, 06:30:23 AM
Hello all!

Does anyone know the config options for setting up a tunnel in Window 10 ver trial 10130?

Any help would be great!

Regards..
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: cholzhauer on June 15, 2015, 06:31:59 AM
I'd imagine the same commands that you use for Vista/7/8 will work
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: zwitterions on June 17, 2015, 07:44:13 AM
Thanks for the reply, you would think so as well, but no, the same settings do not work..  again any help would be great, as you  must know help on win 10 insider pro is not in large quantities.

Regards

Andrew
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: cholzhauer on June 17, 2015, 07:44:55 AM
I'll try to help...what errors are you getting?
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: Lupo on June 29, 2015, 09:36:09 AM
It seems that in Windows 10 there is a new implementation of netsh.

I've been following the progress of the issue as well, as it completely hinders the ability to set up ipv6 tunnels..
As of the latest (10130 at the time of posting this) build, they fixed the crash that was present in the previous versions,
but it's just because now the command returns a "Not Implemented" error instead of executing and crashing.

Code: [Select]
C:\WINDOWS\system32>netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel 10.0.0.2 216.66.80.26
Not implemented

Hopefully it will be fixed soon.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: Lupo on July 06, 2015, 12:30:28 AM
Updating with some more testing on the new build 10162.

That command now returns this:
Code: [Select]
C:\Windows\system32>netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel 10.0.0.2 216.66.80.26
The function attempted to use a name that is reserved for use by another transaction.
This was on a fresh install.

Each time the command is ran, it will create an additional interface in Device Manager -> Network Adapters, but none of them will work.
This bug is getting quite worrying, as the release date draws closer.



EDIT -
Well, this is embarassing, and really weird. I've been trying different things for a couple days before posting this message, and I always had the same result.
I tried -again- just as I was typing, to copy the error message..

And, well.. I tried again after posting.. it went through. It properly created the interface, and it works. I did not change any setting, nor any connected device or anything.
I did nothing different than 5 minutes ago. just deleted the broken interface in device manager, and tried adding v6v4tunnel again.

I'm not sure if it will work again if I try to remove it. If nobody is interested in proper troubleshooting, I'll just leave it there since having working ipv6 is more important to me
than mere personal curiosity.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: PanicPaintbrush on July 30, 2015, 12:57:12 AM
I'm on the release version of Windows 10 and I'm getting the same errors. Does anyone know how to get it to work?

Code: [Select]
C:\WINDOWS\system32>netsh interface teredo set state disabled
Ok.

C:\WINDOWS\system32>netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel 101.166.41.94 216.218.221.42
The function attempted to use a name that is reserved for use by another transaction.

C:\WINDOWS\system32>netsh interface ipv6 add address IP6Tunnel 2001:470:35:f5a::2
The filename, directory name, or volume label syntax is incorrect.


C:\WINDOWS\system32>netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:35:f5a::1
The filename, directory name, or volume label syntax is incorrect.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: iannet on July 30, 2015, 10:37:33 AM
Have the same issue on release build of Windows 10 ... has netsh functionality changed?
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: cholzhauer on July 30, 2015, 11:54:50 AM
If you run netsh in Win10, there's a warning that it might be pulled from future versions of Windows and that you should user PowerShell instead.

Code: [Select]
netsh>int
In future versions of Windows, Microsoft might remove the Netsh functionality
for TCP/IP.

Microsoft recommends that you transition to Windows PowerShell if you currently
use netsh to configure and manage TCP/IP.

Type Get-Command -Module NetTCPIP at the Windows PowerShell prompt to view
a list of commands to manage TCP/IP.

Visit http://go.microsoft.com/fwlink/?LinkId=217627 for additional information
about PowerShell commands for TCP/IP.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: Noetzel on July 31, 2015, 04:55:45 AM
Hello everyone,

I'm having the same issue with the same results (except mine has not gone through yet on it's own, :)).

I've tried in both the standard cmd line and in powershell, makes no difference.  Same "reserved" blah-blah and a disconnected media PTP interface is added.

Only on Windows 10, ;)
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: phedz on July 31, 2015, 08:17:35 PM
so yeah, the way I did it is replace add v6v4tunnel IP6Tunnel x.x.x.x x.x.x.x with add v6v4tunnel "Private" x.x.x.x x.x.x.x to get past the first error, then just replace the other two lines with "Private" instead of IP6Tunnel.

Happy IPv6'ing
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: Noetzel on July 31, 2015, 10:11:06 PM
phedz:  glad that worked for you!  I tried the same thing (substituting "Private" for the tunnel name) and, unfortunately, got the same result again.  :(

"The function attempted to use a name that is reserved for use by another transaction."  and the addition of a disconnected tunnel adapter local area connection* device.

I did successfully add the TAP-Windows Adapter V9 to use a SIXXS tunnel, but haven't been able to get that one to talk outside of the local machine yet.  I'd like to see if we can figure out the HE 6in4 solution, though.

Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: iannet on August 01, 2015, 05:27:04 AM
After numerous tries using the "Private" method worked! I did nothing different, seems there is something wrong in Win10

One interesting point is that it seems Microsoft Edge does not support ipv6 ... at least it's using ipv4 and could not find any setting anywhere.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: cholzhauer on August 01, 2015, 06:43:40 PM
Quote
One interesting point is that it seems Microsoft Edge does not support ipv6 ... at least it's using ipv4 and could not find any setting anywhere.

Not true.  Just tried it with a http://[ipv6address] and it works fine.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: Noetzel on August 02, 2015, 03:29:37 PM
Actually having an intermittent issue like this is really not good.  Can't imagine what conditions might be that somehow repeated attempts finally works, hmmmm...

I've tried three different machines all with the distribution version of Win10 and probably 35 different attempts.  No go, same error and results.  Thinking an existing Local Area Connection might somehow interfere, I've deleted all interfaces, reset the stack and tried to install the 6in4 as the only interface.  Same result as before.

A stumper for me at this point.  Any help from anywhere would be appreciated!  Thanks in advance.  :)
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: zwitterions on August 03, 2015, 09:17:05 AM
I thank everyone on this issue with Windows 10, but i can not seem to get around it, has anyone come up with a script to make it work?

Any help would be much App!
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: ellegi on August 04, 2015, 02:57:43 AM
doesn't work for me with "Private"   :-\
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: ellegi on August 16, 2015, 11:48:07 AM
I'm investigating for the problem.

After launching the netsh command and opening the driver debug log file c:\windows\inf\setupapi.dev.log

i see this  0x00000005 "Access denied" error. Tell me if someone here have the same problem.

>>>  [Configure Driver Package - c:\windows\system32\driverstore\filerepository\nettun.inf_amd64_73be4b5cbfb3a9a0\nettun.inf]
>>>  Section start 2015/08/04 23:40:28.022
      cmd: netsh  interface ipv6 add v6v4tunnel "Private" 192.168.1.15 1.2.3.4
     sto: Source Filter  = TUNDIRECT.ndi
     sto: Target Filter  = ROOT\*TUNDIRECT\0000
     inf: Class GUID     = {4d36e972-e325-11ce-bfc1-08002be10318}
     inf: Class Options  = Configurable
!!!  idb: Failed to open driver package object 'nettun.inf_amd64_73be4b5cbfb3a9a0'. Error = 0x00000005
<<<  Section end 2015/08/04 23:40:28.038
<<<  [Exit status: FAILURE(0x00000005)]


Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: LVNeptune on August 16, 2015, 11:58:37 AM
[Boot Session: 2015/08/16 11:53:03.493]

>>>  [Configure Driver Package - c:\windows\system32\driverstore\filerepository\nettun.inf_amd64_73be4b5cbfb3a9a0\nettun.inf]
>>>  Section start 2015/08/16 11:54:30.082
      cmd: netsh  interface ipv6 add v6v4tunnel "Private" 192.168.2.138 x.x.x.x
     sto: Source Filter  = TUNDIRECT.ndi
     sto: Target Filter  = ROOT\*TUNDIRECT\0000
     inf: Class GUID     = {4d36e972-e325-11ce-bfc1-08002be10318}
     inf: Class Options  = Configurable
!!!  idb: Failed to open driver package object 'nettun.inf_amd64_73be4b5cbfb3a9a0'. Error = 0x00000005
<<<  Section end 2015/08/16 11:54:30.099
<<<  [Exit status: FAILURE(0x00000005)]
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: th3cr3a7or on August 17, 2015, 07:58:36 PM
I used the following defined commands to get it configured correctly
netsh teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface= private localaddress= "Your local address" remoteaddress= "remote address given to you"
netsh interface ipv6 add address interface= private address= 2001:470:1c:211::2
netsh interface ipv6 add route prefix= ::/0 interface= private nexthop= 2001:470:1c:211::1
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: abuson on August 18, 2015, 08:57:01 AM
I used the following defined commands to get it configured correctly
netsh teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface= private localaddress= "Your local address" remoteaddress= "remote address given to you"
netsh interface ipv6 add address interface= private address= 2001:470:1c:211::2
netsh interface ipv6 add route prefix= ::/0 interface= private nexthop= 2001:470:1c:211::1

Thanks, this actually works!!

Small fixes + you don't have to use private, it works with interface name - IP6Tunnel too:
netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel localaddress=LocalIPv4 remoteaddress=RemoteIPv4
netsh interface ipv6 add address interface=IP6Tunnel  address=2001:470:1c:211::2
netsh interface ipv6 add route prefix=::/0 interface=IP6Tunnel nexthop=2001:470:1c:211::1
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: LVNeptune on August 18, 2015, 09:03:21 PM
Yea that's a negative. still same errors as before.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: LVNeptune on August 18, 2015, 09:15:41 PM
So I figured out that every time I ran the add v6v4tunnel command it was adding a subinterface but NOT naming it to what I named.

netsh interface ipv6 show subinterface

this command shows the new "Local Area Connect *X" that was added. If you replace the interface="enter full lan name here" it should work for you.

No clue what's up with stuff not working for everyone though. Really makes little to no sense.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: ellegi on August 19, 2015, 12:56:45 AM
So I figured out that every time I ran the add v6v4tunnel command it was adding a subinterface but NOT naming it to what I named.

netsh interface ipv6 show subinterface

this command shows the new "Local Area Connect *X" that was added. If you replace the interface="enter full lan name here" it should work for you.

No clue what's up with stuff not working for everyone though. Really makes little to no sense.

same problem here.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: zwitterions on August 19, 2015, 04:22:47 AM
Hi ALL.

I have tried everything in this post, and the new example in the win 10 example, i can only guess it is because i use a VPN  all the time, it shows that i have bytes out in 6to4 adapter, none in, i am going to get on to Microsoft tech support, and get to the bottom of this. I also can not see why some people are getting it to work, and others like myself are not, i am on full windows 10 now, and nothing makes it work! I thank everyone who has put forward there ideas and configs, if i get a response from Microsoft, i will post it back here today.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: 3mook06 on August 20, 2015, 02:13:34 AM
Hey all, im pretty bad with the command line stuff, just gonna post the error i had and see if anyone has any ideas.
---
Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\Windows\system32>netsh interface teredo set state disabled
Ok.

C:\Windows\system32>netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel localaddress=192.168.1.101 remoteaddress=216.66.80.90
The function attempted to use a name that is reserved for use by another transaction.
---
^that last line is the error, cant seem to get around it, thanks all



EDIT: ok i think i have fixed it somewhat after much fiddling

1: in device manager, view - show hidden devices
2: uninstall all the "Microsoft Direct Point-to-point Adapter"
3: uninstall all the "Microsoft ISATAP Adapter"
4: Reboot
5: Command Prompt as Admin the following:

netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface="private" localaddress=192.168.1.101 remoteaddress=216.66.80.90
netsh interface ipv6 add address interface="private" address=2001:470:27:19c::2
netsh interface ipv6 add route prefix=::/0 interface="private" nexthop=2001:470:27:19c::1

^so yeah i needed quotes on private, IP6Tunnel would not work for me

6: i had some issues getting anything to use ipv6, so i manually added google ipv6 DNS to my network adapter (2001:4860:4860::8888) and (2001:4860:4860::8844)

seems good enough for now
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: zwitterions on August 26, 2015, 12:39:38 AM
Hi all, i have tried everything possible, and can not get it to work, i see a lot of people saying add private address, however i use a static address, i mean most of us are sages, and i can not see why either one of us sages, or hurricane does not put up a working example. Just a thought, i mean what good are we "Sages" if we can not get this working?

I do thank everyone's input, but were is the Eisenstein out there with us sages?

I am putting off upgrading my other win7 ultimate boxes, for fear of losing my IPv6 i get a lot of IPv6 traffic, and need to keep it there.

PLEASE, some one out there has cracked this..
Regards
Zwitterions
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: ellegi on August 26, 2015, 02:45:13 AM
Me in the same situation. Tried everything: copied old tunnel.sys drivers, changed something in windows registry, but it is a huge problem caused by microsoft and we should complain with them.

At the moment i've temporary solved configuring the oèv6 tunnel on a linux box and routing through vpn.

Hi all, i have tried everything possible, and can not get it to work, i see a lot of people saying add private address, however i use a static address, i mean most of us are sages, and i can not see why either one of us sages, or hurricane does not put up a working example. Just a thought, i mean what good are we "Sages" if we can not get this working?

I do thank everyone's input, but were is the Eisenstein out there with us sages?

I am putting off upgrading my other win7 ultimate boxes, for fear of losing my IPv6 i get a lot of IPv6 traffic, and need to keep it there.

PLEASE, some one out there has cracked this..
Regards
Zwitterions
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: Lupo on August 27, 2015, 01:41:42 PM
Possibly good news for everyone that was experiencing this issue.

After the latest three updates pushed today (KB3081448, KB3081449, KB3081452), I was able to consistently create and delete v6v4tunnel interfaces.
No change in the syntax from what we always used. It seems they fixed whatever problem was preventing it from working correctly.

I tested multiple times, on two computers that were unable to create the interface before, and both instances went through with no issues.

Hopefully this was a global fix, and not just luck on my side.
Regards.


Edit: only one weird thing.. I had to set a dns address in the ipv6 configuration for it to properly work.. Just having ipv6 enabled global dns seems to not work properly for me.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: ellegi on August 27, 2015, 02:34:59 PM
Great. it works!

I have the same problem with dns. What commands you have used to set dns for the specified interface?


Possibly good news for everyone that was experiencing this issue.

After the latest three updates pushed today (KB3081448, KB3081449, KB3081452), I was able to consistently create and delete v6v4tunnel interfaces.
No change in the syntax from what we always used. It seems they fixed whatever problem was preventing it from working correctly.

I tested multiple times, on two computers that were unable to create the interface before, and both instances went through with no issues.

Hopefully this was a global fix, and not just luck on my side.
Regards.


Edit: only one weird thing.. I had to set a dns address in the ipv6 configuration for it to properly work.. Just having ipv6 enabled global dns seems to not work properly for me.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: Lupo on August 27, 2015, 03:10:51 PM
I just added he.net's dns in the ipv6 section of my NIC in the graphical interface, was a quick test and it worked.

Walkthrough, just in case:
Network and Sharing Center -> Change Adapter Settings -> Right click on NIC, Properties -> Double click Internet Protocol Version 6 -> paste 2001:470:20::2 in the dns address.

If there is a better way with netsh, I haven't encountered it yet.
If someone with better knowledge could post the netsh command to add the dns server ONLY to the ipv6 tunnel, and not as global, it would be greatly appreciated.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: ellegi on August 28, 2015, 12:26:09 AM
Yes, it works.
I tried also with netsh int ipv6 set dnsservers name="IP6Tunnel" static 2001:470:20::2 primary. It will not gave me errors but if i execute netsh int ipv6 sh dnsserver the settings is not here.

I just added he.net's dns in the ipv6 section of my NIC in the graphical interface, was a quick test and it worked.

Walkthrough, just in case:
Network and Sharing Center -> Change Adapter Settings -> Right click on NIC, Properties -> Double click Internet Protocol Version 6 -> paste 2001:470:20::2 in the dns address.

If there is a better way with netsh, I haven't encountered it yet.
If someone with better knowledge could post the netsh command to add the dns server ONLY to the ipv6 tunnel, and not as global, it would be greatly appreciated.
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: bolvan on October 04, 2015, 10:22:36 AM
hi all !

Today is 4th of October and "the function attempted to use a name that is reserved for use by another transaction." problem is still there.
I tried 3 copies of win10, updated all, and only one of them succeeded to add 6in4 tunnel. It was enterprise LTSB x64.
But still there's huge problem.
When resolving a domain with both A and AAAA records, system does not query both records, just A.
For example, if "ping google.com" then it will ping ipv4 address.
In wireshark I see only A lookup and no AAAA.
Only if A lookup fails then it tries to lookup up AAAA.
In all previous version windows system tries both A and AAAA and chooses ipv4 or ipv6 based on the prefix preference table.
I reproduced in windows 10 the same preference table as it was in 8.1, but no success.

In case of native connection (ipv6 and ipv4 on the same adapter) things work as expected.

Win 10 is buggy, i understand now why they are not releasing server in parallel as they always did
Title: Re: IPv6 tunnel config, in windows 10 ver 10130.
Post by: bolvan on October 06, 2015, 11:50:06 PM
Looks like windows 10 cannot prioritize ipv6 over ipv4 if they are provided on different interfaces.
Simple experiment.

Imagine there's LAN subnet with IPV6 stateless configuration router and IPV4 NAT.
You have win 10 VM with 2 virtual adapters. On one of them only ipv4 enabled, on another one - only ipv6.

Code: [Select]
Ethernet Ethernet0:

   IPv6-address. . . . . . . . . . . . : 2001:470:yyyy:yyyy:xxxx:xxxx:xxxx:xxxx
   IPv6-address. . . . . . . . . . . . : 2002:yyyy:yyyy:1:xxxx:xxxx:xxxx:xxxx

Ethernet Ethernet1:

   IPv4-address. . . . . . . . . . . . : 192.168.1.20
   Subnet mastk  . . . . . . . . . . . : 255.255.255.0
   Default gateway   . . . . . . . . . : 192.168.1.1

Windows cannot choose ipv6 by default in such situation :

Code: [Select]
X:\>ping -6 vk.com

Pinging vk.com [2a00:bdc0:3:103:1:0:403:907] with 32 bytes of data:
Reply from 2a00:bdc0:3:103:1:0:403:907: time=45ms

X:\>ping vk.com

Pinging vk.com [87.240.131.97] with 32 bytes of data:
Reply from 87.240.131.97: bytes=32 time=10ms TTL=58


Now I leave only one adatper :

Code: [Select]
Ethernet Ethernet0:

   IPv6-address. . . . . . . . . . . . : 2001:470:yyyy:yyyy:xxxx:xxxx:xxxx:xxxx
   IPv6-address. . . . . . . . . . . . : 2002:yyyy:yyyy:1:xxxx:xxxx:xxxx:xxxx
   IPv4-address. . . . . . . . . . . . : 192.168.1.20
   Subnet mastk  . . . . . . . . . . . : 255.255.255.0
   Default gateway   . . . . . . . . . : 192.168.1.1

Windows prefer ipv6 over ipv4 :

Code: [Select]
X:\>ping -4 vk.com

Pinging vk.com [87.240.131.97] with 32 bytes of data:
Reply from 87.240.131.97: bytes=32 time=10ms TTL=58

X:\>ping vk.com

Pinging vk.com [2a00:bdc0:3:103:1:0:403:907] with 32 bytes of data:
Reply from 2a00:bdc0:3:103:1:0:403:907: time=45ms