Hurricane Electric's IPv6 Tunnel Broker Forums

General IPv6 Topics => IPv6 on Windows => Topic started by: masterwane on October 19, 2017, 04:44:08 PM

Title: Works fine on Debian but can not get to work on Windows 10
Post by: masterwane on October 19, 2017, 04:44:08 PM
I have 4 computers at my house, 2 of them are Debian and the other two are Windows. I have IPv6 working with no problems on the two Debian machines, but on Windows, I have had no success. Here is what I have done.

Code: [Select]
netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel interface=IP6Tunnel localaddress=192.168.1.104 remoteaddress=209.51.161.14
netsh interface ipv6 add address interface=IP6Tunnel address=2001:470:1f06:282::4
netsh interface ipv6 add route prefix=::/0 interface=IP6Tunnel nexthop=2001:470:1f06:282::1

Everything executed with no problems, but I still don't have IPv6 internet connection. Any idea how I can troubleshoot this?
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: kcochran on October 19, 2017, 05:43:24 PM
As long as they're all on the same LAN, setup one for the tunnel, and have it be the router for the rest of them.  Then they think they're native, and you have a simpler configuration all around.
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: masterwane on October 19, 2017, 09:00:22 PM
As long as they're all on the same LAN, setup one for the tunnel, and have it be the router for the rest of them.  Then they think they're native, and you have a simpler configuration all around.

For that I would need a computer for multiple NIC cards right?
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: cholzhauer on October 20, 2017, 05:01:24 AM
No, you can do it with one NIC
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: masterwane on October 20, 2017, 06:02:43 AM
No, you can do it with one NIC

Are there any instructions posted about this anywhere?
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: cholzhauer on October 20, 2017, 06:13:18 AM
You create the tunnel like you attempted to above...this uses a virtual interface based off the physical.

You then setup your physical interface with an IP from the routed /64 and point all of your clients at that.  If you need more than one subnet, use the /48
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: masterwane on October 20, 2017, 03:19:33 PM
You create the tunnel like you attempted to above...this uses a virtual interface based off the physical.

You then setup your physical interface with an IP from the routed /64 and point all of your clients at that.  If you need more than one subnet, use the /48

On my main actual interface, I gave a static IPv6 ip '2001:470:1f06:282::4' to the interface. And for the gateway IP, I gave the IPv6 ip which is working on my Linux machine in this case '2001:470:1f06:282::2', is that what I was supposed to do?
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: cholzhauer on October 20, 2017, 03:44:58 PM
Is that IP in use anywhere else?  You mention you had other tunnels in use at one point
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: masterwane on October 20, 2017, 05:09:34 PM
Is that IP in use anywhere else?  You mention you had other tunnels in use at one point

No, I am using '2001:470:1f06:282::3' and '2001:470:1f06:282::2' on the other machines which have Debian on them. However when I did add the static IP, Windows did complain that it's being used by the virtual adapter, should I remove the virtual adapter? Also I am using the ''2001:470:1f06:282::2' which is the IP used on one the Debian machines as a gateway address from the Windows machine. Am I supposed to do that for the gateway address?
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: cholzhauer on October 21, 2017, 06:20:02 AM
So your setup should be something like this:  Tunnel is terminated on your "router", whichever computer you deem that to be.  After you have the tunnel working on there, you tell the router to hand out addresses to the rest of your network...the easiest way to do that is via router advertisements.  (And make sure you enable forwarding..there are a bunch of sites online that will walk through this)  After you have this done, your computers will route IPv6 traffic to your router and out to the Internet.
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: masterwane on October 21, 2017, 08:53:06 AM
So your setup should be something like this:  Tunnel is terminated on your "router", whichever computer you deem that to be.  After you have the tunnel working on there, you tell the router to hand out addresses to the rest of your network...the easiest way to do that is via router advertisements.  (And make sure you enable forwarding..there are a bunch of sites online that will walk through this)  After you have this done, your computers will route IPv6 traffic to your router and out to the Internet.

Has anyone succeeded getting this to work on Windows 10 without using another machine in the LAN? I travel often and it would be great if I can get it working from Windows 10 directly. That way I will have IPv6 any new place I go.
Title: Re: Works fine on Debian but can not get to work on Windows 10
Post by: divad27182 on October 21, 2017, 02:14:43 PM
On my main actual interface, I gave a static IPv6 ip '2001:470:1f06:282::4' to the interface. And for the gateway IP, I gave the IPv6 ip which is working on my Linux machine in this case '2001:470:1f06:282::2', is that what I was supposed to do?

I believe 2001:470:1f06::/48 is the transit networks off the New York City tunnelbroker.  You cannot give any other addresses on that subnet.  i.e. 2001:470:1f06:282::4 is improper.  You are assigned a second subnet, probably 2001:470:1f07:282::/64 that you may allocate addresses in, and have your machine that is 2001:470:1f06:282::2 route to and from.