Hurricane Electric's IPv6 Tunnel Broker Forums

General IPv6 Topics => IPv6 on Routing Platforms => Topic started by: rxforcomputers on June 12, 2011, 11:40:57 AM

Title: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 12, 2011, 11:40:57 AM
I've just installed a new Cisco RV220W replacing a WRVS4400N on which I had a working TunnelBroker tunnel with a routed /48. I'm looking for any information to both setup the tunnel on this router and get the DHCPv6 leases working on this new hardware and am coming up empty handed. Any help or steerage would be greatly appreciated!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 22, 2011, 12:43:46 PM
With the help of this document: https://supportforums.cisco.com/docs/DOC-17069 I managed to setup the tunnel on the router.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 22, 2011, 01:06:42 PM
Thanks SO much for the reply. Looks like this document you found was hot off the press, looking at the date! I have a few questions for you (kauwen), however (please!) ...

1) was the 6to4 that you setup between private routers, or to a tunnel broker such as HE ?

2) on page four of the document, the field IPv6 Destination, is this the IPv6 address of the far side (Server's IPv6 Address)? I'm expecting so ...

3) on the same page (4), what address did you put into the IPv6 Gateway field?

While the document goes through the "high level" configuration, it gives no detail as to what variables the blanks on the pages to be filled in with.

Thanks for your time and information. I very much appreciate your posting this!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 23, 2011, 11:37:46 AM
1) was the 6to4 that you setup between private routers, or to a tunnel broker such as HE ?
I configured the (HE) tunnel with it

2) on page four of the document, the field IPv6 Destination, is this the IPv6 address of the far side (Server's IPv6 Address)?
This is the subnet you want to route through the tunnel. I guess you want all ipv6 go through the tunnel so specify 0:: for destination and 0 for prefix length.

on the same page (4), what address did you put into the IPv6 Gateway field?
::216.66.84.46. This is the ipv4 server address of my tunnel.

Hope this helps :)

Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 24, 2011, 07:52:24 PM
@kauwen -- Thanks for the reply. I must be overlooking some other setting in some other screen that was not discussed in the documentation that you referred to. Although is was helpful, there are several other IPv6 related configuration screens that aren't covered, and my limited v6 experience is no help. Unfortunately, I just spent an hour and a half with no results in tunneling. My router was DHCPing fine, but the tunnel never came up. I did notice that the WAN v4 IP of my router had changed since applying for my tunnel so I went to TunnelBroker and changed to my current v4 address and it was accepted, so I'm assuming that communication between HE and myself was successful.

Guess I'm back to searching for some "more thorough" documentation for this setup and router. If anyone has any pointers or advice it would be very much appreciated!

Cheers!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 25, 2011, 05:10:53 AM
There are no other settings that should be changed.
But what firmware are you on? And how do you determine if the tunnel is up?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 25, 2011, 06:05:56 AM
Admittedly, I realized after posting that I omitted my firmware version and was going to edit my post this morning to mention -- fw 1.0.1.0. So, my configuration screens don't "exactly" match that in the documentation, but it's not that hard to figure the equivalent settings in my screens.

As for the test, I used to do two tests when using my old router which I had a working tunnel on. I would try to do a ping to the "HE v6 DNS server" (normally would receive a response) and I would do an "nslookup" of a v6 host (ipv6.google.com -- normally would resolve). After attempting the tunnel configuration last night, both of these tests would fail with errors indicating "unreachable" on my PC (W7) after I renewed and checked my IP address on it (the IP lease info all looked good on my host, BTW). Also worth noting and something that would be part of the testing is that once my host leased its info from the router, even trying to hit any v4 Internet host, such as www.tunnelbroker.net, I would notice a long lag before activity (loading of the page), obiously having to wait for the first v6 nameserver lookup to timeout before my PC would move on to the v4 nameserver lookup and succeeding.

On the main Status Summary page in the router, the v6 tunnel status doesn't indicate that it is "up" either, even though on the ISATAP Tunnel page it shows "active", but of course this just means that the defined tunnel is switched on.

Anyway, I hope that this is enough to give you answers to your questions. I'm open to any suggestions. Thanks!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 25, 2011, 10:44:34 AM
I'm on the same firmware.

I don't have a tunnel status on the main status page and I don't have an ISATAP tunnel. Did you create an ISATAP tunnel?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 25, 2011, 11:21:06 AM
I had no other tunnel-type to pick -- no choice. This was the type of tunnel that it created. Did I do something wrong, possibly, earlier in the configuration that caused it to come out as an ISATAP?

Thanks for hanging with me through this!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 25, 2011, 03:09:01 PM
The static route you add at step 4 of the before mentioned document is the tunnel.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 25, 2011, 07:55:12 PM
Thanks, I'll give it another shot in the morning and let you know the outcome. Looking forward to getting this to work. It's possible that when I was on the "Step 5" screen I may have gotten carried away and added an ISATAP.  ???
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 26, 2011, 04:30:59 PM
OK. I've given it another try and still no-go ...

One thing worth noting, before I forget, is that I have a routed /48 associated with my tunnel ... do I maybe need to turn this off on the HE side and run with only the /64?

Again on page four, I have set, under IPv6 Static Routing, the IPv6 Destination to "0::" as you advised, and this seems right to me after giving it some thought ...

I've set "6 to 4 Tunneling" to "Automatic Tunneling = check".  Of course in our firmware version this is the only thing on this screen, none of the other selections or configuration  in step 5 appear ...

Advertisement Prefixes section, although different than the screenshot in the document, I added one equivalent to that of the screenshot ...

In the Router Advertisement screen I have configured it exactly as shown, except for our firmware not having a checkbox to Enable, I set RADVD Status to enable ... I even put a check in the Other box (which was not checked) for the RA Flags ...

And of course, I've enabled Dual-Stack in the router.

The only thing that is different this time around is that I'm not experiencing the "lag" when I attempt to go to any website. The v6 lookup fails instantly, my PC moves on the v4 DNS lookup and pages load right away. Attempting a ping on 2001:470:20::2 (from W7 PC) I get "PING: transmit failed. General failure", and trying an NSLOOKUP of "ipv6.google.com" I get "UnKnown can't find ipv6.google.com: No response from server".

One thing I'll also want to address, at some time after the tunnel is working, is to get the leasing of the /48 prefix to my clients if this subnet is to be kept in play. I'd like details of the correct way to setup v6 DHCP in this equipment, if possible.

Since this current configuration is not affecting, what seems to be, the normal operation of my network I'm leaving it in place so trying quick changes should not be a problem or time consuming.

So, once again thanks and I'm still open to any and all suggestions  ::)

Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 27, 2011, 04:48:06 AM
Oh, one more question that my have something to do with my tunnel failure. What do your settings look like under Networking > WAN > IPv6 WAN Configuration?

In this section I've set the WAN Configuration Type to "Static IPv6", the IPv6 Address to my "HE Client IPv6 Address", Prefix Length of course to 64, the Default IPv6 Gateway to the "HE Server IPv6 Address" and the Primary DNS Server to the "Anycast IPv6Cashing Nameserver" (2001:470:20::2). The DHCPv6 Address Settings are dimmed and can't be set since I've chosen "Static" in the first selection on this page ...

If your working settings are otherwise please advise.

Thanks
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 27, 2011, 10:52:46 AM
One thing worth noting, before I forget, is that I have a routed /48 associated with my tunnel ... do I maybe need to turn this off on the HE side and run with only the /64?
I don't know I only use /64

Advertisement Prefixes section, although different than the screenshot in the document, I added one equivalent to that of the screenshot ...
I didn't do that, some way the address is picked up or calculated automatically

Attempting a ping on 2001:470:20::2 (from W7 PC) I get "PING: transmit failed. General failure"
I experience that often the first time I use ipv6. A second try will work (also the status of the adapter for ipv6 connectivity changes from 'no internet connection' to 'internet'.

One thing I'll also want to address, at some time after the tunnel is working, is to get the leasing of the /48 prefix to my clients if this subnet is to be kept in play. I'd like details of the correct way to setup v6 DHCP in this equipment, if possible.
I don't think that is really needed. Router advertisement is enough.

What do your settings look like under Networking > WAN > IPv6 WAN Configuration?
Just left it on dhcpv6. This is really not needed, if we had a ipv6 wan connection we didn't need a tunnel ;)

Just some more observation:
Some computers on my network only started to work after reboot of the router.
Check if the client computers get an ipv6 address in the range advertised by the router.



Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 27, 2011, 07:15:40 PM
OK, I've removed all of these other, supposedly irrelevant, settings that I had mistakenly put into the configuration and still not working, unfortunately. So this brings me, hopefully, to one last question ...

On the screen Networking > IPv6 > IPv6 Static Routing, I've set the IPv6Gateway to the HE endpoint server's v4 address, in the form of "::216.218.224.42". After setting this address in this field, the only thing that the GUI will let me choose without error for the line directly above it, Interface drop down, is "sit0 WAN". Is this how your's is set?

Now that I have culled out all of my FUBAR settings, the end just doesn't seem like very much configuration to get a tunnel working! Can't believe that it should be this easy ... if this works, I'll be thoroughly impressed with "Automatic Tunneling".

Cheers, Mark

EDIT -- and, BTW, now with the current configuration the only IPv6 address my clients (PCs) are getting is Link-Local, nothing routable ... This may be my only failure point right now and may be working once once I get v6 leases to come to the clients. Maybe RA isn't working for some reason?

I've dropped the /48 from my tunnel config on the HE side as well and removed any mention of it from my router configuration ...
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 28, 2011, 12:43:03 PM
On the screen Networking > IPv6 > IPv6 Static Routing, I've set the IPv6Gateway to the HE endpoint server's v4 address, in the form of "::216.218.224.42". After setting this address in this field, the only thing that the GUI will let me choose without error for the line directly above it, Interface drop down, is "sit0 WAN". Is this how your's is set?
Yes that is correct

EDIT -- and, BTW, now with the current configuration the only IPv6 address my clients (PCs) are getting is Link-Local, nothing routable ... This may be my only failure point right now and may be working once once I get v6 leases to come to the clients. Maybe RA isn't working for some reason?
This indeed started working only after I rebooted the router.

Hope this helps
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 28, 2011, 01:07:22 PM
Been there, done that, drank the KoolAide .. other ideas?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 28, 2011, 05:54:39 PM
@kauwen -- Curious of something. How is your page under Networking > LAN > IPv6 LAN Configuration setup? This is one that I don't remember us touching as of yet. Please let me know how these variables are setup in your equipment.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 29, 2011, 11:36:56 AM
I have only configured internal ipv6 address over there. Dhcp disabled.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 29, 2011, 11:41:53 AM
Ok, great ... I'll disable DHCP (I'm still stuck in the v4 way of thinking, but I'm doing this to learn). What address did you use? your tunnels Client v6 address, I'm assuming?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 29, 2011, 03:26:54 PM
I think I left it at it's default, it is fec0::1, this is just an internal address for the Lan.

I think your main problem is that the computers don't pick up the router advertisement. What do you have now for Router advertisement and Advertisement prefixes?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on June 29, 2011, 08:11:43 PM
For Router Advertisement, I have RADVD Status = Enable, Advertise Mode = Unsolicited Multicast, Advertise Interval = 30, RA Flags =  Managed, Router Prefernce = High, MTU = 1500, Router Life Time = 3600

For Advertisement Prefixes, I have nothing set.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on June 30, 2011, 11:04:46 AM
For Advertisement Prefixes, I have nothing set.
You should, see step 3 of the document. When you set this it will automatically set the prefix (in the 2002 range) that is broadcasted and the clients should pick up this address prefix.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on July 14, 2011, 11:52:57 AM
Cisco now made a document available how to setup an ipv6 tunnel: https://supportforums.cisco.com/docs/DOC-17497
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 14, 2011, 12:01:31 PM
man, you've come through once again! I'll be giving this info a try soon. I was next going to be wiping my router to factory defaults and starting fresh ... was really dreading having to go to that extreme since my wife has a home business. Thanks again, and I'll report back with my findings.

Cheers!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 14, 2011, 06:15:50 PM
OK, I went through the Cisco documentation setting everything described and had absolutely no better luck. Then, I reset my router to factory defaults via the reset button (held it for 30 seconds to be sure. Set all of my v4 configuration up and my wireless security settings and confirmed proper v4 operation ... no issues there. I then went through the Cisco v6 tunnel configuration steps again and made no other changes than those described and ... STILL NO GO! I'm about to throw this router out in the trash!

IF I put the HE IPv6 Nameserver's address (2001:470:20::2) hardset into my W7 computer's TCP/IPv6 properties for my adapter, strangely enough, I get nameserver resolution for ipv6.google.com (2001:4860:8005::69) and www.kame.net (2001:200:dff:fff1:216:3eff:feb1:44d7), no problem. One would think this would indicate that the tunnel is up, and it may well be. I can't, however, pull any webpages from either, at least the Kame webpage is not the IPv6 version but the IPv4.

I'll go no further with any changes until someone can hopefully advise something logical that I can try. WHAT THE HECK AM I OVERLOOKING?? My clients (PCs) are still not getting the proper IPv6 addresses, either, BTW. The only IP address it's getting is the Link Local, that it probably always has. No 2001 or 2002 address ...
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: cholzhauer on July 14, 2011, 07:17:43 PM
I didn't read the guide, but how are you handing out addresses?  What happens if you assign a static address to your computer from your routed /64 and try?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 14, 2011, 07:30:05 PM
OK, I've set a v6 address in my /64 and set the default gateway and the DNS address and I can no longer get name resolution and cannot ping my default gateway or v6 DNS server. Trying to ping what should be my default gateway address gets "host unreachable". Guessing my router doesn't know its local IP address ...
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: cholzhauer on July 15, 2011, 12:56:27 PM
Lets see the output of ipconfig /all and your routing tables.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 15, 2011, 07:35:18 PM
Since this is all that is probably relevant, here is the ipconfig /all of my ethernet and Teredo interfaces only:

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : rxforcomputers
   Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
   Physical Address. . . . . . . . . : 00-13-20-8C-45-9E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::cf7:9a29:aea6:f5d7%2(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.21.101(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, July 15, 2011 18:58:57
   Lease Expires . . . . . . . . . . : Saturday, July 16, 2011 18:58:57
   Default Gateway . . . . . . . . . : 192.168.21.1
   DHCP Server . . . . . . . . . . . : 192.168.21.1
   DHCPv6 IAID . . . . . . . . . . . : 251663136
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-10-4A-7D-94-00-13-20-8C-45-9E
   DNS Servers . . . . . . . . . . . : 68.105.28.11
                                       68.105.29.11
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:3826:3d2f:b942:c7ae(Preferred)
   Link-local IPv6 Address . . . . . : fe80::3826:3d2f:b942:c7ae%12(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

This is my IPv4 routing table in my router:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
127.0.0.1       127.0.0.1       255.255.255.255 UGH   1      0        0 lo
192.168.21.0    0.0.0.0         255.255.255.0   U     0      0        0 bdg1
192.168.21.0    192.168.21.1    255.255.255.0   UG    1      0        0 bdg1
70.189.56.0     0.0.0.0         255.255.254.0   U     0      0        0 eth1
239.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 bdg1
0.0.0.0         70.189.56.1     0.0.0.0         UG    0      0        0 eth1

My IPv6 routing table is currently empty. My PC is Windows 7 and has IPv6 protocol set to fully automatic configuration currently and the router is configured according to the Cisco HE Tunnel document from an IPv6 standpoint. v4 is working perfectly!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on July 16, 2011, 09:01:17 AM
I don't think Teredo should be active, did you configure it in the past? Or installed some tunnel client program?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 16, 2011, 09:06:50 AM
I've never configured the Teredo Adapter that I can ever remember, and I've just checked my W7 netbook and the Teredo adapter config on it looks very similar to this one. I think that Teredo is enabled by default on W7 and Vista ...
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: kauwen on July 16, 2011, 09:11:17 AM
But Teredo should only be used if your router is not able to route ipv6
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 16, 2011, 10:00:16 AM
Ok, yes I agree that Teredo is not needed, and I have neither enabled it or configured it. It is just as it comes configured standard in Windows. Also, my tunnel was once working with my WRVS4400N with my computer configured just as it is now, except with my old router I did have to set the HE Nameserver's IP in my IPv6 DNS setting on my Ethernet adapter to have things fully functional.

I guess my point is that Teredo has always been there just as it is now. I really wouldn't know how to disable it right off hand, but I'm sure I have a hammer around that can take care of that if need be  ;D . I just don't think this is my problem ...
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: cholzhauer on July 18, 2011, 06:55:47 AM
You should disable teredo 

Code: [Select]
netsh int ipv6 set teredo disabled

I don't see any IPv6 info in there at all...you said the tunnel is setup on your router?  I've sort of lost track of this thread... If it is, you need to do RA or DHCPv6 to get your computer and address.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 18, 2011, 10:44:01 AM
I'll try disabling Teredo this evening when I get home from work and find if it makes any difference.

Yes, I've got the router's IPv6 configured as described in the Cisco example documentation, and RADVD is setup as described in that document. I agree, I should be seeing some evidence of IPv6 leasing or configuration on my client and I'm not.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: cholzhauer on July 18, 2011, 11:34:26 AM
If that's the case, disabling teredo isn't going to help this.  Is there a firewall in the way that might be blocking traffic?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 18, 2011, 04:52:39 PM
No Sir, no firewall ... single layer LAN. Have the RV220 and a 16 port switch. Simple home network, and bare in mind that the tunnel was working with my old router, a WRVS4400N.

Tried disabling the Teredo and saw no difference other that the Teredo adapter showing Media State Disconnected and no IP information in it now.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: cholzhauer on July 19, 2011, 04:04:29 AM
Something's wrong on your router/tunnel...it's just not doing RA to give you an IPv6 address or routing information.

Can you post the code or screen shots of what you have set up?
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 19, 2011, 08:33:13 PM
Ok, here's my best stab at walking you through the IPv6 tunnel settings I've put into my router ...

Following the Cisco document "Connecting RV220W to an IPv6 Tunnel broker", and after setting up my /64 tunnel on
the HE side, I followed this procedure. My firmware version is  1.0.1.0, so my screens didn't exactly match the
screenshots in the document. In cases where I didn't have an exact match to choose I made a best educated guess.

This, by the way, is also the order in which I made the settings. Here we go!

I first went to Networking > IPv6 > Routing Mode and selected radio button next to "IPv4 / IPv6 mode".

Next, went to Netowrking > IPv6 > Router Advertisement and set RADVD Status: to "Enable", Advertise Mode: to
"Unsolicited Multicast", Advertise Interval: to "30", RA Flags: have Managed and Other checked, Router Preference:
is set to "High", MTU: is set to "1500", and Router Life Time: is set to "3600".

At this point, my clients (PCs) were not acquiring 6to4 prefixes (2002:WAN IP in HEX::) as the documentation said
that I should have. I continued anyway.

Next, I went to Networking > IPv6 > Advertisement Prefixes, and clicked the Add button. In the following screen, I
set the IPv6 Prefix Type: to "6to4", the SLA ID: to "1", checked  that the IPV6 Prefix (although greyed out): is
"2002:<My WAN IP in Hex>:1::", the IPv6 Prefix Length (also greyed out): is "64", and the Prefix Lifetime: is
"3600". I then clicked the Save button.

I then went to Networking > IPv6 > 6 to 4 Tunneling and checked "Enabled" for Automatic Tunneling.

Next, I went to Networking > IPv6 > IPv6 Static Routing and clicked Add. On the next screen, I set the Route Name:
to "tunnelbroker", Active: has "Enable" checked, IPv6 Destination is set to "2001:", IPv6 Prefix Length" is set to
"3", Interface: has "sit0 Wan" selected", IPv6Gateway: is set to "::216.218.224.42" (HE Server IPv4 address), and
the Metric: is set to "2".

Lastly, I went to Networking > IPv6 > Advertising Prefixes again and clicked Add. Following screen, IPv6 Prefix Type: is "Global/Local/ISATAP", SLA ID: is greyed out and blank, IPV6 Prefix: is "<My HE Routed /64 Prefix>::2", IPv6 Prefix Length: is "64", and Prefix Lifetime: is "3600".

At this point when nothing seemed to be working, I rebooted the router as I had read in other posts that sometimes a reboot would bring up the tunnel after the settings were in place. No difference, still no working.

One thing that I have tried after all of this is I went to Networking > LAN > IPv6 LAN Configuration and set the IPv6 Address: to "<My HE Routed /64 Prefix>::101f" (random last four characters), IPv6 Prefix Length: is set to 64, and under the DHCPv6 section, I left the DHCP Status: set to "Disable DHCPv6 Server".

So, this is all of the settings related to IPv6 that I've done in an effort to get the tunnel working. Please, if you recognize something that I've done wrong, please let me know.

Thanks again!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: cholzhauer on July 20, 2011, 05:15:14 AM
Is the MTU correct?

One thing is HE uses 6in4, not 6to4...you mention the 2002 address range, but that's never doing to work.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on July 20, 2011, 07:12:24 AM
Very sorry to have not numbered my steps to make discussion a little easier. I wasn't thinking.

Is the MTU correct?

One thing is HE uses 6in4, not 6to4...you mention the 2002 address range, but that's never doing to work.

I'm guessing your question concerning the MTU is regarding the step that I described:

"Next, went to Netowrking > IPv6 > Router Advertisement and set RADVD Status: to "Enable", Advertise Mode: to
"Unsolicited Multicast", Advertise Interval: to "30", RA Flags: have Managed and Other checked, Router Preference:
is set to "High", MTU: is set to "1500", and Router Life Time: is set to "3600". "

These settings were directly from the Cisco documentation with no translation needed. The document showed "1500", so that's is what I set it to. If it needs to be otherwise I'm open to suggestions.

As for the 6to4 or 6in4, I'm guessing that this is regarding this step that I described:

"Next, I went to Networking > IPv6 > Advertisement Prefixes, and clicked the Add button. In the following screen, I
set the IPv6 Prefix Type: to "6to4", the SLA ID: to "1", checked  that the IPV6 Prefix (although greyed out): is
"2002:<My WAN IP in Hex>:1::", the IPv6 Prefix Length (also greyed out): is "64", and the Prefix Lifetime: is
"3600". I then clicked the Save button."

There was no 6in4 to select, and the Cisco document that I followed said 6to4 so that's what I selected. Lastly, the 2002 address range that you reference is not something that I set but was automatically there in a box that was greyed out and couldn't be changed, "IPv6 Prefix:". I simply mentioned it because that I was thinking the fact that I was "2002:<what my WAN IP was in Hex>:1::" was relevant to this conversation.

Cheers, and thanks!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: cholzhauer on July 20, 2011, 07:25:25 AM
Yeah, your assumptions were correct.

Your RV220W will work with HE because you're not allowed to change that 2002 to a 2001.

This is really the only thing that I found on google and it's more directed at hosting the tunnel behind the router, not on it

https://supportforums.cisco.com/thread/2089646?tstart=20
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rtrsalt on April 12, 2012, 02:40:51 PM
Any luck with this?  I am having similar problem.  The document at https://supportforums.cisco.com/docs/DOC-17497, is this for 6to4 or 6in4?  It seems like it is for doing the tunneling to the router because the router is then advertising the assigned prefix from HE (in addition to 2002 prefix).

Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rxforcomputers on April 12, 2012, 04:26:40 PM
Yes, this is the document that got things working for me! From the time when I was last posting, Cisco revised the firmware and, after a hard reset of the unit and following the instructions in the doc, the tunnel came up and has since been up even after another firmware update. My current firmware is now 1.0.3.5, BTW.
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: rtrsalt on April 13, 2012, 08:28:55 PM
I followed this doc still not working.  I am RV110W running 1.2.0.9.  What is strange is that although HE uses manually configured 6in4, RV110W doesn't seem to support this.  Although I add an IPv6 static route to ::<IPv4 address of HE server>, it doesn't show up in the routing table.  The default route for all IPv6 traffic is to ::192.88.99.1, the 6to4 anycast relay.  I don't want to send it there, but rather to the HE server.  Also confused weather my hosts behind the RV110W are supposed to have the 2002 address or the 2001 assigned by HE.  Also, I couldn't add static route like "::x.x.x.x" in Cisco document.  Rather RV110W made me put it in as ::x:x:x:x. 
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: JoFe on January 09, 2013, 01:07:52 AM
I have the same problem with the RV110W. Has in the meanwhile someone get tihis to work on a RV110W? I think the only problem is that the webinterface does not let you enterer a IPv6 route to ::<IPV4 tunnelbroker server> ("invalid ip format")
Has anyone an idea how to fix this or to get rid of the "invalid ip adress" message ? Thx!
Title: Re: Tunnel Setup on Cisco RV220W -- Help Needed
Post by: glaurent on December 18, 2014, 11:40:10 PM
I opened a new post, but just in case.

Did you succeed to run HE tunnel on RV220W with last firmware (1.0.6.6) ? I tried few hours yesterday without success.

prefix is propagated correctly and my laptop has an IPV6 with the correct prefix, but can't route nor ping.
IPV6 himself works as I can ping6 the RV220W.
I even don't know if the tunnel is well connected  :(