Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Guru test failing, although command from videos pass  (Read 2629 times)

jjkiers

  • Newbie
  • *
  • Posts: 3
Guru test failing, although command from videos pass
« on: September 09, 2010, 10:37:23 AM »

Hello,

I'm trying to pass the guru test, but it seems the HE test can't query its own nameservers. I didn't find an answer elsewhere in this forum. If I run the commands as listed in the video, I get perfect results, as you can see below.

I wrote the following scripts to perform the dig commands from the video:

For only ipv6 queries:
Code: [Select]
for s in `dig -6 NS ipv6.bedrijfonline.net +short`; do echo Testing $s:; echo IP address of name server: `dig -6 AAAA $s +short`; echo IP address of ipv6.bedrijfonline.net: `dig -6 AAAA ipv6.bedrijfonline.net @$s +short`; echo Done testing $s; echo; echo;done;

or use:
Code: [Select]
for s in `dig NS ipv6.bedrijfonline.net +short`; do echo Testing $s:; echo IP address of name server: `dig AAAA $s +short`; echo IP address of ipv6.bedrijfonline.net: `dig AAAA ipv6.bedrijfonline.net @$s +short`; echo Done testing $s; echo; echo;done;

In either case, it gave me the following results:
Code: [Select]
Testing ns3.he.net.:
IP address of name server: 2001:470:300::2
IP address of ipv6.bedrijfonline.net: 2001:1af8:fe29:0:222:5fff:fe06:a8af
Done testing ns3.he.net.


Testing ns2.he.net.:
IP address of name server: 2001:470:200::2
IP address of ipv6.bedrijfonline.net: 2001:1af8:fe29:0:222:5fff:fe06:a8af
Done testing ns2.he.net.


Testing ns4.he.net.:
IP address of name server: 2001:470:400::2
IP address of ipv6.bedrijfonline.net: 2001:1af8:fe29:0:222:5fff:fe06:a8af
Done testing ns4.he.net.


Testing ns5.he.net.:
IP address of name server: 2001:470:500::2
IP address of ipv6.bedrijfonline.net: 2001:1af8:fe29:0:222:5fff:fe06:a8af
Done testing ns5.he.net.

I really don't know what is wrong, neither did I find an answer elsewhere in this forum. Could someone else please try this, and tell me why it fails?

Thanks, Jacob
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2729
Re: Guru test failing, although command from videos pass
« Reply #1 on: September 09, 2010, 10:41:32 AM »

Everything seems to work for me too.

Normally, when something like this happens, someone at HE needs to reset something so the cache is updated

Logged

jjkiers

  • Newbie
  • *
  • Posts: 3
Re: Guru test failing, although command from videos pass
« Reply #2 on: September 09, 2010, 10:43:55 AM »

In that case, I'll just wait another day or so, to see if it works then.
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1735
Re: Guru test failing, although command from videos pass
« Reply #3 on: September 09, 2010, 10:43:59 AM »

Cache is fine. Your submitted URL had extra stuff on the end. I've removed the extra, please retest.
Logged

jjkiers

  • Newbie
  • *
  • Posts: 3
Re: Guru test failing, although command from videos pass
« Reply #4 on: September 09, 2010, 10:45:57 AM »

Thanks, the test just passed. Quick response, by the way!
Logged