• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Ping and Web Work - Traceroute Fails

Started by angelou, February 03, 2011, 08:10:45 PM

Previous topic - Next topic


Well, it seems I have created an interesting situation, and I am not quite sure what is causing it. 

My linux router for the most part is working fine, radvd is passing the info, all the ipv6 clients are getting address, and they can all access the ipv6 network through the tunnel.  The router and clients can also ping all ipv6 addresses without issue.  But no one, clients or router can perform any traceroutes.  They all just die, not even a single hop.

I would think if ping was working, traceroute would.  Oh great Gurus, what have I broke.


Why would you think ping and traceroute are the same? Have you read the traceroute man page?
By default traceroute uses UDP, not ICMP. Check your firewalls(s), and provide more information to work with.


Well, It did work 2 days ago and just stopped working, so I am a little at a loss as to what has changed.  As for the ICMP/UDP comment, I honestly thought traceroute used ICMP as well.  That is something new I have learned today.  Here is how my Ubuntu 10.10 ipv6 tunnel router is setup.

/etc/network/interfaces: = HE Server IPv4 Endpoint
2001:470:8:7aa::1 = Static IPv6 assignment from my routable range to the linux router interface. (Can be any ip in routed range)
2001:470:7:7aa::2 = Client IPv6 Endpoint

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface - ipv4
auto eth0
iface eth0 inet dhcp

# The primary network interface - ipv6
iface eth0 inet6 static
     address 2001:470:8:7aa::1
     netmask 64

# IPv6 via Hurricane Electric Tunnel
auto he-ipv6
iface he-ipv6 inet6 v4tunnel
     address 2001:470:7:7aa::2
     netmask 64
     up ip -6 route add default dev he-ipv6
     down ip -6 route del default dev he-ipv6


2001:470:8:7aa::/64 = Routed range you are using

interface eth0
        AdvSendAdvert on;

        # Disable Mobile IPv6 support
        AdvHomeAgentFlag off;

        prefix 2001:470:8:7aa::/64
                AdvOnLink on;
                AdvAutonomous on;

                # Disable Mobile IPv6 support
                AdvRouterAddr off;


Uncomment the following line

net.ipv6.conf.all.forwarding = 1

As for my router, it is a Netgear WNDR3700 running DD-WRT.  No special firewall setting other than disabling the blocking of Multicasting were made to get ipv6 working with it.  There are obviously many settings in there, but nothing really pertaining to ipv6 since it is not controling the ipv6 tunnel, but if you wish additional information from the router, let me know and I will post it.