Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Cannot get tunnel up  (Read 4288 times)

d3rtus

  • Newbie
  • *
  • Posts: 4
Cannot get tunnel up
« on: January 09, 2011, 11:18:10 AM »

I have a Windows Server 2008 R2 Enterprise machine running on vmware.

I have a Linksys WRT54G router so I put 192.168.1.42 in the DMZ.

Used these commands on the 2008 VM:

netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel IP6Tunnel [removed] 72.52.104.74
netsh interface ipv6 add address IP6Tunnel 2001:470:1f04:1632::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f04:1632::1

If I try to ping 2001:470:1f04:1632::1 it returns "General Failure" however if I ping 2001:470:1f04:1632::2 it responds fine. Where did I go wrong?



C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : WIN-OAV9AQVMIVK
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0C-29-09-ED-B4
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::fc2e:8af1:c66a:38bc%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.42(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 234884137
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-AE-9D-1E-00-0C-29-09-ED-B4

   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{6DFAA0C1-2C91-4811-86A2-938BBF22D042}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter IP6Tunnel:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Direct Point-to-point Adapater
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2715
Re: Cannot get tunnel up
« Reply #1 on: January 09, 2011, 01:14:47 PM »

im going to ssume since you masked out your ip address, you used your pubic ip instead of your nat'd one
Logged

d3rtus

  • Newbie
  • *
  • Posts: 4
Re: Cannot get tunnel up
« Reply #2 on: January 09, 2011, 01:51:34 PM »

im going to ssume since you masked out your ip address, you used your pubic ip instead of your nat'd one

I am a networking newbie but I thought that since I put the machine in the DMZ, I was supposed to use the public IP. Am I wrong?
Logged

donbushway

  • Newbie
  • *
  • Posts: 40
Re: Cannot get tunnel up
« Reply #3 on: January 09, 2011, 02:43:46 PM »

You need to use the nated address not the public address.
Logged

d3rtus

  • Newbie
  • *
  • Posts: 4
Re: Cannot get tunnel up
« Reply #4 on: January 09, 2011, 02:50:26 PM »

Cool, that seems to have gotten me a little further. Still not getting through.

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0C-29-2B-E0-59
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:470:1f04:1632::3(Preferred)
   Link-local IPv6 Address . . . . . : fe80::b53b:2693:aa23:2e8%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.42(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 234884137
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-BB-D6-13-00-0C-29-2B-E0-59

   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       4.4.8.8
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{02C816B3-C0B2-4B5A-82C7-292B83A686CC}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter IP6Tunnel:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Direct Point-to-point Adapater
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:470:1f04:1632::2(Preferred)
   Link-local IPv6 Address . . . . . : fe80::b844:d06e:a0bc:b68e%13(Preferred)
   Default Gateway . . . . . . . . . : 2001:470:1f04:1632::1
   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       4.4.8.8
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Windows\system32>ping 2001:470:1f04:1632::1

Pinging 2001:470:1f04:1632::1 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 2001:470:1f04:1632::1:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2715
Re: Cannot get tunnel up
« Reply #5 on: January 09, 2011, 06:40:02 PM »

So what were the commands you put into the command prompt window?

If you used the nat address and your tunnel still isn't working, that must mean that protocol 41 isn't getting passed to your host.  Have you looked at traffic yet?
Logged

d3rtus

  • Newbie
  • *
  • Posts: 4
Re: Cannot get tunnel up
« Reply #6 on: January 09, 2011, 06:54:58 PM »

So what were the commands you put into the command prompt window?

As above, although I switched my public IP with my server's internal 192.168.1.42.

Quote
If you used the nat address and your tunnel still isn't working, that must mean that protocol 41 isn't getting passed to your host.  Have you looked at traffic yet?

I thought by putting it in the DMZ, I wouldn't have to worry about protocol 41 not being passed... Oh well. Time to flash my router with DD-WRT.

edit:

Tunnel is up after flashing my router to DD-WRT. I guess putting it in the DMZ means nothing. Thanks for the replies.
Logged