Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: IPv4 Address Changed, Tunnel Stopped Working  (Read 4220 times)

neilehodges

  • Newbie
  • *
  • Posts: 4
IPv4 Address Changed, Tunnel Stopped Working
« on: May 04, 2011, 10:23:13 PM »

I've been using HE for a long time since Comcast lacks IPv6 support, but today I found out that my IPv4 address changed with a reboot of my router, and now I can't even ping any IPv6 addresses.  I've updated the endpoint address in the HE web interface and updated the settings in hostname.gif0 to reflect that.  Just changing an IPv4 address, right?

It just doesn't work anymore.  For example, I tried pinging ipv6.google.com:
Code: [Select]
$ ping6 ipv6.google.com
PING6(56=40+8+8 bytes) 2001:470:1f04:bbe::2 --> 2001:4860:8005::67
^C
--- ipv6.l.google.com ping6 statistics ---
6 packets transmitted, 0 packets received, 100.0% packet loss
Here's the tcpdump for the duration of the ping command:
Code: [Select]
# tcpdump -i vr0 host 72.52.104.74
tcpdump: listening on vr0, link-type EN10MB
22:19:29.831700 neilehodges-1-pt.tunnel.tserv3.fmt2.ipv6.he.net > pz-in-x67.1e100.net: icmp6: echo request (encap)
22:19:29.860504 tserv3.fmt2.ipv6.he.net > c-24-19-6-219.hsd1.wa.comcast.net: icmp: tserv3.fmt2.ipv6.he.net protocol 41 port 0 unreachable [tos 0x20]
22:19:30.832647 neilehodges-1-pt.tunnel.tserv3.fmt2.ipv6.he.net > pz-in-x67.1e100.net: icmp6: echo request (encap)
22:19:30.862818 tserv3.fmt2.ipv6.he.net > c-24-19-6-219.hsd1.wa.comcast.net: icmp: tserv3.fmt2.ipv6.he.net protocol 41 port 0 unreachable [tos 0x20]
22:19:31.822658 neilehodges-1-pt.tunnel.tserv3.fmt2.ipv6.he.net > pz-in-x67.1e100.net: icmp6: echo request (encap)
22:19:31.851881 tserv3.fmt2.ipv6.he.net > c-24-19-6-219.hsd1.wa.comcast.net: icmp: tserv3.fmt2.ipv6.he.net protocol 41 port 0 unreachable [tos 0x20]
22:19:32.822697 neilehodges-1-pt.tunnel.tserv3.fmt2.ipv6.he.net > pz-in-x67.1e100.net: icmp6: echo request (encap)
22:19:32.851943 tserv3.fmt2.ipv6.he.net > c-24-19-6-219.hsd1.wa.comcast.net: icmp: tserv3.fmt2.ipv6.he.net protocol 41 port 0 unreachable [tos 0x20]
22:19:33.822729 neilehodges-1-pt.tunnel.tserv3.fmt2.ipv6.he.net > pz-in-x67.1e100.net: icmp6: echo request (encap)
22:19:33.851909 tserv3.fmt2.ipv6.he.net > c-24-19-6-219.hsd1.wa.comcast.net: icmp: tserv3.fmt2.ipv6.he.net protocol 41 port 0 unreachable [tos 0x20]
22:19:34.822770 neilehodges-1-pt.tunnel.tserv3.fmt2.ipv6.he.net > pz-in-x67.1e100.net: icmp6: echo request (encap)
22:19:34.851750 tserv3.fmt2.ipv6.he.net > c-24-19-6-219.hsd1.wa.comcast.net: icmp: tserv3.fmt2.ipv6.he.net protocol 41 port 0 unreachable [tos 0x20]
^C
972 packets received by filter
0 packets dropped by kernel

What in the world is going on here?
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1722
Re: IPv4 Address Changed, Tunnel Stopped Working
« Reply #1 on: May 04, 2011, 10:30:19 PM »

Please retest, your tunnel config on our side wasn't updated, so I straightened it out. Make certain to email ipv6@he.net to open a trouble ticket when you have problems.

« Last Edit: May 04, 2011, 10:33:39 PM by broquea »
Logged

neilehodges

  • Newbie
  • *
  • Posts: 4
Re: IPv4 Address Changed, Tunnel Stopped Working
« Reply #2 on: May 05, 2011, 05:44:01 AM »

I had assumed the problem was on my end, as it usually is, which is why I posted here.

Awesome, thanks for looking at that!  Works as before now.
Logged

chandro

  • Newbie
  • *
  • Posts: 27
  • hello!!
    • Chandro & Co
Re: IPv4 Address Changed, Tunnel Stopped Working
« Reply #3 on: May 06, 2011, 12:40:19 PM »

what i did is erase erase tunnel on my PC, update ip of the tunnel on tunnelbroker.net and then install tunnel again on my PC.

it works.
Logged
2001:0:0:7::B0ND