Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Enthusiast test fail  (Read 6044 times)

u8sf

  • Newbie
  • *
  • Posts: 12
Enthusiast test fail
« on: July 02, 2011, 11:11:29 PM »

In test, I set up  wampserver (Apachee) web server in windows Vista 32bit.
Via browser, In IPv4, I can see the file , but In IPV6 I cannot get it .

From IPv6 portscan, can see:
*********
Starting Nmap 5.00 ( http://nmap.org ) at 2011-07-02 22:41 PDT
Interesting ports on 2001:470:35:2e9::2:
Not shown: 992 closed ports
PORT      STATE SERVICE
135/tcp   open  msrpc
3306/tcp  open  mysql
49152/tcp open  unknown
49153/tcp open  unknown
49154/tcp open  unknown
49155/tcp open  unknown
49156/tcp open  unknown
49157/tcp open  unknown

Nmap done: 1 IP address (1 host up) scanned in 63.27 seconds
********
I see TCP port 80 is not open in IPV6.
What settings in Wampserver (Apache) or Window Vista 32 bit, affect open /close the port 80?
Any suggestion?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2736
Re: Enthusiast test fail
« Reply #1 on: July 03, 2011, 05:58:27 AM »

By default, apache will listen on IPv6 unless you tell it not to.

What's probably going on is that you running a firewall that's blocking it...what OS and firewall are you running?

The "listen 80" directive in apache covers both IPv6 and IPv4
Logged

u8sf

  • Newbie
  • *
  • Posts: 12
Re: Enthusiast test fail
« Reply #2 on: July 03, 2011, 07:27:09 AM »

this is window vista. computer under DMZ (use public IP address) and the vista firewall is off also.
Does the listen 80 directive need add ipv6 address or not ? that mean 2001:470:35:2e9::2:80

Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2736
Re: Enthusiast test fail
« Reply #3 on: July 03, 2011, 08:06:24 AM »

No...as long as you've told apache to listen on 80 in it's config, you don't need to specify port 80

can you access your website over ipv6 internally?

Check in the windows advanced firewall and make sure you're allowing port 80

if you're running Windows 7 pro, any reason you didn't use IIS?
Logged

snarked

  • Hero Member
  • *****
  • Posts: 777
Re: Enthusiast test fail
« Reply #4 on: July 03, 2011, 12:35:56 PM »

BTW, close port 135.  Too many exploits.
Logged

u8sf

  • Newbie
  • *
  • Posts: 12
Re: Enthusiast test fail
« Reply #5 on: July 03, 2011, 06:41:56 PM »

No...as long as you've told apache to listen on 80 in it's config, you don't need to specify port 80

can you access your website over ipv6 internally?

Check in the windows advanced firewall and make sure you're allowing port 80

if you're running Windows 7 pro, any reason you didn't use IIS?
"can you access your website over ipv6 internally?"
How to do ? I know "localhost" or "127.0.0.1"for IPV4 , What is for IPV6

" Check in the windows advanced firewall and make sure you're allowing port 80"
Firewall is set to off. and I also set allowing port 80.

 
"if you're running Windows 7 pro, any reason you didn't use IIS?"
because I think apachee is so common , should be easier to set up , However , I will switch to IIS if apachee is fail .
Logged

u8sf

  • Newbie
  • *
  • Posts: 12
Re: Enthusiast test fail
« Reply #6 on: July 03, 2011, 06:46:40 PM »

BTW, close port 135.  Too many exploits.
open port 135 is not by me.
Can you tell the steps how to  close port 135? from windows or apachee or other software setting.
Logged

snarked

  • Hero Member
  • *****
  • Posts: 777
Re: Enthusiast test fail
« Reply #7 on: July 04, 2011, 12:30:26 PM »

Block port 135 in yor firewall.  As you're using Windows, you're on your own as for how to do that.
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2736
Re: Enthusiast test fail
« Reply #8 on: July 04, 2011, 07:53:02 PM »

Snarked is right...block 135.  It'll be blocked when you turn your firewall back on though.

You can access your webserver internally by http://[ipv6 address]  (make sure you include the [] )
Logged