Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Tunnel setup completed without errors but pinging gives "Request timed out"  (Read 6044 times)

gary4gar

  • Newbie
  • *
  • Posts: 2

Hey everyone,
I am trying to setup IPv6 tunnel on my Windows 7 32bit PC.  I am sitting behind NAT router but I have enabled DMZ which is mapped to my private ip . scanned using nmap to conform open ports.  further, I have setup IPv6 tunnel using the following command(192.168.1.8 is my private IP)

Quote
netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel IP6Tunnel 192.168.1.8 216.218.221.42
netsh interface ipv6 add address IP6Tunnel 2001:470:35:16f::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:35:16f::1
Now, then I try to ping it, I get "Request Timed Out"

Quote
C:\Windows\system32>ping ipv6.google.com

Pinging ipv6.l.google.com [2404:6800:800b::6a] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 2404:6800:800b::6a:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Here is the complete output of ipconfig
Quote
C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Gaurish-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : ASUS 802.11n Wireless LAN Card
   Physical Address. . . . . . . . . : E0-CB-4E-9F-E9-4C
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::1158:cf8e:bc25:15fc%15(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.8(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.2
   DHCPv6 IAID . . . . . . . . . . . : 434162510
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-78-16-E1-00-24-1D-F6-32-E

   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       8.8.4.4
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter IP6Tunnel:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Direct Point-to-point Adapater
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:470:35:16f::2(Preferred)
   Link-local IPv6 Address . . . . . : fe80::1dd8:f6a2:679b:e9b7%26(Preferred)
   Default Gateway . . . . . . . . . : 2001:470:35:16f::1
   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       8.8.4.4
   NetBIOS over Tcpip. . . . . . . . : Disabled


I have done everything correctly but still for some reason its not working ???  Please help
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2715

Your router must be blocking protocol41...what router/firewall are you using?
Logged

gary4gar

  • Newbie
  • *
  • Posts: 2

Your router must be blocking protocol41...what router/firewall are you using?

ADSL Router: Huawei Smartax mt841
Wireless AP: TP-Link WR541G

here is the network diagram:



Protocol 41 issue? How to test & any workarounds?
« Last Edit: July 10, 2011, 07:33:43 AM by gary4gar »
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2715

Only way I know of to test is to sniff packets and see what's going on.

Some routers let you use a DMZ mode to get past this, but some don't have a DMZ mode and others don't even work when you use the DMZ.

You can also test by turning off the firewall or putting your tunnel server ahead of the firewall.
Logged

jmv

  • Newbie
  • *
  • Posts: 15

If you have only a single PC,

you can try to bypass your router, run pppoe (windows VPN functionality) from your PC. You can connect your PC directly to your modem, or put the modem into a LAN (not WAN) port.


If you have more PCs you can run network sharing on the one running pppoe.

I realize I'm a bit sparse on details here...

The fundamental issue is probably indeed that your NAT is dropping protocol 41 packets. Try to sniff some packets on the link between the modem and the wan, if you have the tools to do that.
Logged