• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

I'm new here, trying to get it working...

Started by LSS740572, July 01, 2011, 06:26:21 AM

Previous topic - Next topic


I'm pretty new to tunnel brokers... I just don't know how to get it work properly.

I have three computers connected together with a TP-LINK TL-WR340G router, and they share the same Internet connection (2Mb/s ADSL). Not sure whether that router supports Protocol 41 or not and I couldn't find anything about it in the router. Maybe not.

The computer I want to use the tunnel is running Windows 7 Ultimate x64 and it's been set as DMZ in the router.

I created a tunnel with the endpoint set as the WAN IP address, and ran the example configuration generated in the page, but it doesn't seem functional as the certificate page still reports my IPv4 address and I still cannot browse any IPv6-only sites. Tried using my LAN IP in the configuration, still not functional.

By the way... what are the Routed IP anyway? I even assigned a Routed /48 address to the tunnel but I don't know how to use it...

Could you help me about it? I need to know what I need in order to create a working tunnel...


What commands did you use on the windows 7 computer to set up your tunnel?  Since you're behind a NAT, you need to change your public IP address to whatever private address you're using on that computer.

The routed /64 is basically the same idea as the /48 you requested; the difference is the /64 is only one subnet and the /48 contains 64k of /64's.  You only need the /48 if you're going to be using more than one subnet.

One way to rule out your router is to by pass it...do you have a way to assign the pubic IP to your computer instead of the router (put the computer in front of the router instead of behind.)


Well, the command is basically the same as those given by the Example Configuration, while I changed the endpoint into my router's IP.

netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel IP6Tunnel
netsh interface ipv6 add address IP6Tunnel 2001:470:18:a89::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:18:a89::1

(The IP is the LAN IP for this computer, and the same goes to DMZ setting in the router.)

I don't know how to put the computer in front of my router, anyway... The router itself is not a modem, as I already have an ADSL modem to connect to its WAN port.

The router does support Dynamic DNS from DynDNS, and I already set one. What I know is that typing the DynDNS subdomain name I set to the router will redirect to this computer, which is the DMZ. I don't know if that could be a workaround...


Eventhough your computer is in the dmz, it still has a private address... You need to use that in place of the 172 address


A private address? If it's not entirely equal to the LAN IP address I assigned to this computer, then how can I find it?

I replaced that router with TP-LINK TD-W89741N (apparently that thing's only available in China, resembles TD-W8951ND but not really identical), which is both an ADSL modem and a router... still can't get it work despite I didn't turn on any kinds of security options inside...

EDIT: The so-called private address doesn't seem to be the router's own address either... in fact I set my router and computer's IP to a 10.x.x.x range. Does that thing only work on 192.168.x.x range?


What does the output of ipconfig/ifconfig look like?


EDIT 2: Heh heh... IPv6 finally worked (tested on test-ipv6.com)! But now I can't sign into the certification page... It keeps saying my username is invalid but I can sign in to the tunnel broker page. Maybe I do need to use my LAN IP this way.

EDIT 3: By the way... if it works by using the LAN IP as the route... will it mean the tunnel is available not to only this computer, but to all computers connected to that router?


Email Ipv6@he.net if you're having problems with your login.


EDIT 3: By the way... if it works by using the LAN IP as the route... will it mean the tunnel is available not to only this computer, but to all computers connected to that router?

I don't think I follow you here...can you clarify?


Maybe not... It still won't work on the other computer I'm using...

Obviously, only the one set as DMZ and only when there is only one NAT device will it work as it's probably completely exposed to the outside... as my old ADSL Modem is also a router itself connected to the WAN port of my old router and dialed through it via PPPoE, there probably are two NAT devices (the ADSL Modem configuration will not be accessible unless I connect it directly to a PC) and setting the DMZ in the router only overcomes one (it may bypass the router but will not bypass the modem).

Well... the problem is I kinda forgot the password I used here. I saved my password in the browser before but I accidently changed the saved password in the certification page. Now I've logged in and I've successfully reached Explorer. Thanks for help.