• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Need help adding second computer on LAN

Started by glienesch, December 02, 2011, 07:28:51 AM

Previous topic - Next topic


I've got two Windows 7 Pro x64 computers behind a IPv6 Certified router (Netgear WNDR3700).  My local network uses static IPs.  My ISP is WildBlue (satellite) which doesn't support IPv6.  I've set up one computer to use HE Tunnelbroker and to my amazement things are working 10/10 and 10/10 according to test-ipv6.com.  However, I'm having difficulty configuring the second computer to use the tunnel.  The two computers are virtually identical.  What should I do to add the second computer to use Tunnelbroker?   

Also, in my LAN adapter properties, I'm not sure what to put in the TCP/IPv6 Properties.  Things seem to work no matter what.  Any suggestions?

Thanks for your help!


On your tunnel properties page, there is a line that says "routed /64" Let's say it's 2001:db8:1234:abcd::/64

You take one IP address, say 2001:db8:1234:abcd::1/64 and assign it to the Local Area Conection on your PC that has the tunnel broker connection set up.  The default GW here is the IP address of the HE side of the tunnel.

Take a second IP address from that range, say 2001:db8:1234:abcd::2/64 and assign it to your adapter on your second PC.  The default GW here is 2001:db8:1234:abcd::1/64


Thanks for the reply.  I think I missed something.  I lost IPv6 on the first computer.  Here's some information from my tunnel properties page:

IPv6 Tunnel Endpoints
Server IPv4 Address:
Server IPv6 Address:2001:470:1f0e:f02::1/64
Client IPv4 Address:
Client IPv6 Address:2001:470:1f0e:f02::2/64
Available DNS Resolvers
Anycasted IPv6 Caching Nameserver:2001:470:20::2
Anycasted IPv4 Caching Nameserver:
Routed IPv6 Prefixes
Routed /64:2001:470:1f0f:f02::/64

The difference in bold may be the problem.  My new LAN Adapter IPv6 properties window didn't save as it complained there was a conflict.  So I did something wrong.

When it last worked on the first computer, I had the Default gateway on the TCP/IPv6 Properties was my routers IPv6 address on the WAN as reported in the router's GUI.  My IPv6 address was much longer and didn't contain consecutive colons.  I think I got if from ipconfig.  This may not be what it should have been.  How can I correct this?  As you can tell, I don't really know what I'm doing....  :)


When you say you lost your tunnel, I assume it was working at some point? What changed to make it not work?

Are you running NAT?

The IP address on the IP6tunnel adapter on your tunnel router should be 2001:470:1f0e:f02::2/64.

The IP address on your Local Area Connection adapter on your tunnel router can be 2001:470:1f0f:f02::1/64 and the address on your second host can be 2001:470:1f0f:f02::2/64


Yes, it was working this morning.  I'm running NAT (192.168....)  I scored 10/10 and 10/10 on test-ipv6.com.  That's when I decided to get the second computer working.  I tried to implement the instructions from your first post on my working computer as I didn't think it matched what I thought you recommended. 

My router has an IPv6 page.  Here's what it says:


Internet Connection Type   

Connection Type   6to4 Tunnel
Router's IPv6 Address On WAN

LAN Setup
Router's IPv6 Address On LAN
IP Address Assignment
  Use DHCP Server <--- not selected
  Auto Config <----selected

Use This Interface ID
  :  :  :  <---- not used

IPv6 Filtering   Secured 

Here's my ipconfig for the first adapter:

Windows IP Configuration

Ethernet adapter LAN 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter LAN 1:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2002:48ad:1d63:e472:59b1:332e:4c77:3cc9
   Temporary IPv6 Address. . . . . . : 2002:48ad:1d63:e472:cc85:2556:2d3b:380a
   Link-local IPv6 Address . . . . . : fe80::59b1:332e:4c77:3cc9%10
   IPv4 Address. . . . . . . . . . . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . : 2002:48ad:1d63::1

Tunnel adapter isatap.{2C987B32-3C3B-4836-B80C-148F6BC612C5}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter IP6Tunnel:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:470:1f0e:f02::2
   Link-local IPv6 Address . . . . . : fe80::c18e:eee:6828:e8b8%21
   Default Gateway . . . . . . . . . : 2001:470:1f0e:f02::1

Tunnel adapter isatap.{9809D297-1C9D-4DAB-BE2E-F8A3FF43A1A4}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Reusable ISATAP Interface {D39279AA-7BF7-4FF9-ABD7-D0AE3F7DD684}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

The only thing I changed to make things stop working was editing the TCP/IPv6 Properties.  You mentioned, "The IP address on the IP6tunnel adapter on your tunnel router should be 2001:470:1f0e:f02::2/64."  You are right.  That's listed in the ipconfig Tunnel Adapter IP6 Tunnel shown above. 

What goes in the TCP/IPv6 Properties dialog?  I forgot what I had when I tried to input what I thought were your recommendations.  The fields are:

IPv6 address, Subnet prefix length, and Default gateway.

What's confusing me is having to guess what should go into those fields.  It doesn't like  2001:470:1f0f:f02::2 for the IPv6 field and I get a message that it's invalid.  The router doesn't ask me for any IP information -- it just displays it. 

Another note.  I entered the same netsh commands on my wife's computer as on mine with the exception of using her IPv4 address in place of mine.  Would this cause a conflict?

So, do you see where something is wrong in the information I've provided?  What do you recommend I do to get things working again?  Sorry for all the trouble.


Ethernet adapter LAN 1:

  Connection-specific DNS Suffix  . :
  IPv6 Address. . . . . . . . . . . : 2002:48ad:1d63:e472:59b1:332e:4c77:3cc9
  Temporary IPv6 Address. . . . . . : 2002:48ad:1d63:e472:cc85:2556:2d3b:380a
  Link-local IPv6 Address . . . . . : fe80::59b1:332e:4c77:3cc9%10
  IPv4 Address. . . . . . . . . . . :
  Subnet Mask . . . . . . . . . . . :
  Default Gateway . . . . . . . . . : 2002:48ad:1d63::1

This is the first thing that caught my attention...I didn't read your questions at the bottom too thoroughly because you need to get rid of the 6to4 stuff you listed.  Does your router mention 6in4 or 6to4?

On both your computers, run this from an elevated command prompt

netsh int ipv6 set teredo disabled
netsh int ipv6 isatap set state disabled
netsh int ipv6 6to4 set state disabled


The router internet connection type is a drop-down list.  The choices are, Auto Detect, Disabled, 6to4 Tunnel, Pass Through, Fixed, DHCP, and PPPoE.  I may have manually selected 6to4 trying to get things working.

I've run your three netsh commands on both computers.  Thanks.


There's your problem...your router doesn't have support for 6in4, just 6to4.  The addresses are completely different.

If I had to guess (and I'm 95% sure of this) The reason you got 10/10 on that test was because you were connecting over 6to4, not the 6in4 tunnel you configured from HE

I hope that makes sense.  6to4 is turned on by default on Windows and if your computer finds a router advertising that it can do 6to4, it'll connect to it without telling you.


When things were working this morning, I had already entered "teredo set state disabled."  Would the alternate path be available? 

Here's my current test-ipv6.com results:

Test with IPv4 DNS record - ok (1.717s) using ipv4
Test with IPv6 DNS record - timeout (15.015s)
Test with Dual Stack DNS record - ok (1.525s) using ipv4
Test for Dual Stack DNS and large packet - ok (1.782s) using ipv4
Test IPv4 without DNS - ok (1.527s) using ipv4
Test IPv6 without DNS - timeout (15.030s)
Test IPv6 large packet - timeout (15.020s)
Test if your ISP's DNS server uses IPv6 - bad (1.734s)
Test for buggy DNS - safe (5.006s)

I can connect with http://ipv6.google.com/ with IE but not Chrome.

Should I set the IPv6 Internet Connection on the router to "Pass Through?"  Thanks.


I'm curious as to what address websites see you comming from...what's the address in the lower right hand corner of your replies to this post?


It shows

Any ideas how I can fix this?  Thanks.


Your tunnel isn't working.  Which router are you using?  You're probably going to have to terminate the tunnel on a computer somewhere and go from there


That did it!  I deleted the tunnel and everything is now working just using the IPv6 certified router via 6to4.  When I went to test-ipv6.com, I passed all the tests.  It only noted that my ISP wasn't IPv6 capable.  We're good.  Thanks for your help.