• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

ipv6 tests - created tunnel now what?

Started by SE1, October 11, 2011, 10:02:28 AM

Previous topic - Next topic


QuoteIf you want to use the ::4 address, tell the VM to not do RA

how do i do this? I'm still getting those addresses.

QuoteThis is where you'd need your /48.

Simply pick a /64 for use on each interface (assuming you wanted the interfaces to be on different subnets/networks) and away you go.

WHere do we use the /48.


You need the /48 if you're using multiple subnets...you know 2001:db8:12:1::/64, 2001:db8:12:2::/64, ect  if your two adapters are on different networks, eg and, you need to assign a different /64 to each

You can either tell the VM not to do RA (depends on your OS) or just tell whatever is doing RA not to do it


My windows machine has multiple ipv6 address, how do i remove the second one , coz it uses it to for ipv6. (attached jpeg).


Which one?

The third one is a temporary address..remove it by doing a

netsh int ipv6 set privacy disabled

The second one is an RA address...if you don't want it, either tell your router not to do RA or tell your computer to stop accepting it  http://luka.manojlovic.net/2011/06/08/my-contribution-to-ipv6-day-configuring-ipv6-in-windows-server-2008-r2-video-tutorial/


One more question,

when I try to create a virtual interface in the VM,

auto eth0:0
iface eth0:0 inet6 static
address 2001:470:481c::1
netmask 48

i get an error:
STOCSIFFLAGS: Cannot assign requested address.

the address is the /48 assigned.

What could be the problem?


You don't want to use the entire /48...you have to take /64's out of it

so if your /48 is 2001:470:481c::/48, you can use


you can use what you have, just change the netmask to 64, which would give you a subnet of 2001:470:481c:0::/64


I still get the same error,

cannot assign requested address.


Looks like it could be a number of things...one of the things that google brought up was a user that was trying to configure an address the wrong way.

Isn't there a GUI you could run it though?