• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

Raspberry pi ipv6 tunnel help

Started by barclay, October 14, 2014, 10:35:15 AM

Previous topic - Next topic


Hi all,
Newbie here... :)
Looking at using ipv6 through a little raspberry pi project I picked up through the Raspberry forums I followed the instructions to the letter on the project page on a B+ board running Raspbian and through my mac separately, today I've gone with a fresh install on the raspberry and tried for a second time deleting then creating a new tunnel again today with no success getting the tunnel working as yet on either occasion.
The Router I'm using is a TG582n with firmware 8CM0 with the ping from wan active. Should I be worrying about the router passing protocol 41?
Would appreciate any pointers at all please guys. I've tried using :connection unbind application=IP6TO4 on my router with no luck either.

No response from any of those address
ping6 ipv6.bbc.co.uk
ping6 2620:0:ccc::2
My mac has been issued with an ipv6 address from my endpoint "Raspberry Project" and I can connect via ssh to the box ok locally with an ipv6 address.

Regards, Barclay


I don't have a Raspberry Pi so I can't comment directly on that setup, but in general the things you need are:

ISP to pass you protocol41
Router to pass you protocol 41
Routing device that understands IPv6 and 6in4 tunnels.  (If this device happens to be your "real" router, even better)
Configured tunnel

To check if you're moving protocol41 packets, break out some sort of packet-sniffing tool like wireshark.