Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: tunnel not starting up until pinged from outside  (Read 1280 times)

czlars

  • Newbie
  • *
  • Posts: 2
tunnel not starting up until pinged from outside
« on: November 24, 2014, 02:29:15 AM »

Hi,

I have set up new IPv6 tunnel on Mikrotik platform:

/interface 6to4 add local-address=nn.nn.nn.nn mtu=1480 name=tunnelbroker remote-address=216.66.86.122

/ipv6 address
add address=2001:470:6e:xxx::2 interface=tunnelbroker
add address=2001:470:6f:xxx:: interface=bridge-local

/ipv6 route
add check-gateway=ping distance=1 gateway=tunnelbroker
add check-gateway=ping distance=1 dst-address=2000::/3 gateway=2001:470:6e:xxx::1

After the setup the routes are marked as unreachable and nothing works... until I try to ping the IPv6 from outside. As soon as I try to ping the IPv6 tunnelbroker interface through some web service, the Mikrotik log says "link up" and IPv6 starts to work.

What is wrong? (RouterOS 6.22, Mikrotik 2011UiAS-2HnD, FW 3.19, TB tunnel id 213554)

Thanks,
Lars
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2714
Re: tunnel not starting up until pinged from outside
« Reply #1 on: November 24, 2014, 05:08:48 AM »

I suspect it'll also work if you ping the far end of the tunnel from inside your network...can you confirm?
Logged

czlars

  • Newbie
  • *
  • Posts: 2
Re: tunnel not starting up until pinged from outside
« Reply #2 on: November 24, 2014, 08:11:59 AM »

No. Ping to anything else than my local tunnel end results in "no route to host", which is probably correct as the route is not active (interface marked as unreachable).

Seems that it may be a Mikrotik issue as this behaviour is experienced only after router reboot. When the interface is running (started by the outside ping), it can be disabled and enabled again without any problems.
Logged