Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: How to achieve this IPv6 network configuration (SLAAC + DHCPv6 coexistence [mayb  (Read 563 times)

JenkinsNET

  • Newbie
  • *
  • Posts: 5
  • HE IPv6 Sage Certified

I'm trying to setup DHCPv6 on my home network without any success. I'm looking for some detailed guidance. The rest of this post gives the background...

My home network is full IPv4 / IPv6 dual stack. It has a few 'servers' which provide services both internally and externally (i.e. on the Internet), several Macs, one PC and a host of devices (iPhones, iPads, smart home devices, ...). My core network is a 10 GbE wired network. I also have a 1 GbE 'access' network (with 3 Gb/s uplink to the core) and a 802.11ac WiFi network provided by 3 access points (extended over the wired backbone).

My ISP is Virgin Media and may connection is 350 Mbit/s down, 30 Mbit/s up. It provides only IPv4 connectivity. My 'servers' are a mix of macOS (Catalina) and Synology NAS units (DSM 6.2). My router (and additional WiFi access points) are all Apple AirPort Extreme units (802.11ac tower version with latest firmware).

My IPv6 Internet connectivity is provided by a TunnelBroker tunnel which terminates at my AirPort Extreme router. The router provides RAs and SLAAC config for my routed /64 from the tunnel.

My network has two separate IPv4 subnets. One is 'private'; it has no router and can only be used for strictly internal traffic. The other is 'public'; by this I mean that there is a router and addresses in this network can access the Internet. Of course there is a firewall etc. etc. The public network has DHCP with many reservations so all my devices end up with 'known' addresses.

My IPv6 network parallels the IPv4 one. It has a 'private' /64 subnet (fd00::/64) used by my core systems (servers, Macs) and a 'public' routable /64 which is the one provided by the router from the tunnel. All of my IPv6 capably systems connect to the public subnet but only those allowing explicit IPv6 configurations (servers, Macs) connect to the private subnet. Many devices on the public subnet use SLAAC assigned addresses and prefixes but the servers and Macs use well known, explicitly configured addresses for that subnet.

I have internal DNS for my internal domain which has all the 'known' addresses defined, both IPv4 and IPv6.

This all works very nicely and has done for some years now but I have one annoying niggle. I'd like to be able to control the public IPv6 addresses that many of my devices (iPhones, iPads, other things) get assigned (something like DHCP 'reservations') but of course this is not possible with SLAAC. I'm trying to figure out how I can maybe use DHCPv6 instead of SLAAC but I'm not having any luck. I have tried the ISC Kea DHCPv6 server and while it is easy to configure, clients simply do not get addresses from it! AFAIK it is *not* possible to disable SLAAC on the router.

Does anyone have any suggestions for how I can achieve what I want to do?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2731

Have you tried the Windows DHCP server?
Logged