Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: FiOS - HE config in "internal" ASUS router, good with G1100, fails with G3100  (Read 466 times)

garrigan

  • Newbie
  • *
  • Posts: 2

I am wondering if a firmware upgrade resolved the following issue from two years ago: A Hurricane Electric 6in4 tunnel on an Asus router functions with a G1100 "edge" router, but it fails with a G3100 router.

I have posted this issue in several forums.

Release notes for firmware versions are not available.

Was anyone successful using Hurricane Electric's 6in4 IPv6 tunnel with a G3100 "edge" router in their home network? I am asking because I am considering buying a used G3100 router.

The following details are from two years ago.

The configuration exists on an ASUS router which is inside the home network. Via the configuration on the ASUS router I am tunneling IPv6 traffic within IPv4 packets. This configuration functions correctly with a G1100 in the environment, but it fails to function when I replace the G1100 with a G3100.

I can demonstrate that with a G1100 in place with the factory default configuration the data flows properly. If I swap in a G3100 the data flow stops. I do account for the possibility that the external IP address changes. I verify with Hurricane Electric that the configuration contains the proper IP address. My best guess is that the G3100 does not properly process Protocol 41 traffic. During the reset process on the G3100 one IPv6 ICMP packet did traverse the G3100. I did receive one reply. I had a steady ping to www.google.com 2607:f8b0:4006:812::2004. Also this event has been observed during a reboot of the G3100.

From Hurricane Electric: ģipv6.he.net/certificatio ˇˇˇ /faq.php
If you are using a NAT (Network Address Translation) appliance, please make sure it allows and forwards IP protocol 41.
What is IP Protocol 41?
IP Protocol 41 is one of the Internet Protocol numbers. Within the IPv4 header, the IPv4 Protocol field is set to 41 to indicate an encapsulated IPv6 packet.

>>>> It appears the G3100 does not function properly with protocol 41.

My expectation is that the G3100 should function at least as well as the G1100.

I realize when new equipment is deployed there exists a period of time during which issues are discovered and remediated.

I also am cognizant Verizon is deploying equipment that caters primarily to Joe and Mary and X consumers, not IT professionals.

I posted the issue within the Verizon Direct forum. As noted above I am publicly sharing this information.
« Last Edit: January 08, 2022, 01:36:36 PM by garrigan »
Logged