• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

IPv6 Stopped Working

Started by Ishipapiter, May 17, 2009, 05:42:50 PM

Previous topic - Next topic


I've had an IPv6 tunnel set up for quite some time now, and it's been working just fine. Recently it stopped working, and i can't connect to any ipv6 server.

I tried whatismyipv6.net and it gives me only my ipv4 address.
I also tried to ping "ipv6.google.com" with no luck. It shows [their ipv6] from my ipv6, but gives me 4 general failures.
"ipconfig /all" shows me the right setup for the IP6Tunnel adapter with the right ipv6 address. Deleting and re-setting up the adapter doesn't help.

Strangely, I set up a tunnel in Windows 7, and it worked fine (most of the time).

I'm pretty sure my firewall isn't causing the problem, and ICMP blocking isn't enabled in my router. What happened?!?!


I had the same problem.  With Alex Broque's help, I managed to get a proper tunnel working yesterday, and managed to work through to Guru certification  :)  and then last evening my tunnel quit abruptly and I've not been able to get it going again no matter what I try.  I have a v6->v4 tunnel from Hexago that works just fine, but it's somewhat slower and I'd really like to get my HE tunnel working again.  It looks as if the back end software for the tunnel broker UI may be a bit fusty.


There's gremlins hiding in it here and there from the old code.  I recode something and wake them up.  I think they're back to sleep for now, however.


Ah the dreaded software e-gremlins  :-[  -- feared by programmers everywhere.  I know them well.  They live in old, fusty code, especially Unix/Linux code, because mostly Unix code just works, even when its old and fusty - except when the gremlins get loose.  I'm going to have to give the HE tunnel a break and try again next week, giving you and others the opportunity to perform a proper exorcism.


Just FYI, it's still not working this morning.  ifconfig tells me:

sit1      Link encap:IPv6-in-IPv4 
          inet6 addr: 2001:470:1f0e:76::2/64 Scope:Global
          inet6 addr: fe80::a08:1/64 Scope:Link
          inet6 addr: fe80::d86e:c69/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:9566 (9.3 KiB)

Note the TX packet and RX packet counts.  These are ping6 packets sent to 2001:470:1f0e:76::1 which I'm told is the server v6 address.  Should I not be seeing these come back through the tunnel?


For some unfathomable reason, my tunnel profile with HE had the wrong v4 address for my end of the tunnel  ???   Once I fixed this, all is well.

My bad!!

[fmouse goes away to iron his hands]

Or is this something that perhaps the HE UI backend did?