Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Can't reach anything but endpoints  (Read 2789 times)

mattventura

  • Newbie
  • *
  • Posts: 1
Can't reach anything but endpoints
« on: November 28, 2009, 08:23:43 PM »

I configured my openWRT using the tutorial on the openWRT wiki, with this script:
#!/bin/sh /etc/rc.common
LOCALIP=71.231.208.248
POPIP=216.218.226.238
LOCTUN=2001:470:a:122::2
REMTUN=2001:470:a:122::1

START=50

start()
{
        echo -n "Starting  he.net IPv6 tunnel: "
        ip tunnel add he-ipv6 mode sit  remote $POPIP local $LOCALIP ttl 255
        ip link set he-ipv6 up
        ip link set mtu 1280 dev he-ipv6
        ip tunnel change he-ipv6 ttl 64

        ip -6 addr add $LOCTUN/64 dev he-ipv6
        ip -6 route add ::/0 dev he-ipv6
        ip -6 ro add default via $REMTUN dev he-ipv6
        ip -f inet6 addr
        echo "Done."
}
stop()
{
        echo -n "Stopping he.net IPv6 tunnel: "
        ip link set he-ipv6 down
        ip tunnel del he-ipv6
        echo "Done."
}
restart()
{
        stop
        start
}


Now, the tunnel worked fine until now. But starting a few hours ago, I can only ping the tunnel endpoints (2001:470:a::1 and ::2). If I traceroute6 from my server to something else it gets to my router, then to the endpoint, but then dies.


traceroute to www.kame.net (2001:200:0:8002:203:47ff:fea5:3085) from 2001:470:b:122:20a:5eff:fe77:bd47, 30 hops max, 16 byte packets
 1  2001:470:b:122::1 (2001:470:b:122::1)  0.501 ms  0.678 ms  0.589 ms
 2  mattventura-1.tunnel.tserv14.sea1.ipv6.he.net (2001:470:a:122::1)  60.005 ms  60.25 ms  59.503 ms
 3  * * *
 4  * * *
...
29  * * *
30  * * *


My IPv4 address is still the same, and I wasn't doing anything with the router at that time. Is this just an outage at the PoP or something?

Update: when I do a reverse DNS lookup on my tunnel's endpoints, I see two names: mattventura-1.tunnel.tserv14.sea1.ipv6.he.net and incdona-1.tunnel.tserv14.sea1.ipv6.he.net. Is this normal?
« Last Edit: November 28, 2009, 08:34:31 PM by mattventura »
Logged

broquea

  • Sr. Network Engineer, HE.NET AS6939
  • Administrator
  • Hero Member
  • *****
  • Posts: 1723
Re: Can't reach anything but endpoints
« Reply #1 on: November 28, 2009, 09:37:06 PM »

Needed to flush configuration issues out of the system, which restored
service.

Looks like the point-to-point /64 didn't get a proper rDNS scrubbing
from when it was de-allocated previously. I can remove the extra entries.
Logged