Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: tunnel doesn't work after an IPv4 change... how to solve?  (Read 6585 times)

AccessOne

  • Newbie
  • *
  • Posts: 4
tunnel doesn't work after an IPv4 change... how to solve?
« on: January 25, 2010, 06:12:25 AM »

Hi,

I'm behind a dynamic IPv4 (usually changes every 24h).
I change the IPv4 Endpoint via the HTTP-API and curl in the crontab.

however, everytime it changes the endpoint the tunnel breaks connection... or at least the IPv6-Endpoint is un-ping-able...

I also tried to shut down the sit0 and sit1 device and re-open the tunnel... but it won't work..

Any ideas how to solve it?
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2724
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #1 on: January 25, 2010, 06:20:09 AM »

Quote

I change the IPv4 Endpoint via the HTTP-API and curl in the crontab.

I assume that means that you've changed the IP address in the tunnel information page on the HE website?
Logged

AccessOne

  • Newbie
  • *
  • Posts: 4
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #2 on: January 25, 2010, 06:21:35 AM »

Well, I use this API:
Code: [Select]
https://ipv4.tunnelbroker.net/ipv4_end.php
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2724
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #3 on: January 25, 2010, 06:26:21 AM »

Gotcha.

I assume you've been able to change the tunnel information before and have it work properly?

If that's the case, we'll need some more information;  Can you post your routing tables and output of ifconfig -a ?
Logged

AccessOne

  • Newbie
  • *
  • Posts: 4
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #4 on: January 25, 2010, 06:30:36 AM »

dunno if it work properly... but I can change the Tunnel IPv4-Endpoint...
and I checked it with my current IP, its the same... so I asume the tunnel has been changed...


The info:

Code: [Select]
sit0      Link encap:IPv6-nach-IPv4 
          inet6-Adresse: ::13.37.0.3/96 Gültigkeitsbereich:Kompatibilität
          inet6-Adresse: ::127.0.0.1/96 Gültigkeitsbereich:Unbekannt
          inet6-Adresse: ::13.37.1.4/96 Gültigkeitsbereich:Kompatibilität
          UP RUNNING NOARP  MTU:1480  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:7 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

sit1      Link encap:IPv6-nach-IPv4 
          inet6-Adresse: 2001:470:23:102::2/64 Gültigkeitsbereich:Global
          inet6-Adresse: fe80::d25:3/64 Gültigkeitsbereich:Verbindung
          inet6-Adresse: fe80::d25:104/64 Gültigkeitsbereich:Verbindung
          UP PUNKTZUPUNKT RUNNING NOARP  MTU:1480  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2031 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:0 (0.0 B)  TX bytes:251844 (245.9 KiB)

Code: [Select]
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
13.0.0.0        *               255.0.0.0       U     0      0        0 eth0
13.0.0.0        *               255.0.0.0       U     0      0        0 eth1
default         13.37.0.1       0.0.0.0         UG    0      0        0 eth1
default         13.37.0.1       0.0.0.0         UG    0      0        0 eth0
Kernel-IPv6-Routentabelle
Destination                    Next Hop                   Flag Met Ref Use If
::/96                          ::                         Un   256 0     0 sit0
2001:470:23:102::/64           ::                         Un   256 0     0 sit1
fe80::/64                      ::                         U    256 0     0 eth0
fe80::/64                      ::                         U    256 0     0 eth1
fe80::/64                      ::                         Un   256 0     0 sit1
::/0                           ::                         U    1   0     0 sit1
::/0                           ::                         !n   -1  4343757 lo
::1/128                        ::                         Un   0   3   689 lo
::13.37.0.3/128                ::                         Un   0   1     0 lo
::13.37.1.4/128                ::                         Un   0   1     0 lo
::127.0.0.1/128                ::                         Un   0   1     0 lo
2001:470:23:102::/128          ::                         Un   0   1     0 lo
2001:470:23:102::2/128         ::                         Un   0   1     0 lo
fe80::/128                     ::                         Un   0   1     0 lo
fe80::/128                     ::                         Un   0   1     0 lo
fe80::/128                     ::                         Un   0   1     0 lo
fe80::d25:3/128                ::                         Un   0   1     0 lo
fe80::d25:104/128              ::                         Un   0   1     0 lo
fe80::20c:29ff:fe3e:470e/128   ::                         Un   0   1     0 lo
fe80::20c:29ff:fe3e:4718/128   ::                         Un   0   1   292 lo
ff00::/8                       ::                         U    256 0     0 eth0
ff00::/8                       ::                         U    256 0     0 eth1
ff00::/8                       ::                         U    256 0     0 sit1
::/0                           ::                         !n   -1  4343757 lo
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2724
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #5 on: January 25, 2010, 06:34:44 AM »

Did the tunnel ever work with the current set up (Before your IPv4 address changed?)
Logged

AccessOne

  • Newbie
  • *
  • Posts: 4
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #6 on: January 25, 2010, 06:38:58 AM »

yes sure... thats why I wonder... coz even when I reboot it won't work :S
Logged

wicked0ne

  • Newbie
  • *
  • Posts: 1
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #7 on: August 13, 2010, 09:04:22 PM »

Im also suffering from this...only if i reboot it solves the issue. Im using freebsd7.3 and ipv6 works great up until my ipv4 ip changes. In my router running tomato firmware its setup to update dynamic ip services when a my wan ip changes....and i have manually logged into my HE account and verified that indeed my endpoint ip has been updated....would love to hear any ideas on what i can do to bring my tunnel back up without having to reboot....in my case rebooting my server is a major major pain in the butt.

Code: [Select]
ifconfig -a
bge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
        ether 00:11:11:a3:ac:03
        inet6 fe80::211:11ff:fea3:ac03%bge0 prefixlen 64 scopeid 0x1
        inet 192.168.5.50 netmask 0xffffff00 broadcast 192.168.5.255
        inet6 2001:470:XXXX:XXX::1 prefixlen 64
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
plip0: flags=108810<POINTOPOINT,SIMPLEX,MULTICAST,NEEDSGIANT> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
        inet 127.0.0.1 netmask 0xff000000
gif0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1280
        tunnel inet 192.168.5.50 --> 209.51.161.14
        inet6 fe80::211:11ff:fea3:ac03%gif0 prefixlen 64 scopeid 0x4
        inet6 2001:470:XXXX:144::2 --> 2001:470:1f06:144::1 prefixlen 128
        inet6 2001:470:XXXX:XXXX:beef:beef:beef:50 prefixlen 64
        inet6 2001:470:XXXX:XXXX:beef:beef:beef:51 prefixlen 64       
        options=1<ACCEPT_REV_ETHIP_VER>


Code: [Select]
netstat -nr
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            192.168.5.1        UGS         0  1241135   bge0
127.0.0.1          127.0.0.1          UH          0     8089    lo0
192.168.5.0/24     link#1             UC          0        0   bge0
192.168.5.1        00:1d:7e:53:9c:10  UHLW        2        0   bge0   1173
192.168.5.10       00:30:67:26:a6:5f  UHLW        1     1607   bge0    920
192.168.5.20       00:1a:92:59:69:1a  UHLW        1      159   bge0   1000
192.168.5.50       00:11:11:a3:ac:03  UHLW        1   469475    lo0
192.168.5.255      ff:ff:ff:ff:ff:ff  UHLWb       1     1931   bge0

Internet6:
Destination                       Gateway                       Flags      Netif Expire
::/96                             ::1                           UGRS        lo0 =>
default                           2001:470:XXXX:144::1          UGS        gif0
::1                               ::1                           UHL         lo0
::ffff:0.0.0.0/96                 ::1                           UGRS        lo0
2001:470:XXXX:144::1              link#4                        UHL        gif0
2001:470:XXXX:144::2              link#4                        UHL         lo0
2001:470:XXXX:XXXX::/64           link#4                        UC         gif0
2001:470:XXXX:beef:beef:beef:beef:50 link#4                        UHL         lo0
2001:470:XXXX:beef:beef:beef:beef:51 link#4                        UHL         lo0
2001:470:XXXX:dead::/64           link#1                        UC         bge0
2001:470:XXXX:dead::1             00:11:11:a3:ac:03             UHL         lo0
2001:470:XXXX:dead:21a:92ff:fe59:691a 00:1a:92:59:69:1a             UHLW       bge0
fe80::/10                         ::1                           UGRS        lo0
fe80::%bge0/64                    link#1                        UC         bge0
fe80::211:11ff:fea3:ac03%bge0     00:11:11:a3:ac:03             UHL         lo0
fe80::21a:92ff:fe59:691a%bge0     00:1a:92:59:69:1a             UHLW       bge0
fe80::%lo0/64                     fe80::1%lo0                   U           lo0
fe80::1%lo0                       link#3                        UHL         lo0
fe80::%gif0/64                    link#4                        UC         gif0
fe80::211:11ff:fea3:ac03%gif0     link#4                        UHL         lo0
ff01:1::/32                       link#1                        UC         bge0
ff01:3::/32                       ::1                           UC          lo0
ff01:4::/32                       link#4                        UC         gif0
ff02::/16                         ::1                           UGRS        lo0
ff02::%bge0/32                    link#1                        UC         bge0
ff02::%lo0/32                     ::1                           UC          lo0
ff02::%gif0/32                    link#4                        UC         gif0

Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2724
Re: tunnel doesn't work after an IPv4 change... how to solve?
« Reply #8 on: August 14, 2010, 06:24:28 AM »

if your tunnel is hosted on your router, why would you need to reboot your server?
Logged