• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.


Welcome to Hurricane Electric's Tunnelbroker.net forums!

Main Menu

Tunnel Problems

Started by Thumper, February 17, 2011, 09:22:15 AM

Previous topic - Next topic



I am having trouble setting an ipv6 tunnel on Win7 x64. I created a tunnel on this site and set up the tunnel using netsh using the commands provided (all commands worked fine).

I set up a DMZ because my router cannot forward Protocol 41 and turned off the windows firewall. Open ports are visible from outside.

I can ping the server ipv4 fine.

What could the problem be?


Could be a bunch of things...what commands did you use to create the tunnel?  Is your ISP passing you protcol41?


I used these commands:

netsh interface teredo set state disabled
netsh interface ipv6 add v6v4tunnel IP6Tunnel << MYIPV4 >>
netsh interface ipv6 add address IP6Tunnel 2001:470:1f12:65b::2
netsh interface ipv6 add route ::/0 IP6Tunnel 2001:470:1f12:65b::1

I can see the tunnel by entering "netsh interface ipv6 show interfaces" and IP6Tunnel is in "Disconnected" state.

I have no idea if my isp forwards Protocol 41, I will call them...



Are you behind nat?  If so, you need to use your nat address to create the tunnel


I am behind NAT, but my PC is in DMZ. I can see any open ports from outside just fine.


OK, but does "MYIPV4" = 192.168.something?  Since you didn't put that IP in, I have no way of knowing


It is my external IP (195.158.*.*) not my internal IP given by my router's DHCP server (


That's one reason why it's not working

Use the instead of the 195 address


Should i use local IP even though I'm using DMZ?

I tried to create a new tunnel as follows:

netsh interface teredo set state disabled

Gave me ok

netsh interface ipv6 add v6v4tunnel TheTunnel

Gave me ok

netsh interface ipv6 add address TheTunnel 2001:470:1f12:65b::2

Gave me object already exists

netsh interface ipv6 add route ::/0 TheTunnel 2001:470:1f12:65b::1

Gave me ok

When I type netsh interface ipv6 show interface: I get TheTunnel state as "Connected".

However still no ipv6.


Yes you still need to use the nat address.  Also, i am almost positive that the name of the adapter needs to be ip6tunnel, the same way it's listed on your tunnel config page