Hurricane Electric's IPv6 Tunnel Broker Forums

Advanced search  

News:

Welcome to Hurricane Electric's Tunnelbroker.net forums!

Author Topic: Trouble with IPv6 Dig Test (forward lookup)  (Read 4084 times)

bgvaughan

  • Newbie
  • *
  • Posts: 2
Trouble with IPv6 Dig Test (forward lookup)
« on: July 26, 2010, 11:17:11 AM »

For most hostnames I test, perhaps nine out of ten, when I submit the response from a forward lookup via dig, I get this message:

"Sorry, you've already submitted a dig query to the same destination"

I've been using a list of hostnames I got from ipv6.loercks.net, and filtered through a script that ping6'ed them and returned a list of live hostnames. I've only successfully submitted thirteen so far; it seems unlikely to me that I've come across several hundred aliases for those few.

Is there a glitch in the script that tests whether a dig response has been submitted before, or is there something else going on that I'm missing?
Logged

patrickdk

  • Jr. Member
  • **
  • Posts: 67
Re: Trouble with IPv6 Dig Test (forward lookup)
« Reply #1 on: July 26, 2010, 11:39:56 AM »

If I remember correctly, I think it looks for ip's within the same netblock, so generally within the same /64 won't count.

On my list I filtered out all entries that returns results in the same /64 before I submit them.

If not just for the dig results, this will drastically affect the whois lookup for an ip block also. So filtering based on a /48 or /32 would help fix this also.

(It has been a few months, so my memory on how this worked could be inaccurate).
Logged

cholzhauer

  • Hero Member
  • *****
  • Posts: 2724
Re: Trouble with IPv6 Dig Test (forward lookup)
« Reply #2 on: July 26, 2010, 05:03:11 PM »

I think you're right.  Iirc it keeps track of the /48
Logged