• Welcome to Hurricane Electric's IPv6 Tunnel Broker Forums.

certification - stuck in tunneling

Started by tallis, January 06, 2011, 08:07:15 AM

Previous topic - Next topic



I'm stuck in the second part of the ipv6 certification
I setup a Native IPv6 or Tunneled IPv6 using a Tunnelbroker using my ip then i run the linux-route2 commands succesfully.

But when i click on the next link that tests my ipv6 connection it responts that

Your reported Internet Protocol Address is: 109.242.x.y

You do not appear to be using an IPv6 capable connection, why not setup a tunnel from Tunnelbroker.net

maybe it has something to do with my asdl router???
any idea?


Are you sure your tunnel is working properly?  Did you assign an address out of your routed /64 to your ethernet adapter?


I think

this is the output of ifconfig

he-ipv6   Link encap:IPv6-in-IPv4 
          inet6 addr: 2001:470:25:307::2/64 Scope:Global
          inet6 addr: fe80::6df2:c4c5/128 Scope:Link
          UP POINTOPOINT RUNNING NOARP  MTU:1480  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:152 dropped:0 overruns:0 carrier:152
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


I would say "no"

  RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Is your router/firewall passing protocol 41 traffic to you?

Are you behind a NAT?  If so, did you change the commands you entered to reflect that?


Yes I am behind a NAT

and i didn't make any changes to my router setup (port forwarding rules)

Where can i find instructions?

Do i have to forward port 41 from the router to my pc???


port != protocol.

Lets start by changing the commands you used to create the tunnel.

Remove the tunnel adapter.

Re-create the tunnel like you did last time, except this time, use 192.168.x.x (whatever your nat'd address is)

Try again

If it doesn't work, add your machine to the DMZ in your firewall or allow all traffic to it


ok.. i'll try that and report back

thanks for the Xtra fast response time


when i enter my internal address :

Error: That IPv4 endpoint has been blocked (RFC1918 Private Address Space)


I've done it

i used the

ifconfig  (linux-net-tools) commands instead of the ip (linux-route2) commands
and it worked perfectly

i used my routers public address

Thanks for the help!!


Glad to hear it.

In case someone else stumbles across this....you need to use your public address when you enter the address on HE's site and you need to use your NAT address when you enter the route2 commands in linux (substitute your NAT address for the public address)